-   Slackware (
-   -   libreoffice3.3.2 printing problem in SW13.37 (

worsel 05-21-2011 11:19 PM

libreoffice3.3.2 printing problem in SW13.37
After installing libre3.3.2 using the Slackbuild scripts, I found that it displayed
fonts correctly, but doesn't print the same font on the printer. The output of the
printer should be Arial, but is instead some elongated, overlapping mess.

The same Slackware package installed on SW13.1 prints normally. (Same computer,
different partition)

Spadmin used to control the printer fonts, but apparently not anymore. Anyone have
an idea about how to troubleshoot/correct this problem?

TIA, John

System: Linux nadrek #2 SMP Sat Apr 9 23:39:07 CDT 2011 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 4800+ AuthenticAMD GNU/Linux.

willysr 05-21-2011 11:53 PM

Try using AlienBOB's LibreOffice package

worsel 05-22-2011 12:37 AM

libreoffice3.3.2 printing problem in SW13.37
Tried AlienBOB's LibreOffice package. No change. :(
Thank's for the suggestion though. Guess I'll put it away for
today and try again tomorrow. Y'all have a good night!


willysr 05-22-2011 03:29 AM

try exporting it to PDF and then print the PDF file

markush 05-22-2011 04:15 AM


Originally Posted by worsel (Post 4363372)
... Anyone have an idea about how to troubleshoot/correct this problem?...

Did you check if this issue occurs only with the Arial-font or if it is a problem with any font?

As willysr suggested, print the file into pdf and then check if you have the issue with the font even in pdf, check it on the screen and on the printed paper.


worsel 05-22-2011 10:27 AM

It occurs with any font.

Exported as pdf and the resultant file displays and prints correctly.

Printed to a file, the resultant .ps file displays correctly, but prints badly.

This confuses me. Shouldn't the same mechanism be producing both files? They
are, after all, just variations of postscript.


markush 05-22-2011 10:36 AM

Well, I would assume that the problem is anywhere "between" the fonts and cups (or between libreoffice and cups).
Since after exporting the file to pdf everything works fine, it seems unlikely that the fonts (alone) are the problem.
Otherwise if you print the odt-file directly with cups, either to a file or to the printer, the issue remains the same.


Edit: I'm running the LibreOffice-3.3.2 package from AlienBob on Slackware64-13.37 and I don't have any problems.

worsel 06-05-2011 11:07 PM

Since my last post, much, hmmmm.... water .... has gone over the dam. For one thing, I
have a new computer, the old one having gone belly-up. Still have the same problem, though. :(

To correct my previous post, if I export to a pdf file, the file displays properly and prints
properly, sometimes. Envelopes and spreadsheets always print with that strange font. Normal
pages of text seem to be all right most of the time.

I suspect ghostscript-9.00 is the culprit, as I can substitute everything else from SW13.1 into
my system without change. Unfortunately ghostscript-8.71 won't run under SW13.37, even if compiled
therein. (Haven't really looked at why yet.)

Because this has now happened on two different machines, I am really surprised that no one else seems
to have had this problem. I have reinstalled SW13.37 from two different sources, one an iso I downloaded
myself and the other the cd's from my subscription. I have also recompiled, repackaged, and reinstalled
everything that seems to affect printing from the source files. None of this has had any effect on
the problem.

Well, I'll keep working on it. If anyone has a flash of brilliance, let me know.


markush 06-06-2011 12:10 AM

Which printer are you using? Make and Model? did you install any proprietary printerdrivers?


kingbeowulf 06-06-2011 12:24 AM

I tend to prefer HP printers under Linux and have good results with them. You didn't say what printer you are using. I do not use gutenprint. I currently use HP laserjet M1212nf (TCP/IP) and HP Deskjet 990Cm (USB) via hplip and a HP Laserjet 6MP (TCP/IP via D-Link parallel-ethernet dongle). Hplip sets up CUPS and the HP 6MP I set up via CUPS. I don't select the ghostscript version of the drivers but rather the hpxxx.ppd versions. No issues printing from the sbo built Libreoffice.

From your brief information, I would suspect the wrong, or a bad, printer driver, a a misconfigured CUPS (ie via hplip)

willysr 06-06-2011 08:15 AM

So far, i have no problem with Canon printers :)

allend 06-06-2011 08:29 AM

Are you using file-5.05?

You could try upgrading to file-5.07 in slackware-current.

worsel 06-11-2011 10:38 PM

OK, Back at it. I've been busy the last week, without much spare time. Ever notice how
life keeps getting in the way of important things? :)

To answer previous posts: My printer is an Epson Stylus CX5000. I use the Gutenprint driver,
which has worked well for several years. My new computer uses an ASUS M4A78LT-M motherboard
with 4 gig of ram. Uname-a gives this info: "Linux nadrek #2 SMP Sat Apr 9 23:39:07
CDT 2011 i686 AMD Athlon(tm) II X2 245 Processor AuthenticAMD GNU/Linux"

There are two hard drives. One, of 320 GB, is formatted into a number of partitions, the first of
which is my Slackware 13.37 partition and the second, SW 13.1. I am currently running 32 bit versions.
The second hard drive (500 GB) is mounted as /home.

I did try file 5.07. No happiness, the condition persists. Other than the above, I can't add much
to my last post.

Thanks for the ideas/comments,

markush 06-12-2011 01:28 AM

Referring to this: your printer should work fine with Linux (as it did with older versions of Slackware).

I found this paper: which describes how to install Epson-printers with cups.

Did you try to install the printer with cups w/o any other drivers? as you know for cups you'll only need an appropriate ppd-file.


arubin 06-12-2011 08:03 AM

With regard to file 5.07 when I had my printing problem I did not find that upgrading to file 5.07 helped. I had to downgrade to file 5.04.

All times are GMT -5. The time now is 05:08 PM.