LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   LibreOffice will not start and freezes KDE5 on slackware64-current (https://www.linuxquestions.org/questions/slackware-14/libreoffice-will-not-start-and-freezes-kde5-on-slackware64-current-4175668404/)

doteer 01-25-2020 06:35 AM

LibreOffice will not start and freezes KDE5 on slackware64-current
 
Hello, i have been using slackware 14.2 for couple of years now, never had any problems (that i didn't cause) but recently got a new laptop (AMD Ryzen 5 3500u) and decided to try slackware64-current. I did clean install today and installed kde5 as well. As it is required, i installed openjdk too (got it from here https://slackware.nl/people/alien/sl...pkg64/current/) using upgradepkg and i did the same with libreoffice (http://www.slackware.com/~alien/slac.../pkg64/current). However upon running libreoffice command in terminal (as user) my KDE froze and terminal for short period of time displayed these two lines:
Code:

bash-5.0$ libreoffice
mesa: for the --simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the --global-isel-abort option: may only occur zero or one times!

That's it after this i have to force shut down my pc. Also i tried libreoffice5.4 (https://slackware.pkgs.org/current/s...lonly.txz.html) but the result was the same, only lines it displayed upon running are:
Code:

bash-5.0$ libreoffice5.4
javaldx: Could not find a Java Runtime Enviroment!
Warning: failed to read path from javaldx

Does anyone know what the problem is? LibreOffice and openjdk installation went without issues. I googled a lot and couldn't find solution.

cwizardone 01-26-2020 03:23 AM

You might wnat to post this on AlienBob blog under "your feedback."

https://alien.slackbook.org/blog/

Also, you might consider asking a moderator to move this thread to the Slackware forum.
:)

doteer 01-26-2020 04:31 AM

Thank you for your reply and i shall do both. I have a (silly) question about moving thread. How do i do that? I read that i have to report it but i can't find report button. Only got Edit, Quote and Multi-quote.

doteer 03-13-2021 01:31 PM

I found solution to this problem.
Just disable openCL using libreoffice safe mode.
https://wiki.archlinux.org/index.php...zes_or_crashes
And this was not KDE issue, it didn't work for any DE, so i think this could be amd gpu related issue atm.


All times are GMT -5. The time now is 03:37 PM.