LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-06-2018, 05:39 PM   #1
Slackovado
Member
 
Registered: Mar 2005
Location: BC, Canada
Distribution: Slackware 14.2 x64
Posts: 284

Rep: Reputation: 57
libreoffice menu font too small


I've already adjusted qt settings which fixed VLC menu fonts.
But the Libreoffice menu font remains small (last 2 or 3 versions I've installed).
Currently I'm on version 5.4.5.1 and it's built from Slackbuilds, from the one that builds from the binary distributed.
Some posts on the net suggest that libreoffice-gtk package fixed it for them.
Any suggestions?
Thanks
 
Old 03-06-2018, 08:23 PM   #2
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 4,111
Blog Entries: 1

Rep: Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420
is this in kde-4?

I've had the same problem with several applications when running them in kde-4, but not when when using Xfce.
And, yes, oxygen-gtk2-1.4.6.1-x86_64-1alien.txz, is installed.
It does seem to a recent problem, but as I bounce back and forth between Xfce and kde-4, in -current, I can't pinpoint when it started.

Last edited by cwizardone; 03-06-2018 at 08:31 PM.
 
Old 03-07-2018, 01:54 AM   #3
Slackovado
Member
 
Registered: Mar 2005
Location: BC, Canada
Distribution: Slackware 14.2 x64
Posts: 284

Original Poster
Rep: Reputation: 57
Quote:
Originally Posted by cwizardone View Post
is this in kde-4?

I've had the same problem with several applications when running them in kde-4, but not when when using Xfce.
And, yes, oxygen-gtk2-1.4.6.1-x86_64-1alien.txz, is installed.
It does seem to a recent problem, but as I bounce back and forth between Xfce and kde-4, in -current, I can't pinpoint when it started.
I don't use KDE, don't even have it installed except a few libs needed to run K3B.
I use Xfce and don't have oxygen-gtk2 installed (what is it for?).
 
Old 03-07-2018, 09:07 AM   #4
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 4,111
Blog Entries: 1

Rep: Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420
Quote:
Originally Posted by Slackovado View Post
I don't use KDE, don't even have it installed except a few libs needed to run K3B.
I use Xfce and don't have oxygen-gtk2 installed (what is it for?).
Since you are not running kde you don't need it, but to answer your question here is the readme file from Alien Bob's package:

Quote:
oxygen-gtk2 (Oxygen GTK+ engine)
Oxygen-Gtk2 is a port of the KDE widget theme Oxygen, to GTK+.
It's primary goal is to ensure visual consistency between GTK+ and
qt-based applications running under kde. A secondary objective is
to also have a stand-alone nice looking GTK+ theme that would behave
well on other Desktop Environments.
Unlike other attempts made to port the kde oxygen theme to GTK+, this
attempt does not depend on Qt.
See: http://projects.kde.org/projects/pla...ork/oxygen-gtk
 
Old 03-08-2018, 05:03 AM   #5
Slackovado
Member
 
Registered: Mar 2005
Location: BC, Canada
Distribution: Slackware 14.2 x64
Posts: 284

Original Poster
Rep: Reputation: 57
I have installed the oxygen-gtk2 and for a while I had the right font size in qt apps like VLC and Libreoffice menus.
But it totally screwed up my theme and colors, title bars in bright blue color - FUBARED!
But now my fonts are small in all qt apps which leads me to suspect the problem is also with Slackware.
Qt config does not save the font size!
I'm pissed and give up for now.
 
Old 07-11-2018, 07:59 PM   #6
MrNone
LQ Newbie
 
Registered: Aug 2009
Posts: 1

Rep: Reputation: 0
I cause this problem occasionally by playing around in Ubuntu settings
I'm on 16.04 now, but it happened on previous releases.
It is NOT a Libre Office problem.
Go to Settings/Appearance/Behavior
Show the menus for a window
Choose
In the window's title bar
That's it. We're done. Enjoy.
________________
Ptero the Pterosoar

Last edited by MrNone; 07-11-2018 at 08:01 PM. Reason: Can't spell my name
 
  


Reply

Tags
libreoffice, menu fonts


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] LibreOffice is occasionally switching the font as I type Gregg Bell Linux - Newbie 4 07-29-2015 09:45 PM
LibreOffice menu micder Slackware 5 12-02-2014 03:31 PM
LXer: Better font support in LibreOffice on Fedora LXer Syndicated Linux News 0 09-15-2014 01:50 PM
LibreOffice: saving file as odg and adjusting the font in Draw. JosephS Linux - Software 0 01-23-2012 09:21 PM
[SOLVED] Small "?" next to font in xlib font used as a graphic sbauer72 Programming 1 03-29-2011 01:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration