-   Slackware (
-   -   LibreOffice, -current, and slow dialogs (

marnold 10-19-2013 12:02 PM

LibreOffice, -current, and slow dialogs
I have AlienBob's LibreOffice package installed in -current. The dialogs are extremely slow. I particularly notice this in the file manager dialogs. If I click on a directory, it can take 5-10 seconds to switch to it. gkrellm is not reporting any CPU spikes or anything. It seems like it starts out OK and then it gets progressively slower. I don't know if there's a memory leak or what. One time, it even crashed to the desktop.

I may try to dig up an older version and see if it still does that. Thankfully, I still have my copy of 4.0.5 which I know did not show this problem in 14.0.

Alien Bob 10-19-2013 03:12 PM

I just checked here, LibreOffice on Slackware64-current. Dialogs are fast as usual, I see nothing strange. The issue is somewhere on your computer.


chrisretusn 10-19-2013 06:20 PM

I've been using Eric's LibreOffice on Slackware-current since I upgraded it on Oct 9th, working fine here.

marnold 10-19-2013 07:22 PM

I'll have to test it some more. It didn't take me long to discover it. I've reverted to 4.0.5. I won't be using LibreOffice much until Monday, but I'll report back. It's odd because it's like it makes all of KDE unresponsive. The mouse still moves, but I can't click on anything. If 4.0.5 shows the same thing, then the next place I'm going to look is my NVIDIA driver because I upgraded that.

FWIW, I had been running AlienBob's KDE 4.10.5 in 14.0, so there shouldn't have been any new KDE-related weirdness. I do know that LibreOffice's file manager dialogs often got wonky before. I assume that was because of odd KDE integration.

aikempshall 10-26-2013 04:28 AM

I have the same problem with unresponsive dialog on -


# md5sum libreoffice-4.1.2-i486-1alien.txz
67d528100f74b7d238cc5aa583cf6ece  libreoffice-4.1.2-i486-1alien.txz

Also with forms in base where it looks like I've opened two instances of the same form, they overlap and are offset by about 1cm on my screen. After about 5-10 seconds it resolves itself. Looks quite scary while it's happening.

Firstly I thought it might be because it had been compiled against 14.1, so I downloaded the sources from AlienBob and compiled on my machine, same problem.

Need to add, my machine is 10 years old with a Pentium IV, haven't seen this problem before.


519 /home/alex$ lscpu
Architecture:          i686
CPU op-mode(s):        32-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:  0,1
Thread(s) per core:    2
Core(s) per socket:    1
Socket(s):            1
Vendor ID:            GenuineIntel
CPU family:            15
Model:                2
Stepping:              9
CPU MHz:              3006.937
BogoMIPS:              6012.52
520 /home/alex$


ReaperX7 10-26-2013 11:18 AM

Are you using LibreOffice with or without Java?

aikempshall 10-26-2013 02:34 PM

The problems seem to be stacking up for me!

Not quite sure if I should start a separate thread.

I use base quite a bit so I guess I use java. Anyway under

Tools -> Options -> Libreoffice -> Advanced

I have "Use a Java run time environment" ticked -

On 14.0 I have a choice of two

Oracle Corporation 1.7.0-10
Free Software Foundation 1.5.0

Using both, I ran a query that I run on a regular basis which took about 10 seconds, the memory usage for the Oracle JRE is quite small but for FSF its about 200MB.

On the basis of AlienBob's remark -


LibreOffice 4.1.2 packages for Slackware can now be obtained from my 14.0 package repository – they will work on Slackware-current just as well. Note that there are now additional “libreoffice-dict-<language>” packages!

I thought I'd try it on 14.1 -

Tools -> Options -> Libreoffice -> Advanced

I have "Use a Java run time environment" ticked -

On 14.1 I have a choice of one

Free Software Foundation 1.5.0

I ran exactly the same query on the same data and it took about 5 minutes and consumed about 200MB of memory.

Ran it again and it took another 5 minutes and another 200MB of memory.

By the 9th attempt swap space was started to be written to heavily.

So I went back to 14.0 and ran consecutive tests on the same query, the effect on memory was not cumulative and compared with 14.1 blistering fast in fact 30 times faster!

I wonder what's going on?

I installed OpenOffice, on 14.1, for the hell of it. Though I didn't run the same test it appeared to show the same problems as LibreOffice.

Though I will test that again.



marnold 10-26-2013 05:09 PM


Originally Posted by ReaperX7 (Post 5052724)
Are you using LibreOffice with or without Java?

I have no Java installed, currently.

I reinstalled 4.1.2 to see if it was just a problem with the installation (somehow). Unfortunately, the problems came up again. Sometimes when navigating through the file manager, it will get so bad that it will crash to the desktop. I recovered my document, not realizing it wasn't truly saved. Unfortunately, I lost about 1/2 hour's worth of work. Grr.

I'm back on 4.0.5. I didn't spend much time with it before, so I'll have to see if the same problems resurface.

FWIW, I did upgrade my NVIDIA binary driver (in case it was some 2D weirdness) but the same problems happened.

Nh3xus 10-26-2013 07:18 PM


I do have this problem as well on -current.

I'm using the 3.10.5 smp kernel from Pat along with the 304.88 Nvidia drivers.

Here's the list of packages I use :



I did upgrade my Xorg packages to the latest ones proposed by Pat, but still no joy.

aikempshall 10-27-2013 04:54 AM

I've solved my slow running sql in 14.1 by installing the java sdk jdk-7u40 and choosing either the Oracle Corporation 1.7.0-10 of Free Software Foundation runtime in Tools -> Options -> Libreoffice -> Advanced.

So back to the initial problem of slow dialogs. My symptoms also appear on 14.1.

For instance, this example from 14.1, on a spreadsheet with a large amount of data in it

Start Calc with a spreadsheet that contains 60 rows and 80 columns with each cell filled with numeric data.

Select a block of cells

right click

Select Format Cells

The Format Cells dialogue displays but it is transparent with only the dialogue border visible and the options in the Format ListBox visible.

Wait to see if it resolves itself - it doesn't

Click on the format option -1234.12 and the dialogue then renders itself and everything is as it should be.

Move to another application i.e. Firefox

Back to Calc the Format Cells dialogbox is transparent with only the dialogue border visible, this time none of the options are visible.

Wait to see if it resolves itself - it doesn't

Click randomly within the border of the dialogbox until it renders itself.


marnold 10-31-2013 04:56 PM

Well, I've been using LibreOffice all day and have not run into the problems with the file manager dialogs. Guess I'll be staying here until further notice.

aikempshall 11-01-2013 04:34 AM

I've downloaded the rpms and packaged them using a hacked slackbuild from and not had a repeat of the problem - admittedly only tested this on current though I did have the same problem on both 14.0 and current.

When I get time, I will back that out the RPM version and reinstall AlienBobs to see what happens.

I always used to use the SlackBuilds version, but about a year or so ago I moved over to AlienBobs version, can't remember exactly why, but by failing memory says it was a problem I encountered and something I read.


wsanders 12-07-2013 09:44 PM

Slow in FC19 too
Dialogs are very slow in FC19 ( build) as well. It's not CPU or disk bound, sometimes it's fast, sometimes it takes 15 - 20 sec before the dialog can be activated. Some kind of caching ....

I have a Haswell CPU too, and the dialogs would crash LO nearly every time. This seems to be an Intel GPU driver issue, turning off font antialiasing seems to have fixed that.

enine 12-09-2013 10:23 AM

I'm seeing the same issue. Slackware 14.1 LO 4.0.x from Alien BOB is fine 4.1.x is slow in places, very noticeable is the print dialog. I posted a thread a week or to ago and basically got the response that its my computer but that doesn't explain why 4.0.x is fine.

ljb643 12-09-2013 08:13 PM

No problem with LibreOffice 4.1.3 on Slackware 14.1 here, using relatively old hardware. No delay on dialogs. But I downloaded from myself (and converted from RPM).

All times are GMT -5. The time now is 01:13 AM.