LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-06-2018, 07:43 PM   #31
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,382

Rep: Reputation: 3151Reputation: 3151Reputation: 3151Reputation: 3151Reputation: 3151Reputation: 3151Reputation: 3151Reputation: 3151Reputation: 3151Reputation: 3151Reputation: 3151

What mirror do you have selected in slackpkg? Maybe it is incomplete/out-of-date?
 
Old 10-06-2018, 08:10 PM   #32
Hooks123
Member
 
Registered: Aug 2014
Posts: 55

Original Poster
Rep: Reputation: 3
im using the http://spout.ussg.indiana.edu/linux/...are64-current/ mirror. I think it is good because the latest update in the change log is

Fri Oct 5 22:43:41 UTC 2018
ap/mariadb-10.3.10-x86_64-1.txz: Upgraded.
d/python-pip-18.1-x86_64-1.txz: Upgraded.
x/libinput-1.12.1-x86_64-1.txz: Upgraded.
x/mesa-18.2.2-x86_64-1.txz: Upgraded.

and my version of libinput is 1.12.1

Last edited by Hooks123; 10-06-2018 at 08:47 PM.
 
Old 10-07-2018, 08:39 PM   #33
Hooks123
Member
 
Registered: Aug 2014
Posts: 55

Original Poster
Rep: Reputation: 3
im just going to use Calligra as much as i hate it. lol. I've tried to install libreoffice using sbopkg also and it gets the same errors.

Thanks for all the help. I appreciate it.

Last edited by Hooks123; 10-07-2018 at 09:39 PM.
 
Old 10-09-2018, 07:08 AM   #34
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 702
Blog Entries: 1

Rep: Reputation: 610Reputation: 610Reputation: 610Reputation: 610Reputation: 610Reputation: 610
I got a similar error when I first started Eric's new builds of LO. Unhelpfully enough, I can't remember exactly what it said now - something about Java being defective. Still, LO did load after I clicked the message away. I've since started LO a few times, logged out/in and tried again, and got no error messages via shortcuts or the terminal. No idea what that was about now.

EDIT: it was this - "LibreOffice requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - LibreOffice - Java."

Like I say, it's gone now.

Last edited by Lysander666; 10-09-2018 at 07:09 AM.
 
Old 10-09-2018, 07:50 AM   #35
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,391

Rep: Reputation: Disabled
The op's current issue is llvm, not java.
 
Old 10-09-2018, 03:15 PM   #36
Hooks123
Member
 
Registered: Aug 2014
Posts: 55

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by orbea View Post
The op's current issue is llvm, not java.
I tried loading llvm using sbopkg. I got the following error after 95% processing.


Code:
/tmp/SBo/qt-creator-llvm-5.0.1_427ad76/include/llvm/Support/Allocator.h:247:33:   required from ‘void* llvm::BumpPtrAllocatorImpl<AllocatorT, SlabSize, SizeThreshold>::Allocate(size_t, size_t) [with AllocatorT = llvm::MallocAllocator; long unsigned int SlabSize = 4096; long unsigned int SizeThreshold = 4096; size_t = long unsigned int]’
/tmp/SBo/qt-creator-llvm-5.0.1_427ad76/include/llvm/Support/YAMLParser.h:130:42:   required from here
/tmp/SBo/qt-creator-llvm-5.0.1_427ad76/include/llvm/ADT/SmallVector.h:309:11: warning: ‘void* memcpy(void*, const void*, size_t)’ writing to an object of type ‘struct std::pair<void*, long unsigned int>’ with no trivial copy-assignment; use copy-assignment or copy-initialization instead [-Wclass-memaccess]
     memcpy(this->end(), &Elt, sizeof(T));
     ~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from /usr/include/c++/8.2.0/utility:70,
                 from /usr/include/c++/8.2.0/algorithm:60,
                 from /tmp/SBo/qt-creator-llvm-5.0.1_427ad76/include/llvm/ADT/STLExtras.h:20,
                 from /tmp/SBo/qt-creator-llvm-5.0.1_427ad76/tools/lli/OrcLazyJIT.h:18,
                 from /tmp/SBo/qt-creator-llvm-5.0.1_427ad76/tools/lli/lli.cpp:16:
/usr/include/c++/8.2.0/bits/stl_pair.h:198:12: note: ‘struct std::pair<void*, long unsigned int>’ declared here
     struct pair
            ^~~~
make[2]: *** [tools/lli/CMakeFiles/lli.dir/build.make:63: tools/lli/CMakeFiles/lli.dir/lli.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:62495: tools/lli/CMakeFiles/lli.dir/all] Error 2
make: *** [Makefile:152: all] Error 2

qt-creator-llvm:
Would you like to continue processing the rest of the
queue or would you like to abort?  If this failed
package is a dependency of another package in the queue
then it may not make sense to continue.
 
Old 10-09-2018, 03:28 PM   #37
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,262

Rep: Reputation: 5377Reputation: 5377Reputation: 5377Reputation: 5377Reputation: 5377Reputation: 5377Reputation: 5377Reputation: 5377Reputation: 5377Reputation: 5377Reputation: 5377
Quote:
Originally Posted by orbea View Post
The op's current issue is llvm, not java.
It may not be llvm but mesa in combination with AMD graphics: https://www.linuxquestions.org/quest...cs-4175640043/
 
1 members found this post helpful.
Old 10-09-2018, 07:29 PM   #38
Hooks123
Member
 
Registered: Aug 2014
Posts: 55

Original Poster
Rep: Reputation: 3
I did a upgradepkg with llvm-6.0.1-x86_64-2.txz which removed the llvm-7.0.0-x86_64-1.txz. libreoffice worked. I then upgradepkg llvm-7.0.0-x86_64-1.txz so now i am back to the current llvm-7.0.0-x86_64-1.txz and libre still works. Very strange. Im just happy to have libreoffice in my life again.

This thread has more info https://www.linuxquestions.org/quest...06#post5913006
 
Old 10-09-2018, 09:42 PM   #39
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,391

Rep: Reputation: Disabled
I would of not have expected that to work...I wonder how it did? You said this was a fresh install?
 
Old 10-09-2018, 09:43 PM   #40
Hooks123
Member
 
Registered: Aug 2014
Posts: 55

Original Poster
Rep: Reputation: 3
Yes, it was a very fresh install. I used a Current64 as of 9/28/2018 did a upgrade-all. After that i tried installing Libreoffice. It doesn't get any fresher.

Not sure. Ill probably reload current64 over the weekend. Ill test it out again. My guess is something is wrong / different in the newest llvm package. who knows. I don't know enough about this stuff to really help. Im just glad it wasn't me doing something stupid which is usually the case.

Last edited by Hooks123; 10-09-2018 at 09:48 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] libreoffice-6.1.0-x86_64-1alien no postscript Xsane Slackware 6 10-07-2018 09:09 PM
chromium-62.0.3202.75-x86_64-1alien.txz won't run for me Zwergele Slackware 25 11-01-2017 11:51 AM
Installed Allen VLC vlc-2.2.4-x86_64-1alien.txz and PulseAudio Volume Control not working properly BW-userx Slackware 2 01-05-2017 07:16 AM
How to install only Writer from Libreoffice package"libreoffice-4.0.3-i486-1alien.txz just.srad Slackware 10 05-30-2013 02:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration