-   Slackware (
-   -   LibreOffice (

Bazzaah 02-15-2013 02:31 PM

I am using current and have just installed AlienBob's LibreOffice package. Thanks for that AlienBob.

It works fine but looks a bit ugly in KDE. Is there something to make it play nice in KDE?

I have oxygen-gtk which doesn't seem to make a big difference to Libreoffice, at least.


Alien Bob 02-16-2013 07:21 AM

I don't know what you would call "ugly"? Looks fine here, on slackware64-current.


Bazzaah 02-16-2013 07:35 AM

Thanks for the reply.

Sorry, I could have been more specific. Here's a screen shot

Hopefully you can see the lack of formatting around the menu.

So my question - is there a way to get LibreOffice to use the KDE theme? Oxygen-gtk doesn't seem to affect LibreOffice.

allend 02-16-2013 07:41 AM

I think your fonts need some attention to antialiasing.
If you want pretty, use Calligra. If you want functionality, use LibreOffice.

Alien Bob 02-16-2013 07:47 AM

Your screenshot does look ugly indeed. Not at all how my LibreOffice looks in KDE4 on slackware-current here in the home.

Two libraries in the libreoffice package take care of KDE4 UI integration:


These are only compiled when you build LibreOfffice on a computer with KDE4 installed. In my package, those libraries are present.
Oxygen-GTK does not influence the UI of LibreOFfice in KDE.


Bazzaah 02-16-2013 07:59 AM

Thanks - I don't have libcvlplug* but do have kde4be1*- the missing library must be the problem.

I will reinstall your package and see if that helps.

EDIT - it didn't.

Thanks allend - my fonts are all anti-aliased and look pretty nice really - the problem relates only to LibreOffice and most likely the missing lib.

D1ver 02-16-2013 11:02 AM

If you run Libreoffice from the command line do you get any errors? I've seen a similar problem with the SBo package where it complains about If you rename that library it starts working..

Bazzaah 02-16-2013 03:32 PM

Ha, gotta love computers.

I have an installation of Arch alongside Slackware. I installed LibreOffice there to see whether I had the same problem. Interestingly, I did.

I copied the 2 libs across from Arch to Slack and the problem is now solved. Weird. I have no idea why it should work. I have no idea whether this solution would be replicable, so I'm almost reluctant to mark it solved but I no longer have ugly menus, at least.

All times are GMT -5. The time now is 03:21 PM.