-   Slackware (
-   -   LibreOffice 3.6.3 (Alien's Slack64 14.0 build) - options bad display (

catkin 11-21-2012 05:19 AM

LibreOffice 3.6.3 (Alien's Slack64 14.0 build) - options bad display
The selection indicator boxes of all tested options under AutoCorrect Options and Options behave strangely. Some display an empty box regardless of whether selected or not. Some display an empty box or a ticked box as expected but the way the tick appears and disappears is unexpected.

In more detail ...

Under Tools → AutoCorrect Options → Localised Options, both quotes' Replace boxes were shown as cleared but experimentation showed replacing was happening. Clicked in the boxes (the box briefly went grey and then back to white) after which experimentation showed as if they were now cleared.

Under Tools → AutoCorrect Options → Word Completion, "Enable word completion" behaved the same as "Localised Options → both quotes' Replace" but the selected/de-selected state was shown by the sub-options being greyed out or not. "Collect words" behaved similarly.

Under Tools → Options → Language Settings, the strange ticking behaviour seen was under "User defined dictionaries" and Options. More detail later because our Internet connection is going down now.

This is on a fresh installation of Slackware64 14.0 on a system that was previously running Slackware64 13.37 and an earlier version of LibreOffice where the options dialog screens were behaving normally. The package was downloaded from and checksummed before installation.

onebuck 11-24-2012 10:19 AM

Member Response

I have been using with no problems.

You checked the '.md5'? Package does verify, just a habit for me.

catkin 11-26-2012 04:20 AM

Thanks onebuck :)

Useful to know it's working OK for someone else. Yes, it was MD5 summed "The package was ... checksummed before installation".

Will try re-installing if this thread does not give any other ideas in the next day or so.

chrisretusn 11-26-2012 06:24 AM

I tried to duplicate this on my Slackware64, KDE 4.9.3, LibreOffice 3.6.3 (Alien Bob' build). All appears normal here.

catkin 11-29-2012 06:59 AM

Thanks for trying chrisretusn :)

Removing and re-installing the package did not fix the symptoms.

The symptoms can be worked around by one of:
  • Moving the settings dialog window
  • Raising another window which completely obscures the settings dialog window and then making the settings dialog window visible again.
This results in the selection boxes showing the correct appearance. When a selection is changed, both the changed and other boxes may not display correctly; repeating the above fixes the display.

The behaviour on partly obscuring the settings dialog window is too complex to describe summarily.

catkin 12-04-2012 04:39 AM

The problem was fixed by changing from nouveau to nvidia's binary.

Video adapter:
  • According to the packaging: ASUS GT250 Silent
  • According to Xorg.0.log: NVIDIA GPU GeForce GT 520 (GF119)
  • According to lspci: nVidia Corporation GF119 [GeForce GT 520] (rev a1)
nvidia's binary:

Steps to change:
  1. Installed xf86-video-nouveau-blacklist-noarch-1.txz from the extras directory on the Slackware64 14.0 DVD
  2. Changed the default run level from 4 to 3 in /etc/inittab
  3. Rebooted
  4. As root, cd to the directory containing, made it executable and ran it.
    1. Install NVIDIA's 32-bit compatibility OpenGL libraries? No.
    2. Run nvidia-xconfig? Yes.
  5. Tested by, as root, running init 4
  6. FInished off by restoring the default run level of 4 in /etc/inittab

chrisretusn 12-04-2012 05:47 AM

Well that would certainly explain why I wasn't able to reproduce it; ATI graphics. :)

It's good to know though, I normally stick with the nouveau driver unless it causes problems.

All times are GMT -5. The time now is 11:21 AM.