LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-01-2014, 09:47 AM   #1
amandus
Member
 
Registered: Nov 2011
Location: Sweden
Distribution: Slackware-current and Arch Linux
Posts: 56

Rep: Reputation: Disabled
library


Iḿ searching for libparted.so.0 any clue where I can find it.

Have Slackware 14.1 x86
Thanks
 
Old 10-01-2014, 09:52 AM   #2
Slack_Buddha
LQ Newbie
 
Registered: Jun 2013
Location: Dark Side of the Moon
Distribution: Slackware64-current
Posts: 18

Rep: Reputation: Disabled
Quote:
# slackpkg install parted
that should fix your problem
 
Old 10-01-2014, 10:01 AM   #3
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware64-15.0
Posts: 6,409

Rep: Reputation: 2776Reputation: 2776Reputation: 2776Reputation: 2776Reputation: 2776Reputation: 2776Reputation: 2776Reputation: 2776Reputation: 2776Reputation: 2776Reputation: 2776
In Slackware 13.37 there is a symlink '/usr/lib/libparted.so.0 -> libparted.so.0.0.1*'
 
Old 10-01-2014, 10:20 AM   #4
moisespedro
Senior Member
 
Registered: Nov 2013
Location: Brazil
Distribution: Slackware
Posts: 1,223

Rep: Reputation: 195Reputation: 195
If you want to find where it is on your system you can do:

Code:
find / -name libparted 2>/dev/null
 
Old 10-01-2014, 10:49 AM   #5
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-15.0
Posts: 11,118

Rep: Reputation: Disabled
Quote:
Originally Posted by amandus View Post
Iḿ searching for libparted.so.0 any clue where I can find it.Thanks
There is none coming from an official Slackware package included in Slackware 14.1. As pointed out by Allend, this symlink was made when installing an older parted package, no more shipped in Slackware 14.1.

If you would like to tell us why you need it, maybe we can help a little more.

Last edited by Didier Spaier; 10-01-2014 at 11:02 AM.
 
Old 10-01-2014, 11:18 AM   #6
amandus
Member
 
Registered: Nov 2011
Location: Sweden
Distribution: Slackware-current and Arch Linux
Posts: 56

Original Poster
Rep: Reputation: Disabled
I downloaded gparted and it want it.
 
Old 10-01-2014, 11:28 AM   #7
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-15.0
Posts: 11,118

Rep: Reputation: Disabled
Quote:
I downloaded gparted
Where did you download it and which version? I would be surprised that the SlackBuild provided by http://slackbuilds.org need it. I am running it right now, to check (I also run Slackware 14.1). I will report what I come up with.

Last edited by Didier Spaier; 10-01-2014 at 03:48 PM. Reason: s/well/will/
 
Old 10-01-2014, 11:39 AM   #8
amandus
Member
 
Registered: Nov 2011
Location: Sweden
Distribution: Slackware-current and Arch Linux
Posts: 56

Original Poster
Rep: Reputation: Disabled
/slacky/slackware-14.0/system/gparted/0.14.0
 
Old 10-01-2014, 11:48 AM   #9
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-15.0
Posts: 11,118

Rep: Reputation: Disabled
Quote:
Originally Posted by amandus View Post
/slacky/slackware-14.0/system/gparted/0.14.0
I assume that you tried that one because there is no gparted package available for Slackware 14.1 on slacky.eu. But this doesn't work, because as you see, this gparted version expects a library that is not shipped in Slackware 14.1.

So my advice is to build yourself a package using a SlackBuild available at slackbuilds.org.

Last edited by Didier Spaier; 10-01-2014 at 11:49 AM.
 
Old 10-01-2014, 12:00 PM   #10
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-15.0
Posts: 11,118

Rep: Reputation: Disabled
I confirm that gparted built from material provided @ slackbuilds.org works on Slackware 14.1.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Compilation error - GSL library + MPI Benchmark Library = undefined reference quadpixels Programming 5 07-08-2012 03:33 AM
[SOLVED] ./configure problem for libsf library due to apparently missing libdb library. vectrum Linux - Software 6 08-05-2011 02:11 PM
ldd reports shared library missing, but library exists on disk athv_gr Linux - Newbie 7 05-13-2009 12:31 PM
howto compile bin with my library using all-static and shared linked standart library stpg Programming 4 06-29-2004 04:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration