-   Slackware (
-   -   libnepomuk libraries missing in Slackware64/current (

nebloof 05-12-2013 07:31 PM

libnepomuk libraries missing in Slackware64/current
I don't know if anyone is aware of this, but some of the libnepomuk libraries are missing in Slackware64/current

I did a fresh install of Slackware 14 today, pointed repositories to /current to upgrade the system, and Dolphin file manager wouldn't open after reboot. So I tried Konqueror to browse the file system, and it gave the an error that it couldn't find the shared library

When I checked /usr/lib64, libnepomukcore and libnepomukwidgets files were missing.

I really didn't know where to look for source (I guess I could've checked KDE >_<), but I grabbed src packages for libnepomuk 4.10.3 from Linux from scratch, built those, moved the library files to /usr/lib64, and got Dolphin/Konqueror working again.

allend 05-12-2013 07:43 PM

On my system 'grep libnepomukcore /var/log/packages/*' shows

This is a new package not present in Slackware 14.0.

How did you do your upgrade? Did you use 'slackpkg' and did you do 'slackpkg install-new'?

nebloof 05-12-2013 09:15 PM

I wasn't aware of slackpkg until after this thread >_<, so I used slapt-get and those repositories.

But even in the slackpkg repositories I didn't see the libnepomukcore and libnepomukwidets libraries.

And if I run the same command you did, I get nothing back for libnepomukcore.

allend 05-12-2013 09:30 PM

This is what I see for 'grep libnepomukwidgets /var/log/packages/*'.

Is slackpkg set up to use the -current tree on your mirror?
'grep -v "^#" /etc/slackpkg/mirrors' should show a single mirror with -current

I really didn't know where to look for source
The sources are found in the source directory on your mirror.

All times are GMT -5. The time now is 08:55 AM.