-   Slackware (
-   -   Latest updates to -current broke alt-tab in kde (

vulcan59 02-02-2011 07:19 AM

Latest updates to -current broke alt-tab in kde
After applying the 31st Jan and 1st Feb updates to -current (32 bit), alt-tab to switch between windows is no longer working in kde. It seems to lock the desktop and then after a few seconds kde goes back to the login screen. If I disable all desktop effects then alt-tab works again. Is anyone else seeing this? Any suggestions for a fix? I will keep investigating.

willysr 02-02-2011 07:38 AM

No, it's working just fine here

vulcan59 02-02-2011 11:45 AM

I did some more investigation and have had some more apparently random lockups in kde. This may be a problem with Mesa 7.10. I went back to 7.9 and the problems have gone away. For info, I am seeing these problems on a Lenovo T410 laptop with integrated Intel graphics.

lspci -v shows -
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
Subsystem: Lenovo Device 215a
Flags: bus master, fast devsel, latency 0, IRQ 48
Memory at f2000000 (64-bit, non-prefetchable) [size=4M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 1800 [size=8]
Expansion ROM at <unassigned> [disabled]
Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
Capabilities: [d0] Power Management version 2
Capabilities: [a4] PCI Advanced Features
Kernel driver in use: i915
Kernel modules: i915

X is using the Intel driver -
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
Sandybridge, Sandybridge, Sandybridge, Sandybridge, Sandybridge,
Sandybridge, Sandybridge

vulcan59 02-02-2011 12:02 PM

Found someone else with similar problems.

phi11ip 02-03-2011 04:12 AM

Hmmm... I had a similar problem, but with an Nvidia card with propriety drivers. Recompiling the Nvidia drivers cured my problem.

willysr 02-03-2011 05:26 AM

ah, since it has to do with xorg-server and mesa, i guess you will have to recompile your NVIdia driver if you used it
i have recompiled mine, so i don't get this problem :)

svartalfr 02-03-2011 12:16 PM

I have similar specs (on board intel video with a Dell desktop) and also experience odd desktop effect related issues with -current. Except in mine the system freezes then kicks me back out to KDM. Disabling desktop effects seems to have eliminated all freezes.

em21701 02-03-2011 02:05 PM

I have noticed freezing on my machine after the mesa update as well. I have on-board intel graphics and I am running _64. Disabling desktop effects seems to have helped.

hsahin4 02-03-2011 02:31 PM

I am running slackware-current64 and I use nvidia GTS250. There is no problem regarding to Alt+Tab.

vulcan59 03-12-2011 01:24 PM

Since reporting this problem I have been running mesa-7.9_ccc11aa-i486-1 in -current with no problems. Today I thought I would try mesa-7.10.1-i486-1 as included in 13.37 /testing. This also is working ok for me. So, it seems that the changes from 7.10 to 7.10.1 solved my lockups.

piratesmack 03-12-2011 03:19 PM

I was having the same issue with my Intel graphics.
Upgrading to the mesa version in /testing/ has fixed it for me also.

All times are GMT -5. The time now is 05:33 AM.