LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-12-2020, 03:38 AM   #1
danix85
LQ Newbie
 
Registered: Apr 2007
Location: italy
Distribution: Slackware64-current
Posts: 13

Rep: Reputation: 10
latest tmux from current built on a 14.2 VPS doesn't work


Hello everyone,
I have a VPS setup on OpenVZ, I'm using Slackware64-14.2 and when trying to compile tmux from current it builds without a problem. I'm logged in via SSH and when I try to run it as my normal user it doesn't start and just screws my terminal rendering it unusable and I have to exit and login again. But if I try to run it as root it works flawlessly.
I have the same issue with stock tmux.

I have no clue as to why this would happen, it's a fresh install with just the latest updates applied, tmux is the first package that I tried building.

I'm running kernel 4.4.14 (I have no control over this) on my VPS and I'm trying to run tmux 3.1b from current (sources taken from a slackware64-current mirror)

Do you have any ideas/suggestions?
Thanks in advance
 
Old 07-13-2020, 06:58 PM   #2
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 2,538

Rep: Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799
If it works properly as root, then you've got a problem with your permissions.

What groups is your user in? The framebuffer device is usually owned by the "video" group. Is your user a member of that group?
 
  


Reply

Tags
openvz, ssh, tmux, xterm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] xterm throw errors with latest terminus-font in latest -current bakura_666 Slackware 10 01-02-2019 03:47 AM
[SOLVED] Libevent errors w/tmux on Slackware64 -current tallship Slackware 5 06-19-2011 03:53 AM
[SOLVED] Latest current updates .gtkrc-2.0 doesn't appear to work. GazL Slackware 13 11-18-2010 02:42 AM
Where can I download UML VPS or Xen VPS to make a virtual private server? abefroman Linux - Software 3 12-09-2005 10:00 AM
if i get an nforce mobo with built-in VGA... will the built in vga work in linux? kublador Linux - Hardware 2 11-10-2003 08:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration