LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-07-2017, 01:47 AM   #1
3rensho
Member
 
Registered: Mar 2008
Location: Switzerland
Distribution: Slackware64
Posts: 151

Rep: Reputation: 2
Latest -current update broke AlienBob's plasma 5


Running Slack64-current with the latest (November) plasma 5 version from AlienBob. The latest Slackware-current update breaks the KDE desktop. X-server will not start after entering startx. I got three errors about icuxxxxxx.so.56 not being found due to the icu update. Found the corresponding files in /usr/lib64 and linked icuxxxxxx.so.60 to icuxxxxxx.so.56 and that problem went away. Now I get an undefined symbol in libQt5. The undefined symbol ends in 56 so I figure it is related to libQt5 being built with the older icu in place. Has anyone got a fix for this? I figure it must have happened to anyone running -current with Eric's Plasma 5 from November. Thanks in advance.
 
Old 12-07-2017, 02:24 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,867

Rep: Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780
Packages need to be rebuilt against the new icu4c. This will certainly be done but need some time. Spotting which binaries need to be rebuilt would probably help. So please elaborate about these three errors, telling for what programs this occurred.

Last edited by Didier Spaier; 12-07-2017 at 02:27 AM.
 
1 members found this post helpful.
Old 12-07-2017, 02:42 AM   #3
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,135

Rep: Reputation: 391Reputation: 391Reputation: 391Reputation: 391
Do not worry he knows it Eric:

https://alien.slackbook.org/blog/sla...mber/#comments
 
Old 12-07-2017, 06:28 AM   #4
3rensho
Member
 
Registered: Mar 2008
Location: Switzerland
Distribution: Slackware64
Posts: 151

Original Poster
Rep: Reputation: 2
Kewl, that was speedy. Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware-current (alienBOB slacklive-plasma) Intel Corporation Centrino Advanced-N 6235 issue v32itas Slackware 6 07-21-2017 03:09 AM
[SOLVED] things broke in update of -current pzognar Slackware 25 11-27-2015 11:11 PM
Latest update broke yahoo videos XenaneX Mageia 6 04-25-2014 10:54 AM
[SOLVED] Latest updates to -current broke alt-tab in kde vulcan59 Slackware 10 03-12-2011 04:19 PM
latest Etch update broke my wifi... JaseP Debian 5 09-26-2006 12:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration