-   Slackware (
-   -   Latest 12.2 issue - mplayer doesn't "unblank" screen (

mrclisdue 02-10-2009 10:28 AM

Latest 12.2 issue - mplayer doesn't "unblank" screen
As the title states, unless the screen (in this particular case, a 42" plasma) is already unblanked (for lack of a better term)firing up a movie in mplayer doesn't unblank it. I have to physically go to the screen using vnc & x11vnc, and the movie appears - it is already running, so there's no error messages generated, since all's well according to mplayer.

I have commented the setterm line in rc.M referring to blanking and powersaving, etc.

Where else might I look?

As a side note, this was running fine in 12.0, and though it's been a while since I set it up, I don't recall having this issue.


mrclisdue 02-11-2009 02:00 PM

Dirty, inelegant hack
Well, I'm baffled by this behaviour. I uninstalled the sbo mplayer I was using, and compiled the svn mplayer, but the behaviour persists.

I installed vlc to determine if it had the same issue, and it doesn't. However, I don't want to use vlc.

Solution - I created a script that starts vlc, kills it, then launches mplayer.

I hate it, but what are ya gonna do?


mrclisdue 02-12-2009 04:06 PM

better solution - still not 'elegant'
I don't know why mplayer no longer wipes the screen. I now invoke xset when fluxbox launches - this prevents the monitor from going into any kind of powerdown mode.

In order to prevent any screen burn-in, in case the set is left unattended for hours, xscreensaver is set.

When mplayer starts, it won't even wipe xscreensaver.

So, mplayer is now part of a script that first deactivates the screensaver and then starts mplayer.

Certainly a better fix than invoking vlc, but still not a real solution or answer.


All times are GMT -5. The time now is 07:03 AM.