-   Slackware (
-   -   Lastfm no longer working after upgrading to Slackware64 13.1 (amarok 2.3) (

integrale16 06-13-2010 10:14 AM

Lastfm no longer working after upgrading to Slackware64 13.1 (amarok 2.3)

I actually upgraded my Slackware64 13.0 to 13.1 and recognized that Lastfm is no longer working.
I get a message, which tells me that I have to become a paying member to use it now. With Slackware64 13.0 everything was working fine.

Can anyone tell me if there is a chance to get Lastfm working again, without getting a paying member?


XavierP 06-13-2010 10:44 AM

Which version of Amarok do you have? I have 2.3.0 and have just tested my login and didn't receive any notification about needing to pay. Do you have a screenshot of the error message?

Eternal_Newbie 06-13-2010 12:09 PM

I assume he means you need to be a paying member to receive audio streams from Last.FM in Amarok. Last.FM actually made that change a while ago. You should still be able to submit tracks, though.

integrale16 06-13-2010 05:20 PM

I used Amarok to receive audio streams from Last.FM in Amarok, right.
For example I put "blink182" in the field in Amarok and then I received an audio stream with music which is similar to the music of blink182.
But after the upgrade to Slackware64 13.1 (and Amarok 2.3) this does no longer work.

You say that Last.FM made this change while ago. How long ago?
For me it worked with Amarok 2.1.1 on Slackware64 13.0 at least until one or two weeks ago.
And now it doesn't work anymore.

Any suggestions?

Eternal_Newbie 06-14-2010 01:54 AM

Well, from what I remember, they announced the change toward the end of last year. They also announced some changes to the plugin API around the same time, presumably to support the subscription model better. Perhaps Amarok 2.3 uses the new API. I personally have not been able to play streams since around when they announced the change (although I never did that much). maybe you were just overlooked.

XavierP 06-14-2010 04:34 AM

I tested streaming on my box and nothing happens - that's a bit of a pest.

integrale16 06-14-2010 07:42 AM

Does it mean, that I could try to build amarok 2.1.1 on my Slackware64 13.1 box and then it's possible that I can receive the streams again?

Eternal_Newbie 06-14-2010 10:37 AM

No idea, however I noticed in the Amarok Last.FM group that scrobbling doesn't work in 2.3 if you aren't using kwallet unless you edit your ~/.kde/share/config/amarokrc I'm not sure if its the same problem as yours but it couldn't hurt to try

Originally Posted by Amarok Last.FM group
it is a known issue if you disable kwallet.
edit file ~/.kde/share/config/amarokrc



hughetorrance 06-14-2010 01:40 PM

Who needs ... here are two of my favourite stations... Big R Antioch

ps I must have listened to every episode of Gunsmoke twice... LOL

pps Matt Dillon is my kind of guy.

integrale16 06-14-2010 03:30 PM

I already edited the amarokrc because amarok didn't take over my user name and password for Lastfm, although I chose option not to use Kwallet and save username and password in clear text instead.

Is this a known issue (maybe only in slackware) that amarok doesn't take over the username and password?

integrale16 06-14-2010 03:54 PM

I tried to get amarok 2.1.1 working and/or compiling but both I didn't get managed so far.
Does anyone know if this is actually possible?

frandalla 06-14-2010 10:39 PM

You certainly can recompile the package by yourself, but you can also go to the slackware DVD and get the Slackbuild script and rebuild recompile the package using that. Just get your 13 DVD get the files in the source/ folder

damgar 06-14-2010 10:53 PM

Have you tried just installing the old amarok package from a 13.0 mirror?

integrale16 06-15-2010 03:28 AM


As I wrote before, I didn't get it managed to compile amarok 2.1.1 with the slackbuild of 13.0 even with some modifications. When it finally started compiling it stop at about 30% with an error.
And the amarok package from 13.0 is also not working.

So if you have a amarok package 2.1.1 which works on 13.1 it would be nice.

For now I had a look at and found a as a separate software, where the streaming is still wotking. So, it's not so important for me any more to get amarok running again with streaming. :-)

But thanks to all who answered.
And if there is a solution to get it running again, it would still be welcome.


All times are GMT -5. The time now is 02:24 AM.