-   Slackware (
-   -   Last hurdle with Slack...boot from Grub [SOLVED] (

BobNutfield 03-11-2006 06:41 AM

Last hurdle with Slack...boot from Grub [SOLVED]
Hi Everybody,

I am almost Slack installed, net card is finally working, sound enabled. I have one last hurdle to overcome. I cannot seem to get the right grub.conf file entries to get it to boot. Slack is installed on the same SATA hard drive as WinXP. The partitions are this:

sda1: WinXP
sda2: Slackware
sda3: Swap

My current grub entry for Slack is this:

root (hd0,1)
kernel /boot/vmlinuz-2.4.31 root=/dev/sda2 vga-788 ro

When I choose Slack from the grub boot menu, I get this error:

Error 1: Filename must be either absolute pathname or blocklist

This is the grub entry for Slack that was recommended elsewhere and on other sites.
If anyone has Slackware booting from Grub successfully with a similar configuration to mine, would you be so kind as to showing me your grub.conf entry?

Any help very much appreciated.


reddazz 03-11-2006 07:27 AM


title Slackware
kernel (hd0,1)/boot/vmlinuz-2.4.31 root=/dev/sda2 vga=788 ro

Your code above should probably work if you corrrect the vga section (= not -).

BobNutfield 03-11-2006 08:44 AM

Thank you for your reply. I entered the line into grub.conf just as shown, but I am afraid it doesn't work. It returns:

Error 15: file not found

It could be that I do not have the kernel identified correctly (i.e. there may be more to the kernel name), but I have not found it yet. This one really baffles me.

I can boot from the floppy just fine. Just can't figure this one out.

Thanks for your help.


reddazz 03-11-2006 08:57 AM

if you can boot from the floppy, can you change into /boot and then list the files that are in there. Also what is the entry for Fedora Core?

BobNutfield 03-11-2006 01:21 PM

Hi raddazz,

Thank you for your response. My Fedora grub entry is as follows:

root (hd1,0)
kernel /boot/vmlinuz-2.6.14-1.1656_FC4 ro LABEL=/ rghb quiet
initrd /boot/initrd-2.6.14-1.1656_FC4.img

Again, as I understand it, the initrd entry is not required for Slackware. And, yes, I have rooted around in the /boot directory of Slack and found nothing revealing about the file name. I can only assume there is more to the filename than just 2.4.31, but I have not found it.

Thank you again.


KleB 03-11-2006 02:20 PM


sorry if I mess around with things I don't know well, but are you sure that your kernel is in fact named vmlinuz-2.4.31? If I understand you correctly you are not sure. In that case please tell what files do you have in /boot. For other things with grub I can't help you, as I don't use it.


BobNutfield 03-11-2006 02:21 PM

Thank you to all who helped....job done!
Just a quick post to all who helped me with my new installation of Slackware 10.2. I added this distro to my collection as a training tool because of it rock solid stability reputation and it's lack of hand holding (like the other distros do). I want to become an advanced user and I believe Slack will let me to that.

I have two pending posts in this forum asking for help in writing code to enable me to boot Slack from my grub menu. Everything else had been solved (sound, net, etc.) but this one last thing was eluding me. Here is how I solved it:

I simply used the same entry I had described in my previous posts in my grub.conf file, BUT SIMPLY LEFT THE KERNEL VERSION OUT. As such:

root (hd0,1)
kernel /boot/vmlinuz root=/dev/sda2 ro vga=788

That's it!

To all who responded (you know who you are), just a quick thanks.


BobNutfield 03-11-2006 02:24 PM

Thank you for your response..As it turns out I have solved the issue (please see my other post today). I knew the kernel version, but my entries weren't working. Out of a mindset of "one more try", I reedited the grub.conf file and simply left the kernel version out. BANG! It worked.

I hope this experience will help someone else.

Thanks again,


reddazz 03-11-2006 02:57 PM

Glad you got it working. Its the small things that sometimes cause us big problems. :)

cwwilson721 03-11-2006 06:51 PM

I always have vmlinuz as a soft link to the kernel I'm using as my 'current'

ln -s /boot/vmlinuz-2.6.15a vmlinuz
and one to the older 'bootable' kernel

ln -s /boot/vmlinuz-2.6.15 vmlinuzsafe
That way, I can change the kernel (like I do almost once a week), and don't have to woory as much about bootloaders. I just make sure that 'vmlinuz' and 'vmlinuzsafe' are what is called from the bootloader.

BobNutfield 03-12-2006 03:28 AM

Thank you. A good point to remember. I am primarily a Fedora user, so when I installed Slack I tried to make grub entries look the same. Obivously didn't work, but I will know for the future.

BTW, my home is Montgomery, AL. Just noticed you are from the Heart as well.


XavierP 03-12-2006 10:27 AM

Congrats on getting it sorted. I have merged the 2 threads so that the thank yous are in the same place as the help received.

MannyNix 03-12-2006 10:38 AM


Originally Posted by XavierP
Congrats on getting it sorted. I have merged the 2 threads so that the thank yous are in the same place as the help received.

A really nice move, plus the [SOLVED] added improves the quality of the forum greatly

All times are GMT -5. The time now is 03:05 PM.