LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-19-2011, 08:58 AM   #1
keyserSoze
LQ Newbie
 
Registered: Jul 2011
Posts: 9

Rep: Reputation: Disabled
Unhappy Lack of Sound on my laptop via the speakers.


Hello all,

I have a Dell XPS 15 laptop and have installed Slackware 13.0 on it. I'm not getting any sound through the speakers. I tried configuring alsa first. However, I did not have any success. Next I also tried inserting some kernel modules corresponding to sound drivers, which was present in /lib. Again, I'd no sound output.
I can get sound through earphones though.

I've been stuck with this problem from some time. Any help will be appreciated.
 
Old 07-19-2011, 09:34 AM   #2
alfredo10
Member
 
Registered: Sep 2010
Location: Algarve
Distribution: Linux Multiboot
Posts: 258

Rep: Reputation: 14
Hi!
Last year I installed slackware, but now I don't have it - hw problem.
You have Desktop KDE?
I suppose you run "alsamixer, hit F6 to choose sound card and adjust channels.
Did You try
Code:
pavucontrol
In spite of an error message it's possible to continue.
alfredo
 
Old 07-19-2011, 09:56 AM   #3
keyserSoze
LQ Newbie
 
Registered: Jul 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
Is pavucontrol a separate package... ?
 
Old 07-19-2011, 10:16 AM   #4
disco_slack
Member
 
Registered: Apr 2011
Posts: 44

Rep: Reputation: 1
try to find a post of mine regarding skype problem and mic. maybe it works for you.
 
Old 07-19-2011, 10:24 AM   #5
alfredo10
Member
 
Registered: Sep 2010
Location: Algarve
Distribution: Linux Multiboot
Posts: 258

Rep: Reputation: 14
Hi!
Yes, pavucontrol is an extra package, which is not available on each Linux and then must be installed.
alfredo
 
Old 07-19-2011, 11:31 AM   #6
san
Member
 
Registered: Jan 2006
Location: vienna, .at
Distribution: Slackware64 13.37
Posts: 50

Rep: Reputation: 12
this problem sounds familiar to me
sometimes the speaker is muted by default. try to run alsamixer and press "m" to toggle it.

cf. "man alsamixer":
Quote:
When a mixer control is turned off, M (mute) appears below the volume
bar. When it's turned on, O in green appears instead. You can toggle
the switch via m key.
regards,
d.s.

Last edited by san; 07-19-2011 at 11:34 AM.
 
Old 07-19-2011, 10:32 PM   #7
Cheesesteak
Member
 
Registered: Jun 2008
Distribution: Slackware
Posts: 96

Rep: Reputation: 24
I have a Dell XPS 17 (L702X) with working audio. You either need to upgrade ALSA to a more recent version, which provides better support for Intel HDA audio and its various codecs, or you can upgrade to a newer linux kernel and use the included ALSA drivers.

Slackware does not include PulseAudio, so you do not have pavucontrol. You can add PA, but why?

With Slackware 13.37, audio will work right away without trouble, with kernel 2.6.37.6.
 
Old 07-20-2011, 07:13 AM   #8
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: Ubuntu
Posts: 530

Rep: Reputation: 125Reputation: 125
I would definitely check alsamixer. I have a Dell Studio laptop with the ATI HD audio and have had the speakers muted just as san said in his post. Same with the headphones too, sometimes they start muted.
 
Old 07-21-2011, 06:40 AM   #9
keyserSoze
LQ Newbie
 
Registered: Jul 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
@san and @jkirchner :
The weird thing is that, nothing happens when I toggle mute using 'm' key.
In the sense, nothing appears below the volume bar (Neither M or O)
Am I missing something here ?

@Cheesesteak :
I'll try out Slackware 13.37 next.
 
Old 07-21-2011, 09:26 AM   #10
san
Member
 
Registered: Jan 2006
Location: vienna, .at
Distribution: Slackware64 13.37
Posts: 50

Rep: Reputation: 12
in muted state, it should look like this: http://img89.imageshack.us/img89/9883/alsa.png


regards,
d.s.
 
Old 07-25-2011, 06:39 AM   #11
keyserSoze
LQ Newbie
 
Registered: Jul 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
@San :
Sorry for the delay in response.
This is how my alsamixer looks.
There is nothing in there, which you pointed out.
Attached Images
File Type: png alsamixer.png (29.7 KB, 18 views)
 
Old 07-25-2011, 02:20 PM   #12
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 498

Rep: Reputation: 136Reputation: 136
If you get headphone sound, but no the laptop speakers, then the modules are loaded and ALSA is working.

A couple of tools are handy, besides alsamixer:
Code:
$ aplay -L
This will show all the channels ALSA sees. To test, pick a channel:device:
Code:
$ speaker-test -Dfront:Intel -c2 -twav
While this runs, plug in the headphones. Do you hear sound? If yes, ok. Unplug, do you hear sound? No? Then, Speakers are muted, speakers are bad, BIOS muted speakers, check the speaker volume adjustment on the keyboard. If you use KDE, check the audio setup. It sometimes defaults to a nonsense channel. Check the sound mixer in your DE, sometimes those settings override the alsamixer ones.

For example, for my card (SB Audigy2)
Code:
$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=Audigy
    SB Audigy 1 [SB0090], ADC Capture/Standard PCM Playback
    Default Audio Device
front:CARD=Audigy,DEV=0
    SB Audigy 1 [SB0090], ADC Capture/Standard PCM Playback
    Front speakers
rear:CARD=Audigy,DEV=0
    SB Audigy 1 [SB0090], ADC Capture/Standard PCM Playback
    Rear speakers
center_lfe:CARD=Audigy,DEV=0
    SB Audigy 1 [SB0090], ADC Capture/Standard PCM Playback
    Center and Subwoofer speakers
surround40:CARD=Audigy,DEV=0
    SB Audigy 1 [SB0090], ADC Capture/Standard PCM Playback
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Audigy,DEV=0
    SB Audigy 1 [SB0090], ADC Capture/Standard PCM Playback
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Audigy,DEV=0
    SB Audigy 1 [SB0090], ADC Capture/Standard PCM Playback
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Audigy,DEV=0
    SB Audigy 1 [SB0090], ADC Capture/Standard PCM Playback
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
iec958:CARD=Audigy,DEV=0
    SB Audigy 1 [SB0090], ADC Capture/Standard PCM Playback
    IEC958 (S/PDIF) Digital Audio Output
To test just the front channel:
Code:
speaker-test -Dfront:Audigy -c2 -twav

speaker-test 1.0.24.2

Playback device is front:Audigy
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 16 to 16384
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
 0 - Front Left
 1 - Front Right
Time per period = 2.731772
 0 - Front Left
 1 - Front Right
Time per period = 2.986619
 0 - Front Left
^C
 
Old 07-25-2011, 02:23 PM   #13
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 498

Rep: Reputation: 136Reputation: 136
Almost forgot. In alsamixer, hit 'F6' so see all the audio devices. You may have an HDMI or such depending on your laptop/intel chipset.
 
Old 07-26-2011, 12:43 PM   #14
keyserSoze
LQ Newbie
 
Registered: Jul 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
@beowulf999 :
I tried everything which you specified. However I'm still unable to get to the bottom of this.
Also I don't think there is a problem with the speakers as I've no problems with their usage in Windows (I've a Dual Boot Machine)
Again in the audio setup, the default points to my sound card itself. And my sound mixer settings are unmuted.
Finally, in the alsamixer there is no indication as to whether the channel is muted or not. (Please check my attachment, a couple of posts above.)

Do you know any way around this ?
 
Old 07-26-2011, 01:50 PM   #15
bnguyen
Member
 
Registered: Jul 2010
Distribution: Slackware
Posts: 125

Rep: Reputation: 32
Hi,

I had the same issue some time ago with Slackware64-13.1 on a Dell Inspiron 1545 and solved it with the following steps:

- Find the 'series' of the sound card using:
cat /proc/asound/card0/codec#* | grep Codec
(I got 'Codec: IDT 92HD71B7X')

- In the file '/usr/src/linux-`uname -r`/Documentation/sound/alsa/HD-Audio-Models.txt' (or you can use this link: http://www.kernel.org/doc/Documentat...dio-Models.txt), find what the Dell models have similar series number as yours. In my case I search for '92HD71B')

- Create an option for sound the system will load at boot. In my case, I created /etc/modprobe.d/dell-inspiron1545.conf that contains:
options snd-hda-intel model=dell-m4-1

- Reboot

(dell-m4-1 is one of the models that have sound card series 'STAC92HD71B*'. Maybe you have to change some times until you find one that works for you).

Hope that helps.

Last edited by bnguyen; 07-26-2011 at 01:52 PM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound from external speakers in Fedora 8 (laptop speakers ok) openSauce Linux - Hardware 7 03-15-2009 03:48 PM
how to get good sound from laptop speakers -help please neilcpp Linux - Laptop and Netbook 6 09-26-2008 02:29 PM
sound from laptop speakers although external speakers are connected! superpingu Linux - Laptop and Netbook 1 10-18-2007 06:32 AM
Can get sound from laptop speakers but not from headphones thetremorchrist Linux - Hardware 4 02-14-2004 03:43 AM
Geting no sound from laptop speakers eroica Linux - Laptop and Netbook 6 10-11-2003 08:26 PM


All times are GMT -5. The time now is 04:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration