LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   kwin choppy (https://www.linuxquestions.org/questions/slackware-14/kwin-choppy-925536/)

Knightron 01-24-2012 06:24 PM

kwin choppy
 
hello guys, I've done several installs of slackware 13.37, because of distro hopping and coming back, and something I've observed is kwin will sometimes react rather choppy with an install, while on other installs its works smooth like it should. it is very noticeable when switching work space with hot corners. has anyone else noticed this choppyness?

bosth 01-24-2012 08:35 PM

Intel GPU?

Knightron 01-24-2012 08:59 PM

yes, Intel HD graphics 3000

bosth 01-25-2012 10:07 AM

There are quite a few threads on using that GPU with Slackware 13.x. They might help you although I still have problems with mine, not so much with KDE but rather with xscreensaver.

Knightron 01-25-2012 02:26 PM

So you think it's the graphics card? I thought it might have been a bug or kwin because it works smoothly all the time in other distributions. I did a reinstall and tested it before installing anything yesterday and it was working smoothly, so i've gone ahead and installed all my stuff, and am happ now. I'll check out a search though if other people have covered this topic before, thanks.

bosth 01-25-2012 02:55 PM

I haven't tried any other distros with my HD 3000, so I can't really compare. But I think Slackware's support for this GPU isn't always the best. This is why there is at least one alternative Intel driver shipped with the Slackware 13.37 disc. That being said, I haven't had much luck with down that road. Others on LQ have tried compiling newer Mesa and other libs, but again I've not had any luck there either.

Knightron 01-25-2012 03:00 PM

Hi, just letting everyone know, i've figured out what makes kwin react choppy. I don't use kde, and the oxygen buttons don't suit my gtk theme, so i change it. I don't know why but changing the oxygen window decorations causes it to act choppy, switch it back and it goes smooth again.

bosth 01-25-2012 07:49 PM

By the way, you might want to upgrade to KDE 4.8 as there appears to have been some work on kwin performance.

Old_Fogie 01-30-2012 08:32 PM

hd3000 here with 3.2.2 kernel with kde 4.8.0 and it's smoooth. definitely look into using alien bob's kde packages in conjunction with --current.

note, 3.1.9 and 3.1.10 is also great with hd3000 video.

no other changes to slackware needed imo for this laptop.


All times are GMT -5. The time now is 04:07 AM.