-   Slackware (
-   -   KVM Win XP guest can internet, can see smb on Slack 12.1 host "but can't find path" (

acummings 11-26-2008 05:47 AM

KVM Win XP guest can internet, can see smb on Slack 12.1 host "but can't find path"
My Win XP guest O.S. accesses the internet fine

it sees the samba share on the host Slack 12.1 -- but when try to access -- it reports "unable to find pathway

Slack 12.1 kernel. KVM

qemu & kqemu are on. kvm and tun are on

/usr/bin/qemu-system-x86_64 -hda ~/virtmach/winxp.qcow -m 896 -no-acpi -localtime -net nic -net user -smb ~/ntp

Win XP guest successfully pings qemu smb

ping (succeeds)

I tried use the IP ( of host Slack (but maybe I didn't get it correctly entered in the "map network drive").

What to do to virtual network file exchange between the host and guest Os's.

root@G33T-M2:~# hig modp
342 modprobe -l qem
343 modprobe -l *qem
344 modprobe -l *qem*
345 modprobe kqemu
347 modprobe -r kqemu
428 modprobe kvm-intel
430 modprobe -r kvm-intel
439 modprobe tun
487 modprobe kvm-intel
494 modprobe tun
501 hig modp

Chuck56 11-26-2008 09:07 AM

I'm running a similar setup except with NFS shares instead of Samba SMB shares. I setup a public bridge with tun/tap for my VMs. They all have DHCP issued IPs and can access the LAN and WAN resources.

An unrelated question on your setup. Are you using qemu/kqemu or kvm/qemu?

mostlyharmless 11-26-2008 10:47 AM

Post your smb.conf; your problem sounds more like a samba settings problem...

Presumably when you try smbclient from Slackware, it shows the shares and they are accessible from there?

Chuck56 11-27-2008 12:23 AM


Originally Posted by acummings (Post 3355069)
qemu & kqemu are on. kvm and tun are on

This is confusing to me but that's easy to do! kvm already includes its own slightly modified version of qemu and doesn't use kqemu. If you have Intel or AMD VT enabled hardware then why would your need to run qemu/kqemu? I've never tried to run kvm & qemu/kqemu together and not sure its a good idea.

acummings 11-27-2008 02:06 AM


If you have Intel or AMD VT enabled hardware then why would your need to run qemu/kqemu?
I wouldn't, didn't need to.

Part of my mixup is due a 2nd VM, an older one, originally from non VT hardware (uses qemu/kqemu). It works fine then and now too with qemu/kqemu (and not KVM) on my later hardware, my Intel VT box.

But this subject/thread I init for my new VM out of the two VM. This new one on Intel VT box I began it as KVM and bridge.

But (my first bridge) I didn't know what I was doing on this new VM. Tried kqemu/qemu out of desperation and grasping at straws.

1. (The old of the 2 VM [qemu/kqemu] works (not using KVM) on this Intel VT box). 2. (the new of the 2 VM has a prob). 3. (I'm [*sometimes far too much of*] a kinisthetic learner). ****you asked****. :-)

Further details on my "old" VM: I already had/have a working Win 2K host which is yet another, a different, .qcow file which came originally from a socket 478 hardware (has the hyperthread excuse but no VT) where I had used qemu/kqemu, not kvm.

(he he), BTW, now been using that one with qemu/kqemu on my Intel VT box. (I don't know how to convert it over to KVM, it's an older, originally from non Intel VT .qcow and qemu/kqemu commandline setup that also uses the -smb and NAT capabilities of qemu).

I wonder if it could be as simple as not loading kqemu and also use the kvm command line to get this one converted over to KVM? And of course, first, do:

root@G33T-M2:~# modprobe kvm-intel
root@G33T-M2:~# modprobe tun

My book (next post) if I ever get enough time I'll revise the book down.

Nonetheless, "book" attempts to further portray why I started this subject/thread due the (not http but limited to LAN file share "no path found") problem with my new, recent VM which is [to be] bridge on Intel VT box.

Thanks. Alan.

acummings 11-27-2008 02:17 AM


qemu/kqemu or kvm/qemu?
kvm/qemu on this VM (Win XP) (BTW I didn't think I'd need "-smb host_share") -- I thought that kvm-intel and tun and a host smb shared folder would do (but, not yet, though).

(about samba.conf [works on "old"er of my two VM] is further below)

host: smp kernel with/in Slack 12.1

******ICS/firewall******** Interesting (to me anyways), see this tag further down below for ""how the Win XP guest was "seeing" my host's samba share"" even though this guest could not access the share, reporting "no path was found" to the seen share.

I could be wrong -- but my guess, I attribute my problem is due to something with problems associated with path between virtual network ( etc.) and real network ( (however, the http protocol works, it does: guest <--> internet works fine, http relays (nat's or whatever) through qemu_gateway to real lan and real gateway. But, any that's outside of or other than http protocol doesn't work; it errors, says "no path found."

This is my first bridging attempt (I'm so confused due that the internet web browsing works fine in the XP guest but to do to (real) LAN from XP guest's (virtual LAN) IP is *to* host IP which is (on real LAN) (file share does not work, error say no path found).

guest info: IP is gateway is

guest pings OK that gateway (that's the gateway in qemu) the guest web browses to internet fine and has to go through my real physical gateway on my real LAN at to get out on internet.

In guest I ping of/to fails (perhaps qemu gateway disallows ping) (BTW the same ping done from host works) -- maybe I hit on part of it here -- http protocol goes fine from guest through qemu gateway onward to 192.168.x LAN and through (real) internet gateway on said lan. Likely, if I fired up the http server on the host at, XP guest would web browse it just fine.

The samba.conf works fine everywhere else on my LAN -- it is only here, this host <--> guest (see below for enclosed smb.conf) that (access/share) problem. Perhaps I should check the samba.conf again though (had pulled a copy of samba.conf over from another box, a Slack 12.0 box -- this VM host box is Slack 12.1 -- can't remember if I put a (physical not virtual) Win LAN box to my Slack 12.1 SMB (it always worked super on the Slack 12.0 box).

BTW, guest is Win XP Pro. And, in it, I just did "manage -- services", and though I'd earlier turned off the firewall, an "ICS/firewall" service yet runs -- NAT and few others it said -- I stopped it and set it to "disabled".

And, now I cannot any longer see the Samba share on the Slack host O.S. Now the *only* net unit is seeing myself, which is "vmXP_blah_blah" (what I had named this Win XP vm guest) file/printer etc. but no share as I've not yet set/specified a or any file share.

BTW my physical LAN is 192.168.1.whatever

DHCP assigned to Slack 12.1 IP for a very long time has been (host IP of this host/guest issue)

A short aside here next.

Ok I already for a long time have had a 100% working (share back and forth via smb and shared folder on host) Windows 2000 SP4 in Qemu/kqemu -- it uses smb and the nat in qemu.

-smb host_share

that is the only LAN thingy in my qemu Win 2K startup command. That one uses NAT and KVM isn't used (qemu/kqemu). But (Win 2K) I had to map a drive letter to the host OS net share in order to get it to work in Win 2K (had error and unable to access until I did the map thing).

End of the aside.

So, recently did the Win XP Pro host OS this one is kvm/qemu. Saw where "kvm-intel" (I've a dual core cpu with 64 and virtualization support) and "tun".

So, thought I'd try to bridge this Win_XP/kvm/qemu

Again, in XP host, the internet web browsing works superbly (I just now tried it again).

Things keep revising as to Linux kernel development versus what used to be needed (I create) versus what's now bundled with the kernel (it's already created/bundled).

Forgot until now to say I'm using a smp kernel with Slack 12.1

my udev rules already looked similar to I'd seen some past (and perhaps also now out dated) "you need to add this to your udev rules". (I did not add/change any).

Did not yet manually create a bridge (for the same reason).

(see next) after (479) since XP guest didn't LAN (specifically to shared host files) then (480) I added -smb shared_folder_on_host (just trying things, not knowing what to do really).

479 /usr/bin/qemu-system-x86_64 -hda ~/virtmach/winxp.qcow -m 896 -no-acpi -localtime -net nic -net user
480 /usr/bin/qemu-system-x86_64 -hda ~/virtmach/winxp.qcow -m 896 -no-acpi -localtime -net nic -net user -smb ~/ntp

My smb.conf:



# workgroup = NT-Domain-Name or Workgroup-Name, eg: LINUX2
workgroup = WORKGROUP
cups options = raw
map to guest = Bad User
domain master = no
restrict anonymous = no
preferred master = no
max protocol = NT
server signing = Auto
domain logons = no
local master = yes
passdb backend = smbpasswd
netbios name = G33T-M2_SW121_SMB
encrypt passwords = yes

path = /home/al
read only = no
force user = root
force group = root
guest account = root
case sensitive = no
guest only = yes
guest ok = yes
browseable = yes
printable =no

path = /mnt/dat_sda8
read only = no
force user = root
force group = root
guest account = root
case sensitive = no
guest only = yes
guest ok = yes
browseable = yes
printable =no

Thanks. Alan.

acummings 12-02-2008 01:16 AM


Kindly recall that I'm on Intel dual core with virtualization technology. My subject line lists my host OS and also the guest OS of my **new VM**

Am I at least close to being on track now as per the next? (And, I'll post results here again once I've tried all of the next).

I don't need qemu/kqemu on this hardware.

So, I think I'll:

# removepkg qemu

And, I'll not load kqemu

And, I need to slackbuild a kvm package and install it.

Does kvm have qemu bundled? (I'm guess that it does).


It "looks" to be easy now (like as in "the 78 kvm being more developed than its predecessors")

I saw in the "78" kvm source code a script or something that creates a bridge and perhaps some other tasks are handled too.

But I would have needed to (I hadn't) either make/install or slackbuild a package of kvm and installpkg

And, (reserved for those who are interested), why I (formerly) hadn't:

I have a late kernel with a kvm module that I manually loaded only when I run my **new VM**

And I had mistakenly thought that since a qemu Slack package is already on my host (**old VM** Win 2k guest from non virt hardware) that this qemu would suffice for the qemu that teams with kvm

kqemu, however, was not loaded when I (had done my attempts with kvm)

kvm kvm kvm kernel virtual machine VM vm network host guest OS os lan share files howto how to help


All times are GMT -5. The time now is 07:30 PM.