-   Slackware (
-   -   KPPP disconnected - exit status: 15 - Sierra Wireless AirCard 580 by Sprint (1xevdo) (

Dennola4 01-25-2009 07:44 PM

KPPP disconnected - exit status: 15 - Sierra Wireless AirCard 580 by Sprint (1xevdo)
Albeit a brand-newbie, I have just had success connecting to the Internet using my AirCard 580.

AT the time of this post the following link is available:

I noticed when booting that the kernel consistently found and identified both the device and the driver so I skipped ahead to the instructions for "Connect Using KPPP". Very easy. After a week of aggravation and feeling too stupid to use Slackware 12.2 it was quite a great feeling to see the magic word: "CONNECTED".

Now my problem seems to be staying connected. I stay connected for a few minutes, then I disconnect. Here is the meassage I get:

Jan 25 19:14:08 localhost pppd[5644]: Cannot determine ethernet address for proxy ARP

Any ideas?

stress_junkie 01-25-2009 08:47 PM

Did you see any of my posts on this issue? I've been using the Sierra 580U for a couple of years. Please use the search feature to find my posts on the subject. At least one of those posts contains detailed instructions for using KPPP with this card.

The specific error message that you listed appears to be related to using a proxy. You should not need to use a proxy.

Dennola4 01-25-2009 09:37 PM

Search Function difficulty
Thank you for the quick response.

So much for the search function, but I did manage to find a post of yours on the subject:

It is almost identical to the Sierra post (above) but for two discrepancies:

1) The Sierra post does not mention changing the PAP/CHAP setting to "script-based".
2) Your instructions do not address naming the modem or selecting "/dev/ttyUSB0". (I find that until the modem is named the "CONNECTION" button is unavailable)

So I basically followed the Sierra instructions verbatim, only now selecting "script-based" as per your advice, crossed my fingers and signed on. For three minutes. And got bumped.

Message: [date] localhost pppd[5644]: Cannot determine ethernet address for proxy ARP

What now?

stress_junkie 01-25-2009 10:58 PM

I'm not sure if the error message pertains to a proxy or if it is an ARP error.

Are you using Sprint for your ISP? I am. I've never seen this kind of error before. I searched the Sprint web support site for that error message. The search returned no references. Grrrr. :-(

Maybe a kind reader will know and educate us both. :-)

Drakeo 01-25-2009 11:44 PM

you Know I do not know much about this usb serial device but I do understand pppoe that uses a pppd and I want you to make sure there is no typo errors ok. for when you login and. you have your interface so it is making a connection and talking to the server now make sure you have your speed set correct and your chaps/paps . another thing you should do it create local host because even though if your using default darkstar then there is a million of them. netconfig.
9 out of 10 times the reason you get bumped is do to a wrong entry.

Dennola4 01-26-2009 02:28 AM

See below >>>

Dennola4 01-26-2009 04:59 AM

See below>>

Dennola4 01-28-2009 01:28 AM

Problem solved!!!
Ok, since uh.... I was pretty much written off (most likely for rambling like a desperate newbie MADMAN) I was forced to solve this problem myself.

Fellow newb with an AirCard, here's what I did:

0) This card was initially activated on XP and it's my (paid) account.

1) I created a user account then signed in as that user.

2) I opened a console and typed

su -i
which made me root for the session.

3) I typed

4) I followed all of the prompts, using the suggested information, only you HAVE TO KNOW your user name and password for Sprint. Not sure? Go to and sign in. Whatever username and password you used there, use here.

5) When prompted for Sprint's IP name or whatever I just put

and for the IP address I put
when this was done I typed

cd /etc/ppp
and hit enter.

6) I typed

vi options
then enter. A list comes up and under modem you see a line that reads /dev/modem which has to be changed to

7) I used the arrow keys to move the cursor to the line I wanted changed, hit the "i" button to input new info, the "esc" button to enter COMMAND mode again, then used the "x" button to delete the unwanted characters. When finished the line should read

8) I typed

to exit visual editor mode (and save changes) and return to command prompt.

9) I closed out terminal session. *whew*


10) I hit the K-Menu button

11) I navigated to "Settings>Internet & Network>Network Settings" and clicked it

12) I clicked the ADMINISTRATOR MODE button at the bottom of the window.

13) I saw two devices: one called ETH0 with a wifi icon next to it, and one called ETH1 with an Ethernet Card Icon next to it. I chose the latter (by clicking it) then clicked the CONFIGURE INTERFACE button.

14) The defaults were already set to "automatic" and "DHCP" so I just hit OK, then I clicked the ENABLE INTERFACE button. When it was done I clicked OK and got outta there. (There was now a green check next to ETH1, and ETH0 was disabled)


15) I printed this off my work computer and used it to set up KPPP, scrolling down and starting at the line "CONNECT USING KPPP":

Then I signed on! :-) Since I'm brand new to all of this I am sure the route I took was not the best. But it worked. I'm sure the Linux gurus have better ways to do it, but unfortunately they didn't offer them here. Anyway, good luck!

All times are GMT -5. The time now is 12:21 PM.