-   Slackware (
-   -   konsole will not start in newest version of -current (

TSquaredF 03-03-2013 06:19 PM

konsole will not start in newest version of -current
I have two computers running the most recent version of -current, an HP desktop & a Toshiba laptop. I am still having this problem with the desktop, but konsole is working perfectly on it. On the laptop, konsole will not start, but xterm works fine. When I run:

konsole &
from xterm. I get the following:

$ konsole &
[1] 2349
$ QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
unnamed app(2349): Communication problem with  "konsole" , it probably crashed.
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "

[1]+  Exit 255                konsole

The first warnings(?) do not appear to be applicable, I get the same thing on the desktop. The Fontconfig warning appears to be the same. It only appeared after I upgraded fontconfig on 03/03/13.
The bolded lines appear to be relevant, but I know nothing about DBus & cannot troubleshoot it. I have reinstalled konsole &, when that didn't work, I redownloaded konsole & installed it again. Neither attempt helped.
Does anyone have any ideas that may help?

frankbell 03-03-2013 09:31 PM

I was unable to duplicate the problem with Current on my Dell 1545; konsole started just fine. I've attached a screencap of the xterm so you can compare the output with yours.

TSquaredF 03-04-2013 09:29 AM

Thanks for the response, Frank. I get the same on my desktop machine, so I don't think it is konsole; must be something else. This appeared, on the laptop only, a couple of days after I upgraded Aliens KDE-4.10 to the one in -current. Maybe my next step is to reinstall DBus, then KDE. Will see what happens.

wildwizard 03-05-2013 03:03 AM

Did you upgrade everything that was in current or just KDE?

TSquaredF 03-05-2013 10:05 AM

I keep -current updated all the way. Yesterday, I ran:

upgradepkg --reinstall *.t?z
in the kde subdirectory of my -current mirror. That did not help, either. I guess my next step is to run the same in all other subdirs, but I'd hate to use that kind of blunderbuss if all that is needed is a rapier.

frankbell 03-05-2013 09:03 PM

Here's an idea for a test. Run xwmconfig and change your window manager to something other than KDE, then see whether you can start Konsole in it.

I suspect it still won't run, but perhaps the error messages will change and tell you something new.

SavoTU 03-06-2013 05:31 AM

I had a few problems after this upgrade because i missed the new packages try


upgradepkg --reinstall --install-new *.t?z

TSquaredF 03-07-2013 10:25 AM

Well, I guess it's time to tie the ribbons on this thread, even though I've found no cure. As mentioned above, I had reinstalled KDE. A couple of days ago, I reinstalled every other Slackware base package, & konsole was still not working. I finally decided to do a complete restart, so yesterday afternoon I formatted another partition & installed -current from scratch. Guess what? Konsole works fine in the new install. I will add the additional packages I use & if everything works OK, I will copy the new partition into the old one & be better off for having cleaned out all of the unused & leftover stuff.

All times are GMT -5. The time now is 09:01 PM.