LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-13-2019, 12:21 PM   #16
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,122

Original Poster
Rep: Reputation: 158Reputation: 158

Quote:
Originally Posted by bassmadrigal View Post
Just a note, the kodi folks prefer using their internal ffmpeg compiled statically into kodi. That's the version they've tested for. They may still offer support on their forum, as I've seen it in the past, but they may choose to tell you they'll only support their internal version.



In regards to your ffmpeg, what all options have you enabled with it?
Here you go:
Code:
libx264=""    ; [ "${X264:-yes}" != "no" ]         && libx264="--enable-libx264"
librtmp=""    ; [ "${RTMP:-yes}" != "no" ]         && librtmp="--enable-librtmp"
libspeex=""   ; [ "${SPEEX:-yes}" != "no" ]       && libspeex="--enable-libspeex"
libxvid=""    ; [ "${XVID:-yes}" != "no" ]         && libxvid="--enable-libxvid"
libass=""     ; [ "${ASS:-yes}" != "no" ]          && libass="--enable-libass"
libopenal=""  ; [ "${OPENAL:-yes}" != "no" ]       && libopenal="--enable-openal"
libopus=""    ; [ "${OPUS:-yes}" != "no" ]        && libopus="--enable-libopus"
libtwolame="" ; [ "${TWOLAME:-yes}" != "no" ]      && libtwolame="--enable-libtwolame"
libvidstab="" ; [ "${VIDSTAB:-yes}" != "no" ]      && libvidstab="--enable-libvidstab"
libx265=""    ; [ "${X265:-yes}" != "no" ]         && libx265="--enable-libx265"
libzvbi=""    ; [ "${ZVBI:-yes}" != "no" ]         && libzvbi="--enable-libzvbi"
fontconfig="" ; [ "${FONTCONFIG:-yes}" != "no" ]  && fontconfig="--enable-libfontconfig"
freetype=""   ; [ "${FREETYPE:-yes}" != "no" ]    && freetype="--enable-libfreetype"
fribidi=""    ; [ "${FRIBIDI:-yes}" != "no" ]     && fribidi="--enable-libfribidi"
gnutls=""     ; [ "${GNUTLS:-yes}" != "no" ]      && gnutls="--enable-gnutls"
libbluray=""  ; [ "${BLURAY:-yes}" != "no" ]      && libbluray="--enable-libbluray"
libcaca=""    ; [ "${CACA:-yes}" != "no" ]        && libcaca="--enable-libcaca"
libcdio=""    ; [ "${LIBCDIO:-yes}" != "no" ]     && libcdio="--enable-libcdio"
libssh=""     ; [ "${LIBSSH:-yes}" != "no" ]      && libssh="--enable-libssh"
libtheora=""  ; [ "${THEORA:-yes}" != "no" ]      && libtheora="--enable-libtheora"
libv4l2=""    ; [ "${V4L2:-yes}" != "no" ]        && libv4l2="--enable-libv4l2"
libvorbis=""  ; [ "${VORBIS:-yes}" != "no" ]      && libvorbis="--enable-libvorbis"
libvpx=""     ; [ "${VPX:-yes}" != "no" ]         && libvpx="--enable-libvpx"
libwebp=""    ; [ "${WEBP:-yes}" != "no" ]        && libwebp="--enable-libwebp"
mp3lame=""    ; [ "${LAME:-yes}" != "no" ]        && mp3lame="--enable-libmp3lame"
opencl=""     ; [ "${OPENCL:-yes}" != "no" ]      && opencl="--enable-opencl"
opengl=""     ; [ "${OPENGL:-yes}" != "no" ]      && opengl="--enable-opengl"
openjpeg=""   ; [ "${JP2:-yes}" != "no" ]         && openjpeg="--enable-libopenjpeg"
pulse=""      ; [ "${PULSEAUDIO:-yes}" != "no" ]  && pulse="--enable-libpulse"
wavpack=""    ; [ "${WAVPACK:-yes}" != "no" ]     && wavpack="--enable-libwavpack"
aac=""        ; [ "${AAC:-yes}" = "no" ]           && aac="--disable-encoder=aac"
 
Old 01-13-2019, 12:21 PM   #17
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 982

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
Looks like a ffmpeg issue, what version/build are you using?
ffmpeg looks to have had some more issues with HLS streams:
https://trac.ffmpeg.org/ticket/4930

Your log looks OK, until the VideoPlayer tries to play the stream and ffmpeg is failing:
Code:
12:45:28.605 T:140509169498624  NOTICE: VideoPlayer: Opening: https://content-ause1.uplynk.com/channel/d0695f6fa2f143eb95c7a41d96d581c4/h.m3u8?ad.kv=_fw_ae,null,_fw_euid,null&exp=1547401647&ptid=ESPN_tvOS_VDMS&rn=238095451&tc=1&oid=d09b16c953aa40c98dd8c513526aca5a&linearv=4&ad=espnlive&ad.csid=watchespn:chromecast_uplynk:espn1:live:en&ad.caid=a110396694&eid=espn_espn1&euid=ESPN3_VDMS&ct=c&sig=0970b3486ab2460973acfc7d3e458c0cecc8c7f3cbbf07399118c4ea19fd43ef&pbs=8ea397f2f1f84b4183de8e060e0392dd
12:45:28.605 T:140509169498624 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
12:45:28.643 T:140509169498624   DEBUG: CCurlFile::GetMimeType - https://content-ause1.uplynk.com/channel/d0695f6fa2f143eb95c7a41d96d581c4/h.m3u8?ad.kv=_fw_ae,null,_fw_euid,null&exp=1547401647&ptid=ESPN_tvOS_VDMS&rn=238095451&tc=1&oid=d09b16c953aa40c98dd8c513526aca5a&linearv=4&ad=espnlive&ad.csid=watchespn:chromecast_uplynk:espn1:live:en&ad.caid=a110396694&eid=espn_espn1&euid=ESPN3_VDMS&ct=c&sig=0970b3486ab2460973acfc7d3e458c0cecc8c7f3cbbf07399118c4ea19fd43ef&pbs=8ea397f2f1f84b4183de8e060e0392dd -> application/vnd.apple.mpegurl
12:45:28.643 T:140509169498624   DEBUG: LinuxRendererGL: Cleaning up GL resources
12:45:28.645 T:140509169498624   DEBUG: CLinuxRendererGL::PreInit - precision of luminance 16 is 16
12:45:28.645 T:140508236080896   DEBUG: Thread VideoPlayer start, auto delete: false
12:45:28.645 T:140508236080896  NOTICE: Creating InputStream
12:45:28.646 T:140508236080896   DEBUG: CurlFile::Open(0x7fca9f7fd6e0) https://content-ause1.uplynk.com/channel/d0695f6fa2f143eb95c7a41d96d581c4/h.m3u8?ad.kv=_fw_ae,null,_fw_euid,null&exp=1547401647&ptid=ESPN_tvOS_VDMS&rn=238095451&tc=1&oid=d09b16c953aa40c98dd8c513526aca5a&linearv=4&ad=espnlive&ad.csid=watchespn:chromecast_uplynk:espn1:live:en&ad.caid=a110396694&eid=espn_espn1&euid=ESPN3_VDMS&ct=c&sig=0970b3486ab2460973acfc7d3e458c0cecc8c7f3cbbf07399118c4ea19fd43ef&pbs=8ea397f2f1f84b4183de8e060e0392dd
12:45:28.893 T:140508236080896  NOTICE: Creating Demuxer
12:45:29.072 T:140508236080896   DEBUG: ffmpeg[7FCA9F7FE700]: [https] the user-agent option is deprecated, please use user_agent option
12:45:29.115 T:140508236080896    INFO: ffmpeg[7FCA9F7FE700]: [hls,applehttp] Opening 'https://content-ause1.uplynk.com/check2?b=29773b78e9074bda8cd05dab529f0852&v=d0695f6fa2f143eb95c7a41d96d581c4&r=h&c=d0695f6fa2f143eb95c7a41d96d581c4&pbs=8ea397f2f1f84b4183de8e060e0392dd' for reading
12:45:29.145 T:140509169498624   DEBUG: ------ Window Init (DialogBusy.xml) ------
12:45:29.252 T:140508236080896   DEBUG: ffmpeg[7FCA9F7FE700]: [https] the user-agent option is deprecated, please use user_agent option
12:45:29.291 T:140508236080896    INFO: ffmpeg[7FCA9F7FE700]: [hls,applehttp] Opening 'crypto+https://x-live-espn-stgec.uplynk.com/ause/slices/297/d09b16c953aa40c98dd8c513526aca5a/29773b78e9074bda8cd05dab529f0852/H00000927.ts?pbs=8ea397f2f1f84b4183de8e060e0392dd&_jt=l&euid=ESPN3_VDMS&chid=d0695f6fa2f143eb95c7a41d96d581c4&ptid=ESPN_tvOS_VDMS&si=0' for reading
12:45:29.354 T:140508236080896   DEBUG: ffmpeg[7FCA9F7FE700]: [https] the user-agent option is deprecated, please use user_agent option
12:45:29.431 T:140508236080896   ERROR: ffmpeg[7FCA9F7FE700]: [crypto] Unable to open resource: https://x-live-espn-stgec.uplynk.com/ause/slices/297/d09b16c953aa40c98dd8c513526aca5a/29773b78e9074bda8cd05dab529f0852/H00000927.ts?pbs=8ea397f2f1f84b4183de8e060e0392dd&_jt=l&euid=ESPN3_VDMS&chid=d0695f6fa2f143eb95c7a41d96d581c4&ptid=ESPN_tvOS_VDMS&si=0
12:45:29.431 T:140508236080896   DEBUG: ffmpeg[7FCA9F7FE700]: [hls,applehttp] Failed to open segment of playlist 0
Please post the output of:
Code:
ffmpeg -buildconf
And eventually try building a newer ffmpeg version with all the required (ssl&stuff) extensions enabled:
http://slackbuilds.org/repository/14...imedia/ffmpeg/
http://www.slackware.com/~alien/slac.../ffmpeg/build/

P.S.
You could use the Kodi modified ffmpeg source tarball:
https://github.com/xbmc/FFmpeg/archi...on-17.5.tar.gz

And it looks like secure.espn.com was down until yesterday:
https://forum.kodi.tv/showthread.php...297#pid2808297

Just for reference, these are the options used by Kodi when it builds ffmpeg on its own:
Code:
./configure --prefix=$FFMPEG_PREFIX \
        --extra-version="kodi-${VERSION}" \
        --disable-devices \
        --disable-ffplay \
        --disable-ffmpeg \
        --disable-sdl \
        --disable-ffprobe \
        --disable-ffserver \
        --disable-doc \
        --enable-gpl \
        --enable-runtime-cpudetect \
        --enable-postproc \
        --enable-vaapi \
        --enable-vdpau \
        --enable-bzlib \
        --enable-gnutls \
        --enable-muxer=spdif \
        --enable-muxer=adts \
        --enable-muxer=asf \
        --enable-muxer=ipod \
        --enable-encoder=ac3 \
        --enable-encoder=aac \
        --enable-encoder=wmav2 \
        --enable-protocol=http \
        --enable-encoder=png \
        --enable-encoder=mjpeg \
        --enable-nonfree \
        --enable-pthreads \
        --enable-pic \
        --enable-zlib \
        --disable-mipsdsp \
        --disable-mipsdspr2 \

Last edited by abga; 01-13-2019 at 12:46 PM. Reason: P.S.
 
Old 01-13-2019, 12:30 PM   #18
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 982

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
Quote:
Originally Posted by bassmadrigal View Post
Just a note, the kodi folks prefer using their internal ffmpeg compiled statically into kodi. That's the version they've tested for. They may still offer support on their forum, as I've seen it in the past, but they may choose to tell you they'll only support their internal version.
Kodi will indeed build its own version of ffmpeg statically, but it fails to build it under Slackware, at least I couldn't make it work. It installs it temporary in the Kodi compilation work directory and then it looks after the ffmpeg pc file (pkgconfig) in the system folders and cannot find it. The hacks they do in the Kodi build scripts work only under Debain/Ubuntu/Whatever.
 
Old 01-13-2019, 12:49 PM   #19
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,952

Rep: Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647
Quote:
Originally Posted by abga View Post
Kodi will indeed build its own version of ffmpeg statically, but it fails to build it under Slackware, at least I couldn't make it work. It installs it temporary in the Kodi compilation work directory and then it looks after the ffmpeg pc file (pkgconfig) in the system folders and cannot find it. The hacks they do in the Kodi build scripts work only under Debain/Ubuntu/Whatever.
I use Larry's kodi SlackBuild on SBo and I've never ran into issues with it not working.
 
Old 01-13-2019, 01:03 PM   #20
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 982

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
Quote:
Originally Posted by bassmadrigal View Post
I use Larry's kodi SlackBuild on SBo and I've never ran into issues with it not working.
That SlackBuild has changed recently, before it had --with-ffmpeg=shared by default and it looks like Kodi can build ffmpeg now under Slackware, maybe the Kodi build scripts changed in 17.6 or I only tried to build it under -current, but I do remember that issue with the pc file and also remember asking for help / questioning the "bright idea" of pseduo-installing ffmpeg in a temp folder in the Kodi forum.
 
Old 01-13-2019, 01:07 PM   #21
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 982

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
@stormtracknole

I advised you to rebuild ffmpeg with openssl and you said it didn't help. In your post #16 I noticed that you don't have TLS enabled:
Code:
gnutls=""     ; [ "${GNUTLS:-yes}" != "no" ]      && gnutls="--enable-gnutls"

EDIT!
Actually I don't understand that output at all and I'm not sure now if --enable-gnutls was used or not during the build. Please post the output of ffmpeg -buildconf as requested in #17


Try rebuilding ffmpeg with only --enable-gnutls and don't enable openssl.
I also updated my post here (P.S. section):
https://www.linuxquestions.org/quest...ml#post5948296

Last edited by abga; 01-13-2019 at 01:12 PM. Reason: EDIT!
 
Old 01-13-2019, 01:36 PM   #22
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,952

Rep: Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647
Quote:
Originally Posted by abga View Post
That SlackBuild has changed recently, before it had --with-ffmpeg=shared by default and it looks like Kodi can build ffmpeg now under Slackware, maybe the Kodi build scripts changed in 17.6 or I only tried to build it under -current, but I do remember that issue with the pc file and also remember asking for help / questioning the "bright idea" of pseduo-installing ffmpeg in a temp folder in the Kodi forum.
Looking through the SlackBuild's changelog, I don't see where it's changed. He still has it optional, but has it disabled by default. I've been using his SlackBuild since 2015 and it's always used an internal ffmpeg (before that, I was building kodi and xbmc manually). I don't remember ever running into an issue where it wasn't working as planned.
 
Old 01-13-2019, 01:37 PM   #23
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,952

Rep: Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647
Quote:
Originally Posted by abga View Post
@stormtracknole

I advised you to rebuild ffmpeg with openssl and you said it didn't help. In your post #16 I noticed that you don't have TLS enabled:
Code:
gnutls=""     ; [ "${GNUTLS:-yes}" != "no" ]      && gnutls="--enable-gnutls"

EDIT!
Actually I don't understand that output at all and I'm not sure now if --enable-gnutls was used or not during the build. Please post the output of ffmpeg -buildconf as requested in #17
He's changed the defaults from no to yes on the options he listed. So it should pass --enable-gnutls to the ./configure.
 
1 members found this post helpful.
Old 01-13-2019, 01:54 PM   #24
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,122

Original Poster
Rep: Reputation: 158Reputation: 158
Sorry for clipping the other configure options. Was pasting this stuff before going out to run some errands.

Code:
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --shlibdir=/usr/lib${LIBDIRSUFFIX} \
  --docdir=/usr/doc/$PKGNAM-$VERSION/html \
  --mandir=/usr/man \
  --disable-debug \
  --enable-shared \
  --disable-static \
  --enable-gpl \
  --enable-version3 \
  --enable-avresample \
  --enable-openssl \
I wanted to make sure that openssl was built. Here's the output for ffmpeg -buildconf:
Code:
configuration:
    --prefix=/usr
    --libdir=/usr/lib64
    --shlibdir=/usr/lib64
    --docdir=/usr/doc/ffmpeg-3.4.5/html
    --mandir=/usr/man
    --disable-debug
    --enable-shared
    --disable-static
    --enable-gpl
    --enable-version3
    --enable-avresample
    --enable-openssl
    --enable-nonfree
    --arch=x86_64
    --enable-libfontconfig
    --enable-libfreetype
    --enable-libfribidi
    --enable-gnutls
    --enable-libass
    --enable-libbluray
    --enable-libcaca
    --enable-libcdio
    --enable-openal
    --enable-libopus
    --enable-librtmp
    --enable-libspeex
    --enable-libssh
    --enable-libtheora
    --enable-libtwolame
    --enable-libv4l2
    --enable-libvidstab
    --enable-libvorbis
    --enable-libvpx
    --enable-libwebp
    --enable-libx264
    --enable-libx265
    --enable-libxvid
    --enable-libzvbi
    --enable-libmp3lame
    --enable-opencl
    --enable-opengl
    --enable-libopenjpeg
    --enable-libpulse
    --enable-libwavpack
I saw gnutls, but thought this was deprecated. Let me go ahead and rebuild now.

EDIT

I'm also the latest version provided by Slackware.

Last edited by stormtracknole; 01-13-2019 at 01:55 PM. Reason: Edited to add version.
 
Old 01-13-2019, 01:58 PM   #25
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,122

Original Poster
Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by bassmadrigal View Post
He's changed the defaults from no to yes on the options he listed. So it should pass --enable-gnutls to the ./configure.
Correct! Just realized this. It is enabled by default (--enable-gnutls) as you can see from my output on the previous post.
 
Old 01-13-2019, 02:17 PM   #26
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 982

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
The default configuration set for ffmpeg that the Kodi build is using (post #17 - P.S. section) doesn't contain openssl but only --enable-gnutls and it should work. There could be issues if both openssl and gnutls are enabled, so remove --enable-openssl and only leave --enable-gnutls:
https://trac.ffmpeg.org/ticket/5915
 
Old 01-13-2019, 02:24 PM   #27
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,122

Original Poster
Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by abga View Post
The default configuration set for ffmpeg that the Kodi build is using (post #17 - P.S. section) doesn't contain openssl but only --enable-gnutls and it should work. There could be issues if both openssl and gnutls are enabled, so remove --enable-openssl and only leave --enable-gnutls:
https://trac.ffmpeg.org/ticket/5915
That is what I had originally.
 
Old 01-13-2019, 02:38 PM   #28
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 982

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
Quote:
Originally Posted by bassmadrigal View Post
Looking through the SlackBuild's changelog, I don't see where it's changed. He still has it optional, but has it disabled by default. I've been using his SlackBuild since 2015 and it's always used an internal ffmpeg (before that, I was building kodi and xbmc manually). I don't remember ever running into an issue where it wasn't working as planned.
Yep, it was the other way around, using static by default and optional to use the shared ffmpeg. I never built Kodi under x86 but only struggled to make it work under Slackware ARM and there was where I needed to separately build ffmpeg and provide it as shared lib to Kodi.
And, never used Larry's script (just for inspiration about the patches), except only when I documented the installation process for Kodi under Slackware ARM for Raspberry Pi:
https://www.linuxquestions.org/quest...hf-4175613852/

Besides, I regard Larry's kodi.SlackBuild broken because it deletes the cmake files that are actually needed for building&installing add-ons:
Code:
# Final clean up.
find $PKG \( -name "Makefile*" -o -name "*cmake*" -o -name "*\.in" \) -exec rm -f '{}' \;
Err:
Quote:
(before that, I was building kodi and xbmc manually)
You mean: "I was building kodi and ffmpeg manually"

Last edited by abga; 01-13-2019 at 03:06 PM. Reason: typo
 
Old 01-13-2019, 03:03 PM   #29
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 982

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
Quote:
Originally Posted by stormtracknole View Post
That is what I had originally.
Dunno what to say then, if you used Larry's Kodi Slackbuild, then your ffmpeg is the one Kodi provides (source tarball) and it should be properly configured, built and working fine.

Some other tries:
- make sure date/time is properly configured on your system
- update the certificates
Code:
/usr/sbin/update-ca-certificates --fresh
- try getting some help in the Kodi forum...

P.S.
I remember you also did a Kodi installation on Raspberry Pi 3 under Slackware ARM and that installation has only one version of ffmpeg (shared), the one you built for enabling the HW acceleration (decoding video streams). Can you check if that installation is working with this video Add-on ?

Last edited by abga; 01-13-2019 at 03:12 PM. Reason: P.S.
 
Old 01-13-2019, 03:11 PM   #30
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,952

Rep: Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647
Quote:
Originally Posted by abga View Post
besides, I regard Larry's kodi.SlackBuild broken because it deletes the cmake files that are actually needed for installing add-ons:
Code:
# Final clean up.
find $PKG \( -name "Makefile*" -o -name "*cmake*" -o -name "*\.in" \) -exec rm -f '{}' \;
I've never ran into problems with addons not being able to be installed, however, I do pretty much keep to the official kodi addons (except for one 3rd-party addon that I use to watch a program that is streamed twice a year).

What addons haven't you been able to install because of that line? And if you present that info to Larry, he might be willing to change his script. He switched libmicrohttpd from an optional to required dependency after I requested it and explaining why I thought it should be default.

Quote:
Originally Posted by abga View Post
Err:

You mean: "I was building kodi and ffmpeg manually"
No, I meant that I was building kodi, and before that xbmc, manually. I've been building xbmc/kodi since Dharma and have always used the internal version. In older versions, ffmpeg was included directly in the xbmc source, but in the newer versions (from Helix on up), they grab the tarball from their own github and will build during kodi's compilation (see tools/depends/target/ffmpeg/autobuild.sh). Larry's script will take a pre-downloaded tarball and link it to the correct spot in the source tree so kodi doesn't download ffmpeg itself (since SBo doesn't permit downloading things once the SlackBuild has been run).
 
  


Reply

Tags
addons, espn, kodi


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Kodi Devs Celebrate New Year with First Release Candidate of Kodi 17 "Krypton" LXer Syndicated Linux News 0 01-01-2017 12:00 AM
[SOLVED] Kodi freezes on exit, kodi.bin won't die pressman57 Linux - Software 6 12-19-2016 07:48 PM
How to make firefox add-ons universally and not just on a particular user redhatwannabe Linux - Software 3 05-26-2009 04:27 AM
Debian Iceweasel Add-ons Not Working digerati1338 Linux - Desktop 2 01-19-2008 12:58 PM
Firefox Add-ons install but don't show up after restart, 'preferences' not working mbvpixies78 Linux - Software 4 12-07-2007 02:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration