LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-12-2019, 02:57 PM   #1
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,122

Rep: Reputation: 158Reputation: 158
Question kodi with video add-ons not working


I've used kodi in the past via raspbian and fedora. I've recently started building it from source for Slackware. I can get my video files to play just fine. However, I'm having an issue with certain add-ons, specifically the ESPN3 app. After I authenticate my credentials, no videos ever play. It always works with Raspbian and Fedora. So I'm wondering, am I'm missing a step here with the compiling process? Based on some of the cryptic logs, the problem may be ffmpeg related?

Any tips would be greatly appreciated. Thanks!
 
Old 01-12-2019, 04:55 PM   #2
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 982

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
Quote:
Originally Posted by stormtracknole View Post
Based on some of the cryptic logs, the problem may be ffmpeg related?
Care to post the logs? Clear your private information and upload the "cryptic logs" somewhere -> https://pastebin.com/
There are also some known issues:
https://kodi.wiki/view/Add-on:ESPN_3
- scroll down the page to paragraph 7
And 39 pages of discussions about that Add-On:
https://forum.kodi.tv/showthread.php?tid=230418&page=39
 
Old 01-12-2019, 04:59 PM   #3
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,963

Rep: Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656
In addition to the logs that abga requested, you also mentioned you're having problems with other addons. What addons are those? Are they all streaming addons? Are you able to use the official youtube addon?

I use kodi a lot (mostly for local media) and I was able to use youtube (which I do use semi-frequently), nasa, and some comedy one... maybe comedy central? All are from the official repo.
 
Old 01-12-2019, 05:19 PM   #4
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 982

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
I'm also using Kodi everyday for my media needs and able to play whatever I like. I do however remember that some online services (can't remember exactly which) needed the inputstream.adaptive Add-On as dependency, so I had to build&install it:
https://github.com/peak3d/inputstrea...e/tree/Krypton

For Kodi Krypton (17.x) get the zip and unpack it from:
https://github.com/peak3d/inputstrea...ve/Krypton.zip
Then build&install it:
Code:
cd inputstream.adaptive-Krypton/
cmake -DCMAKE_INSTALL_PREFIX=/usr
make && make install
ldconfig
 
1 members found this post helpful.
Old 01-12-2019, 05:33 PM   #5
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,122

Original Poster
Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by abga View Post
I'm also using Kodi everyday for my media needs and able to play whatever I like. I do however remember that some online services (can't remember exactly which) needed the inputstream.adaptive Add-On as dependency, so I had to build&install it:
https://github.com/peak3d/inputstrea...e/tree/Krypton

For Kodi Krypton (17.x) get the zip and unpack it from:
https://github.com/peak3d/inputstrea...ve/Krypton.zip
Then build&install it:
Code:
cd inputstream.adaptive-Krypton/
cmake -DCMAKE_INSTALL_PREFIX=/usr
make && make install
ldconfig
Good find. I'm sure I'm just missing a plugin. Here's a snippet of the output when I have debug turned on:
Code:
18:30:41.911 T:139686697760512   ERROR: ffmpeg[7F0B57FFF700]: [crypto] Unable to open resource: https://x-live-espn-stgec.uplynk.com/ause/slices/c83/d09b16c953aa40c98dd8c513526aca5a/c83a5041865c4839aa96bbfbf5cda7f2/H00000087.ts?pbs=1ca5d17ee67d4ffdba436a124f9c7234&_jt=l&euid=ESPN3_VDMS&chid=d0695f6fa2f143eb95c7a41d96d581c4&ptid=ESPN_tvOS_VDMS&si=0
18:30:41.911 T:139686697760512   DEBUG: ffmpeg[7F0B57FFF700]: [hls,applehttp] Failed to open segment of playlist 0
18:30:43.113 T:139686697760512   ERROR: ffmpeg[7F0B57FFF700]: [hls,applehttp] Error when loading first segment 'https://x-live-espn-stgec.uplynk.com/ause/slices/c83/d09b16c953aa40c98dd8c513526aca5a/c83a5041865c4839aa96bbfbf5cda7f2/H00000080.ts?pbs=1ca5d17ee67d4ffdba436a124f9c7234&_jt=l&euid=ESPN3_VDMS&chid=d0695f6fa2f143eb95c7a41d96d581c4&ptid=ESPN_tvOS_VDMS&si=0'
18:30:43.115 T:139686697760512   DEBUG: Error, could not open file https://content-ausw2.uplynk.com/channel/d0695f6fa2f143eb95c7a41d96d581c4/h.m3u8?ad.kv=_fw_ae,null,_fw_euid,null&exp=1547335930&ptid=ESPN_tvOS_VDMS&rn=24616011&tc=1&oid=d09b16c953aa40c98dd8c513526aca5a&linearv=4&ad=espnlive&ad.csid=watchespn:chromecast_uplynk:espn1:live:en&ad.caid=a111358093&eid=espn_espn1&euid=ESPN3_VDMS&ct=c&sig=d3ea14602e0805224c18518ffa89c1808fb8e260a2946370409b60db52b7e053&pbs=1ca5d17ee67d4ffdba436a124f9c7234
18:30:43.115 T:139686697760512   ERROR: OpenDemuxStream - Error creating demuxer
18:30:43.115 T:139686697760512  NOTICE: CVideoPlayer::OnExit()
18:30:43.115 T:139686697760512   DEBUG: OnPlayBackStopped: play state was 1, starting 1
18:30:43.115 T:139686697760512   DEBUG: Thread VideoPlayer 139686697760512 terminating
18:30:43.128 T:139688721385984   DEBUG: OnPlayBackStopped: play state was 3, starting 0
18:30:43.128 T:139688721385984   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.espn_3/?EVENT_PARENTAL_RATING=U&EVENT_ID=3475581&EVENT_NAME=%233+Tennessee+vs.+Florida+%28M+Basketball%29&MODE=PLAY_TV&CHANNEL_RESOURCE_ID=espn1&NETWORK_NAME=espn1&EVENT_GUID=espn1%2F%233+Tennessee+vs.+Florida+%28M+Basketball%29%2F3475581&SESSION_URL=http%3A%2F%2Fbroadband.espn.go.com%2Fespn3%2Fauth%2Fwatchespn%2FstartSession%3Fchannel%3Despn1%26simulcastAiringId%3D110407246]
18:30:43.128 T:139688721385984   DEBUG: Playlist Player: one or more items failed to play... aborting playback
18:30:43.128 T:139688721385984   DEBUG: ------ Window Init (DialogConfirm.xml) ------
18:30:43.128 T:139688721385984    INFO: Loading skin file: DialogConfirm.xml, load type: KEEP_IN_MEMORY
18:30:43.130 T:139688721385984  NOTICE: CVideoPlayer::CloseFile()
18:30:43.130 T:139688721385984  NOTICE: VideoPlayer: waiting for threads to exit
18:30:43.130 T:139688721385984  NOTICE: VideoPlayer: finished waiting
18:30:43.131 T:139688721385984   DEBUG: DeleteRenderer - deleting renderer
18:30:43.131 T:139688721385984   DEBUG: LinuxRendererGL: Cleaning up GL resources
18:30:43.132 T:139688721372928   DEBUG: CAnnouncementManager - Announcement: OnStop from xbmc
18:30:43.132 T:139688721372928   DEBUG: GOT ANNOUNCEMENT, type: 1, from xbmc, message OnStop
18:30:43.146 T:139688721385984  NOTICE: CVideoPlayer::CloseFile()
18:30:43.146 T:139688721385984  NOTICE: VideoPlayer: waiting for threads to exit
18:30:43.146 T:139688721385984  NOTICE: VideoPlayer: finished waiting
18:30:43.147 T:139688721385984   DEBUG: Radio UECP (RDS) Processor - delete ~CDVDRadioRDSData
18:30:43.329 T:139688721385984    INFO: CheckIdle - Closing session to https://content-ausw2.uplynk.com (easy=0x5009390, multi=0x7f0b8c0d31b0)
18:30:43.329 T:139686697760512   DEBUG: Thread JobWorker start, auto delete: true
18:30:43.329 T:139686697760512   DEBUG: DoWork - Saving file state for video item plugin://plugin.video.espn_3/?EVENT_PARENTAL_RATING=U&EVENT_ID=3475581&EVENT_NAME=%233+Tennessee+vs.+Florida+%28M+Basketball%29&MODE=PLAY_TV&CHANNEL_RESOURCE_ID=espn1&NETWORK_NAME=espn1&EVENT_GUID=espn1%2F%233+Tennessee+vs.+Florida+%28M+Basketball%29%2F3475581&SESSION_URL=http%3A%2F%2Fbroadband.espn.go.com%2Fespn3%2Fauth%2Fwatchespn%2FstartSession%3Fchannel%3Despn1%26simulcastAiringId%3D110407246
18:30:43.367 T:139688721385984   DEBUG: ------ Window Deinit (DialogBusy.xml) ------
There was another application that I was having issues with, but I can't remember now. It had to do with premium video though. Fedora must be including a plugin by default when installing their version. I may have to fire up a virtual machine or a docker image to see what in all gets pulled in as far as dependencies.
 
Old 01-12-2019, 06:02 PM   #6
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,122

Original Poster
Rep: Reputation: 158Reputation: 158
It looks like ffmpeg cannot handle protected HLS streams.

link

I have to figure out how the other distributions are building kodi.
 
Old 01-12-2019, 06:14 PM   #7
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 982

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
Could be, google links&inter-links pointed me to this:
https://trac.ffmpeg.org/ticket/6295

Edit your post and add more from your log, the lines before the first line from your snippet could be interesting:
Code:
18:30:41.911 T:139686697760512   ERROR: ffmpeg[7F0B57FFF700]: [crypto] Unable to open resource: https://x-live-espn-stgec.uplynk.com/ause/slices/c83/d09b16c953aa40c98dd8c513526aca5a/c83a5041865c4839aa96bbfbf5cda7f2/H00000087.ts?pbs=1ca5d17ee67d4ffdba436a124f9c7234&_jt=l&euid=ESPN3_VDMS&chid=d0695f6fa2f143eb95c7a41d96d581c4&ptid=ESPN_tvOS_VDMS&si=0
I mean, the plugin init, the first ffmpeg call, etc.
Is your FFMPEG built with SSL support ?
 
Old 01-12-2019, 06:40 PM   #8
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,122

Original Poster
Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by abga View Post
Could be, google links&inter-links pointed me to this:
https://trac.ffmpeg.org/ticket/6295

Edit your post and add more from your log, the lines before the first line from your snippet could be interesting:
Code:
18:30:41.911 T:139686697760512   ERROR: ffmpeg[7F0B57FFF700]: [crypto] Unable to open resource: https://x-live-espn-stgec.uplynk.com/ause/slices/c83/d09b16c953aa40c98dd8c513526aca5a/c83a5041865c4839aa96bbfbf5cda7f2/H00000087.ts?pbs=1ca5d17ee67d4ffdba436a124f9c7234&_jt=l&euid=ESPN3_VDMS&chid=d0695f6fa2f143eb95c7a41d96d581c4&ptid=ESPN_tvOS_VDMS&si=0
I mean, the plugin init, the first ffmpeg call, etc.
Is your FFMPEG built with SSL support ?
Here's from a previous log file that I had saved:
Code:
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: system rules
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: matches rule: system rules
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: mms/udp
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: lastfm/shout
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: rtmp
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: rtsp
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: streams
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: matches rule: streams
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: aacp/sdp
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: mp2
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: dvd
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: dvdimage
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: sdp/asf
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: nsv
15:45:13.374 T:140693586749952   DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: radio
15:45:13.374 T:140693586749952   DEBUG: CPlayerCoreFactory::GetPlayers: matched 0 rules with players
15:45:13.374 T:140693586749952   DEBUG: CPlayerCoreFactory::GetPlayers: adding videodefaultplayer (VideoPlayer)
15:45:13.374 T:140693586749952   DEBUG: CPlayerCoreFactory::GetPlayers: for video=1, audio=0
15:45:13.374 T:140693586749952   DEBUG: CPlayerCoreFactory::GetPlayers: for video=1, audio=1
15:45:13.374 T:140693586749952   DEBUG: CPlayerCoreFactory::GetPlayers: added 1 players
15:45:13.375 T:140693586749952   DEBUG: Radio UECP (RDS) Processor - new CDVDRadioRDSData
15:45:13.376 T:140693586749952  NOTICE: VideoPlayer: Opening: https://content-auso1.uplynk.com/channel/d0695f6fa2f143eb95c7a41d96d581c4/h.m3u8?ad.kv=_fw_ae,null,_fw_euid,null&exp=1547326030&ptid=ESPN_tvOS_VDMS&rn=272906459&tc=1&oid=d09b16c953aa40c98dd8c513526aca5a&linearv=4&ad=espnlive&ad.csid=watchespn:chromecast_uplynk:espn1:live:en&ad.caid=a111038066&eid=espn_espn1&euid=ESPN3_VDMS&ct=c&sig=75b5679e5487f107e670376fe0ca5a0e8baa9af31bdfe07eebd6157ff8f8a284&pbs=295ddbd78c5e4f47ba0268c3588829a6
15:45:13.376 T:140693586749952 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
My ffmpeg is not built with SSL support. Let me try that.
 
Old 01-12-2019, 08:05 PM   #9
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 982

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
Check the P.S. from:
https://www.linuxquestions.org/quest...ml#post5948296
 
Old 01-12-2019, 08:27 PM   #10
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,122

Original Poster
Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by abga View Post
No luck. I built ffmpeg with ssl support, and I'm still getting the same error. :/

I should be building kodi with:
Code:
--with-ffmpeg=shared
in order to pick up ffmpeg that I'm building separately, correct?

Last edited by stormtracknole; 01-12-2019 at 08:28 PM.
 
Old 01-12-2019, 08:30 PM   #11
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 982

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
With that error you get you might receive some proper help if you post it in the Kodi forums https://forum.kodi.tv/

On building Kodi with --with-ffmpeg=shared - Positive! Otherwise Kodi will build ffmpeg by itself.
 
Old 01-12-2019, 08:59 PM   #12
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,122

Original Poster
Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by abga View Post
With that error you get you might receive some proper help if you post it in the Kodi forums https://forum.kodi.tv/

On building Kodi with --with-ffmpeg=shared - Positive! Otherwise Kodi will build ffmpeg by itself.
Thanks for your pointers. This has been bugging me for a while now. ha, ha! I know I can just use Fedora or Raspbian for my Raspberry, but I feel as this would the easy way out. I have to be missing an addon or something. I'll give it a couple of more days of poking around before moving going to the kodi forum. The folks here at LQ are pretty solid, and friendly. Hopefully the folks at the Kodi forums will be the same way.
 
Old 01-13-2019, 10:22 AM   #13
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 982

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
Quote:
Originally Posted by stormtracknole View Post
The folks here at LQ are pretty solid, and friendly. Hopefully the folks at the Kodi forums will be the same way.
The folks at Kodi are definitely more knowledgeable about the Kodi product and they are nice and helpful if it comes to issues like yours, just don't try to get them out of their Debian/Ubuntu realm, focus only on Kodi. They won't help you if you're not providing the full debug log, like I asked you in my first reply. Also be careful not to use some "illegal" Kodi add-on, they'll refuse to look into your issue if they spot such add-ons in your log - it's their support policy.
 
Old 01-13-2019, 11:53 AM   #14
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,122

Original Poster
Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by abga View Post
The folks at Kodi are definitely more knowledgeable about the Kodi product and they are nice and helpful if it comes to issues like yours, just don't try to get them out of their Debian/Ubuntu realm, focus only on Kodi. They won't help you if you're not providing the full debug log, like I asked you in my first reply. Also be careful not to use some "illegal" Kodi add-on, they'll refuse to look into your issue if they spot such add-ons in your log - it's their support policy.
Ah, that's right. I forgot to use pastebin. Here's the full log. I'm not using any illegal add-ons. This one is available by default without using any tweaks.

Last edited by stormtracknole; 01-13-2019 at 11:54 AM.
 
Old 01-13-2019, 12:14 PM   #15
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,963

Rep: Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656Reputation: 3656
Just a note, the kodi folks prefer using their internal ffmpeg compiled statically into kodi. That's the version they've tested for. They may still offer support on their forum, as I've seen it in the past, but they may choose to tell you they'll only support their internal version.

Quote:
Kodi builds that use external ffmpeg/libav are not supported and are strongly discouraged.

SOURCE: https://kodi.wiki/view/Linux_FAQ
In regards to your ffmpeg, what all options have you enabled with it?
 
  


Reply

Tags
addons, espn, kodi


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Kodi Devs Celebrate New Year with First Release Candidate of Kodi 17 "Krypton" LXer Syndicated Linux News 0 01-01-2017 12:00 AM
[SOLVED] Kodi freezes on exit, kodi.bin won't die pressman57 Linux - Software 6 12-19-2016 07:48 PM
How to make firefox add-ons universally and not just on a particular user redhatwannabe Linux - Software 3 05-26-2009 04:27 AM
Debian Iceweasel Add-ons Not Working digerati1338 Linux - Desktop 2 01-19-2008 12:58 PM
Firefox Add-ons install but don't show up after restart, 'preferences' not working mbvpixies78 Linux - Software 4 12-07-2007 02:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration