LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Slackware (http://www.linuxquestions.org/questions/forumdisplay.php?f=14)
-   -   Kms: framebuffer change during boot (http://www.linuxquestions.org/questions/showthread.php?t=4175444887)

maciuszek 01-09-2013 07:32 PM

Kms: framebuffer change during boot
 
I really don't need help with this, although there probably is a better so im looking for advice as well this thread itself might help others altogether.

/* There could be an easier and cleaner fix although i have yet to understand why kms must load, had a look at kernel links to the module although no luck on making those modular themselves. */

With kernel mode settings being curial for many video cards i assume a lot of people are dealing with this as well. For people like me, that are annoyed that the bootup flashes and changes the fb to the kms fb upon loading the driver. I found what i think is the most reasonable fix. Essentially the modesetting will be done at the begging of the runlevel 4 start phase.

This could probably be also done with blacklisting and force loading of the module although i don't like the idea of force loading since there might be other reasons why a module should not be loaded ( conflict ? )

/* My video card is an intel although this should work for any other video card with respectful 'i915' sed's */

Primarily im booting with modesetting set to 0 and of course no vga fb, ( make sure to have no other frambuffer built into your kernel aswell )

Code:

lilo.conf:
append="i915.modeset=0 video=800x450"
...
..
.

then i find that the best place to change this setting ( allowing intel to be happy ) is in /etc/rc.d/rc.4 script, since this is when X will be called(linked) to start. I'm personally content being in a cli run level without a extra pretty fb.

simply i added this to the top of my rc.4:

Code:

# User Added
/sbin/rmmod i915
/sbin/modprobe i915 modeset=1
# End User Added

# Tell the viewers what's going to happen...
echo "Starting up X11 session manager..."
...
..
.

and now everything works fine, :) then second you see the first flash the second one from X starting will kick ( assuming your default runlevel is 4 ). Really basic and ugly fix but I'm happier with it like this, so i decided to share.

/* Like i said if there is a better way please advise */

Didier Spaier 01-10-2013 12:28 PM

Well, as the saying goes there is more than one way to skin a cat.

I personnally use run level 3 not 4 and have a nVidia GPU (using the nouveau driver), not an Intel one.

That said to avoid the screen handover during the boot sequence I just blacklist nouveau (and have set up VGA=normal in /etc/lilo.conf).

This doesn't hurt as nouveau will be automagically loaded at X startup anyway.

parcox 01-11-2013 02:07 AM

Hi maciuszek,
I have an i915 based graphic card too and this hack is what I'm looking for. One question.. Is there any chance to get the scrollback works on VT after the kernel module is loaded with modeset=1 option? Thanks.


All times are GMT -5. The time now is 03:03 PM.