LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
 
Search this Thread
Old 05-13-2013, 06:42 PM   #1
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 47

Rep: Reputation: 0
kmix problem in kde -current64


Hi all there, I did a fresh slack64 14 (no multilib) install and right after I moved to current.

After reboot the system looks ok, except the volume icon on the kde bar indicates no volume (silence) but sound comes out the same. I click to set the volume and the PCM slider is gone.

The only solution is kill kmix and restart it. Click on the icon and now PCM slider appears and I can control the volume no problem.

This happens every time I boot.

My system:

Code:
Linux darkstar 3.8.13 #1 SMP Mon Sep 17 13:38:05 CDT 2012 x86_64 Intel(R) Pentium(R) 4 CPU 3.06GHz GenuineIntel GNU/Linux
Code:
bash-4.2# lspci 
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
00:06.0 System peripheral: Intel Corporation 82865G/PE/P Processor to I/O Memory Interface (rev 02)
00:1d.0 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 Ethernet controller: Atheros Communications Inc. AR2417 Wireless Network Adapter [AR5007G 802.11bg] (rev 01)
01:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Any help welcome
 
Old 05-13-2013, 07:28 PM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,730

Rep: Reputation: 975Reputation: 975Reputation: 975Reputation: 975Reputation: 975Reputation: 975Reputation: 975Reputation: 975
Try explicitly specifying 'model=auto' to the snd-hda-intel kernel module.
http://docs.slackware.com/howtos:har..._snd-hda-intel
 
Old 05-13-2013, 08:49 PM   #3
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 47

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by allend View Post
Try explicitly specifying 'model=auto' to the snd-hda-intel kernel module.
http://docs.slackware.com/howtos:har..._snd-hda-intel
I added the line
Code:
options snd-hda-intel model=auto
to /etc/modprobe.d/snd-hda-intel.conf and still the same problem

Code:
bash-4.2# lsmod | grep snd
snd_intel8x0           27231  1 
snd_ac97_codec        113139  1 snd_intel8x0
snd_pcm                72864  2 snd_ac97_codec,snd_intel8x0
snd_page_alloc          7081  2 snd_pcm,snd_intel8x0
snd_timer              18798  1 snd_pcm
snd                    57796  6 snd_timer,snd_pcm,snd_ac97_codec,snd_intel8x0
soundcore               5474  1 snd
ac97_bus                1198  1 snd_ac97_codec
Code:
bash-4.2# cat /proc/asound/card*/codec* | grep Codec
cat: /proc/asound/card0/codec97#0: its a directory
 
Old 05-13-2013, 10:02 PM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,730

Rep: Reputation: 975Reputation: 975Reputation: 975Reputation: 975Reputation: 975Reputation: 975Reputation: 975Reputation: 975
Scratch that idea. Your device uses the snd_intel8x0 kernel module and not the snd-hda-intel kernel module.

Try 'echo "options snd-intel8x0 buggy_irq=1" > /etc/modprobe.d/snd-intel8x0.conf' after removing /etc/modprobe.d/snd-hda-intel.conf.
 
Old 05-14-2013, 10:17 AM   #5
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 47

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by allend View Post
Scratch that idea. Your device uses the snd_intel8x0 kernel module and not the snd-hda-intel kernel module.

Try 'echo "options snd-intel8x0 buggy_irq=1" > /etc/modprobe.d/snd-intel8x0.conf' after removing /etc/modprobe.d/snd-hda-intel.conf.
Still the same. I think it's a KDE issue more than a driver problem
 
Old 05-14-2013, 07:41 PM   #6
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,730

Rep: Reputation: 975Reputation: 975Reputation: 975Reputation: 975Reputation: 975Reputation: 975Reputation: 975Reputation: 975
I was exploring the possibility that your device was not being successfully initialised.
You could try this. http://www.linuxquestions.org/questi...5/#post4289480
 
Old 05-14-2013, 07:57 PM   #7
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,809

Rep: Reputation: 235Reputation: 235Reputation: 235
From the Changelog:

Quote:
Fri May 3 03:23:05 UTC 2013
ap/alsa-utils-1.0.27-x86_64-1.txz: Upgraded.
Added rc.alsa-oss script, disabled by default so that applications that try
to use OSS compatibility when they could be using ALSA won't steal exclusive
access to the audio device.
Obviously the default config in KDE needs to be changed. This is the danger of using -current.

If you want it to work the way it did previously, you need to enable the new rc.alsa-oss script.

Last edited by rkelsen; 05-14-2013 at 08:01 PM.
 
Old 05-15-2013, 08:54 PM   #8
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 47

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rkelsen View Post
From the Changelog:
Obviously the default config in KDE needs to be changed. This is the danger of using -current.
If you want it to work the way it did previously, you need to enable the new rc.alsa-oss script.
thx rkelsen, but re-enabling the rc.oss script didn't solve the issue. I still have to kill kmix and run it again for each boot
 
Old 05-16-2013, 11:06 AM   #9
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 47

Original Poster
Rep: Reputation: 0
Last batch of updates in -current seems to do the trick, now works again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kde 4.1.2,no kmix and nothing to untar pkgs.????? rixtr66 Slackware 2 10-23-2008 05:03 PM
Kmix window always apears on KDE start falcon56215 Linux - Software 5 04-03-2007 03:36 PM
KDE Kmix Crashing and Sound Issues Hollowpoint Linux - Newbie 2 03-30-2005 03:00 AM
KMix (KDE AudioMixer)... marsques Linux - Software 4 05-14-2004 05:08 PM
Kmix menubar in KDE has disappeared kousik_s Mandriva 4 09-29-2003 04:03 AM


All times are GMT -5. The time now is 03:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration