LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-08-2003, 06:01 PM   #1
Raptor Ramjet
Member
 
Registered: Apr 2003
Location: Under a rock
Distribution: Slackware "current" - Praise "Bob" !!!!
Posts: 92

Rep: Reputation: 15
Angry Keyboard map used by X is different to that used in shell ?


Hello,

I've been looking for the answer to this question for a couple of days now and am getting nowhere... so it's back to the forums again.

I've got a problem on my Slackware 9.1 box in that when I boot the machine the correct UK keyboard map is being used but as soon as I startx the keyboard becomes mapped as being a default US keyboard. This happens whether I start KDE, GNOME, XFCE etc. etc.

Needless to say this is completely doing my head in as whilst I'm in an X session I have to continually remember that the "#", "|", and " keys are not mapped to the correct keyboard keys which makes working in an terminal window and (especially) editing my config files most "interesting"

At this point I should mention that my /etc/rc.d/rc.keymap file looks like this:

#!/bin/sh
# Load the keyboard map (etc. etc.)
if [ -x /usr/bin/loadkeys ] ; then
/usr/bin/loadkeys uk.map
fi

When I'm in a terminal window in X then if I call "loadkeys uk.map" directly this makes no difference.

So I'd be most interested to find out what is causing X to use a different keymap and what I can do about it ?

All answers most welcome....
 
Old 10-09-2003, 05:10 PM   #2
uday
LQ Newbie
 
Registered: Jul 2003
Distribution: Slackware 9
Posts: 18

Rep: Reputation: 0
I have the same problem, but I on the other hand want a swedish keymap
 
Old 10-09-2003, 08:19 PM   #3
slacknoob
LQ Newbie
 
Registered: Oct 2003
Posts: 27

Rep: Reputation: 15
Same problem here for a Brazilian keyboard (qwerty-br-abnt2). Ive already posted a message about this problem, among others im having.



Thanks.
 
Old 10-13-2003, 06:01 AM   #4
Raptor Ramjet
Member
 
Registered: Apr 2003
Location: Under a rock
Distribution: Slackware "current" - Praise "Bob" !!!!
Posts: 92

Original Poster
Rep: Reputation: 15
Answering my own post

Hello,

Well I've found how to set up the keyboard to use a UK map so I think I've got 90% of your solutions for you.

After much rooting around I found it was "simply" a matter of editing the /etc/X11/XF86Config file which has a section for keyboard layout in it. My original version looked like this:

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
EndSection

All I had to do was edit it to add an "Option" line so the section in my file now looks like this:

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "uk"
EndSection

So I presume you'll just need to find what the relevant code for Svenska and Portugese are (sorry but I don't know)

Hope this is of use.
 
Old 10-13-2003, 07:29 AM   #5
kevlong
Member
 
Registered: Apr 2003
Location: UK
Distribution: Slackware 9.1
Posts: 30

Rep: Reputation: 15
Re: Answering my own post

Quote:
Originally posted by Raptor Ramjet
Hello,

Well I've found how to set up the keyboard to use a UK map so I think I've got 90% of your solutions for you.

After much rooting around I found it was "simply" a matter of editing the /etc/X11/XF86Config file which has a section for keyboard layout in it. My original version looked like this:

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
EndSection

All I had to do was edit it to add an "Option" line so the section in my file now looks like this:

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "uk"
EndSection

So I presume you'll just need to find what the relevant code for Svenska and Portugese are (sorry but I don't know)

Hope this is of use.
Or even since you will be in KDE, etc...You could use one of the graphical tools to setup Keyboards, Mice, Monitors, etc. I'll have to check whether these tools actually update XF86Config, but I think that they do.
 
Old 10-13-2003, 10:23 AM   #6
slacknoob
LQ Newbie
 
Registered: Oct 2003
Posts: 27

Rep: Reputation: 15
Thanks, it worked for me. For those Brazilian guys with the same problem, here it goes (abnt2 keyboard only):

...
Option "XkbLayout" "pt-br"
...



Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard map Noido Linux - General 10 06-14-2005 02:41 AM
Keyboard Map UltraSoul *BSD 1 02-08-2005 11:21 AM
keyboard map logicport Linux - Software 1 07-26-2004 11:45 PM
Keyboard map? Gerardoj Linux - Hardware 0 09-29-2003 09:46 PM
Keyboard Map Gerardoj Linux - General 2 08-07-2003 02:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration