LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-03-2007, 01:10 PM   #1
dohpaz
Member
 
Registered: Feb 2006
Location: Edmonton
Distribution: Slackware 12.2, Ubuntu
Posts: 117

Rep: Reputation: 16
keyboard input fails at login screen


I have a slackware 11 system that when booted up to the login screen(runlevel 3) shows no response when typing on the keyboard.I am able to ssh over to it from my laptop and I tried changing the runlevel to '5' in /etc/inittab and rebooting same problem.

There are no lights on the keyboard when this happens. If I reboot I can hit 'Del' to get into the bios and move around with the keys so I know the keyboard works. Plus, I can hit enter at the lilo prompt. I did try another known working keyboard though, same problem.

If I hit ctrl-alt-del before the boot process gets to the login then I get the "switching to runlevel 6" and the system reboots. The keyboard seems to fail as soon as the login starts.

I booted into single user mode and then it works fine.

How can I fix this?
 
Old 02-03-2007, 01:19 PM   #2
dohpaz
Member
 
Registered: Feb 2006
Location: Edmonton
Distribution: Slackware 12.2, Ubuntu
Posts: 117

Original Poster
Rep: Reputation: 16
Not sure if this is useful info but when I boot into single user mode and then try to be sneaky by doing "init 3" the system stalls
at:

Code:
 Starting gpm:  /usr/sbin/gpm -m /dev/mouse -t ps2
And I never get to a login or a prompt. I'm not even sure what should happen haha.

P.s I can login from ssh after init 3.
 
Old 02-03-2007, 01:25 PM   #3
dohpaz
Member
 
Registered: Feb 2006
Location: Edmonton
Distribution: Slackware 12.2, Ubuntu
Posts: 117

Original Poster
Rep: Reputation: 16
Ok i had this system in a closet for the last month and when I hooked it up again I used a usb mouse. That bit in my last post about gpm gave me a hint and I decided to try and reboot with a ps2 mouse. now it works!! can someone explain to me why this is?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard problem in login screen after Upgrading to FC6 reneve59 Fedora - Installation 3 12-16-2006 01:21 AM
fails to load up X, then the login screen keeps flashing? csvke Red Hat 14 04-03-2006 10:59 PM
KDE login screen keyboard layout Julkku Linux - Software 0 03-28-2005 05:21 AM
Login fails - being taken back to login screen donhare Mandriva 3 11-11-2004 04:53 PM
Keyboard input not on screen g_rat Programming 1 03-27-2003 11:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration