LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   keyboard input fails at login screen (https://www.linuxquestions.org/questions/slackware-14/keyboard-input-fails-at-login-screen-525286/)

dohpaz 02-03-2007 01:10 PM

keyboard input fails at login screen
 
I have a slackware 11 system that when booted up to the login screen(runlevel 3) shows no response when typing on the keyboard.I am able to ssh over to it from my laptop and I tried changing the runlevel to '5' in /etc/inittab and rebooting same problem.

There are no lights on the keyboard when this happens. If I reboot I can hit 'Del' to get into the bios and move around with the keys so I know the keyboard works. Plus, I can hit enter at the lilo prompt. I did try another known working keyboard though, same problem.

If I hit ctrl-alt-del before the boot process gets to the login then I get the "switching to runlevel 6" and the system reboots. The keyboard seems to fail as soon as the login starts.

I booted into single user mode and then it works fine.

How can I fix this?

dohpaz 02-03-2007 01:19 PM

Not sure if this is useful info but when I boot into single user mode and then try to be sneaky by doing "init 3" the system stalls
at:

Code:

Starting gpm:  /usr/sbin/gpm -m /dev/mouse -t ps2
And I never get to a login or a prompt. I'm not even sure what should happen haha. :)

P.s I can login from ssh after init 3.

dohpaz 02-03-2007 01:25 PM

Ok i had this system in a closet for the last month and when I hooked it up again I used a usb mouse. That bit in my last post about gpm gave me a hint and I decided to try and reboot with a ps2 mouse. now it works!! can someone explain to me why this is?


All times are GMT -5. The time now is 03:35 PM.