-   Slackware (
-   -   keyboard doesnt work (

phantom_cyph 12-12-2007 06:47 AM

keyboard doesnt work
yup. You read right. My regular, non-USB keyboard does not want to work with Slackware. Its recognized on startup at the boot prompt, but when I try to login, it doesn't read anything. What is the problem? This is kinda stupid.

H_TeXMeX_H 12-12-2007 08:32 AM

What kind of keyboard is it ? What is your default init level ? Do you boot straight into KDM (GUI login) (init 4) or to the regular CLI (command line interface) login (init 3) ?

phantom_cyph 12-12-2007 11:22 AM

Regular type of keyboard, standard with the HP a1410y desktop computer. Its PS/2 jack. I boot into command line first, then used kdm from root, or startx after creating user.

WoodLark 12-12-2007 11:38 AM

If I understand you correctly, the keyboard works at the command line since you can "startx", but doesn't work in the GUI. Check your xorg.conf file; it appears to be telling x that you either don't have a keyboard or that you have some unusual keyboard.

phantom_cyph 12-12-2007 12:01 PM

No, at the initial LILO screen, at the boot prompt, I can type. But after everything loads, and comes to the shell login, I can't type.

H_TeXMeX_H 12-12-2007 03:11 PM

Ok, which Slackware version are you using and with what kernel ? Looks like there's something wrong with the keyboard driver. Did you just install Slackware ? If so, check the md5sum of the install CD/DVD.

phantom_cyph 12-12-2007 04:05 PM

I have already installed Slackware on my laptop, which is what I'm using right now. Its Slackware 11, with the default sata.s (something like that) kernel. It works for my laptop, but not my desktop.

H_TeXMeX_H 12-12-2007 04:19 PM

Maybe try out a different kernel. Try 'huge26.s' for example.

phantom_cyph 12-12-2007 05:19 PM

OK, this solved the keyboard problem, but still no mouse. What entry do i need to make sure I have in xorg.conf to make my mouse work? And what program do I open it up with in command line (given it doesn't have nano).

phantom_cyph 12-12-2007 07:42 PM

Anybody have any ideas? I'm without a desktop computer right now...

brianL 12-12-2007 07:56 PM

If it's a wheel mouse, in xorg.conf, change:


Protocol    "PS/2"


Protocol    "IMPS/2"
then at rhe bottom of the mouse section, add:


Option      "Buttons" "5"
Option      "ZAxisMapping" "4 5"

It has pico, similar to nano.

phantom_cyph 12-12-2007 08:56 PM

OK, I changed the PS/2 to IMPS/2, and added the lines at the end, but when I tried to startx, or start kdm, it said it couldnt find a screen. So I deleted the last two lines, and it came up, but my mouse still doesnt work. Do those lines need to be in a subsection? Cause I put them after the last section, before the next device starts.

phantom_cyph 12-12-2007 10:00 PM

Do I make a separate section for those lines, or try a different kernel? If the last one, which kernel?

simcox1 12-13-2007 02:29 AM

Put those lines directly underneath your "IMPS/2" entry. If X still won't start, check /var/log/Xorg.0.log, and look for any lines beginning with EE or WW.

phantom_cyph 12-13-2007 07:07 AM

X starts, but my mouse still doesn't work.

All times are GMT -5. The time now is 03:44 AM.