LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-22-2015, 10:35 AM   #1
sawka
LQ Newbie
 
Registered: Feb 2013
Posts: 6

Rep: Reputation: Disabled
Keyboard doesn't work anymore with wine in XFCE4 (-current64)


Hi,

After upgrading system to -current64 today I can't use keyboard with wine in XFCE4 to play games. I think it can be keyboard layout problem since wine says in output:

Code:
fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x4090409, 0000: semi-stub!
and keyboard works flawless with wine in fluxbox. I'm using polish layout so I've tried to change it to english (us) before running wine but it doesn't helped (also tried german layout because I'm playing german version of FarCry ;-) ).

I'm using wine 1.7.52 from Alien Bob's latest build.
 
Old 11-22-2015, 07:47 PM   #2
sawka
LQ Newbie
 
Registered: Feb 2013
Posts: 6

Original Poster
Rep: Reputation: Disabled
After another try I realized that after running a game and pressing ALT + TAB keys the keyboard works. So it seems that initially the focus is on another and not game's window. Also i realized that when I switch to another window during game (so that the game's window is minimized) I can't switch back to that game (can't maximize it's window). Such switching worked before XFCE4 upgrade. It's a pity that it's broken now because I switch between game's and another windows quite often. I mostly play games in foreign languages which I'm studying and from time to time I have to check some words in online dictionaries. So fixing that issue would be useful.
 
Old 11-23-2015, 02:19 AM   #3
elcore
Member
 
Registered: Sep 2014
Distribution: Slackware
Posts: 845

Rep: Reputation: Disabled
I'd check first if it works with other WM to rule out xfwm4 bug.
If it doesn't work with other WM then build a new wine from source with latest xorg installed.
Just a guess, but I think that wine package is built on old xorg and may require old xorg to work properly.
 
Old 11-23-2015, 09:23 AM   #4
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: Slackware64-Current
Posts: 6,450
Blog Entries: 15

Rep: Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031
Did you rebuild Wine after the update? A lot of stuff changed after the eudev update from udev-classic. I would try rebuilding and reinstalling Wine to see if it helps.
 
Old 11-23-2015, 09:54 AM   #5
sawka
LQ Newbie
 
Registered: Feb 2013
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
I'd check first if it works with other WM to rule out xfwm4 bug.
If it doesn't work with other WM then build a new wine from source with latest xorg installed.
Quote:
Did you rebuild Wine after the update? A lot of stuff changed after the eudev update from udev-classic. I would try rebuilding and reinstalling Wine to see if it helps.
I tried it on fluxbox and it works without problems but probably I'll rebuild wine anyway as soon as I'll resolve other more urgent issues. In this moment my Core 2 Duo is busy with rebuilding webkitgtk3 since I can't use liferea.
 
Old 11-23-2015, 11:51 PM   #6
elcore
Member
 
Registered: Sep 2014
Distribution: Slackware
Posts: 845

Rep: Reputation: Disabled
I guess it's xfce bug then, could try to build a clean xfce profile, start a new session, and do:
Code:
pkill xfwm4 && fluxbox
Then open wine, and see if there's something wrong with it.
Perhaps check ~/.xfce4-session.verbose-log for any clues.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Apple keyboard doesn't work anymore, even on console mode. lensilvan Slackware 2 08-27-2015 07:59 AM
Why doesn't youtube work anymore? lonesome51 Linux - Newbie 2 06-06-2012 02:29 PM
[SOLVED] After upgrade, my mouse/keyboard don't work anymore in X. BILLYKANE Slackware 5 09-15-2010 07:25 AM
upgrade to slackware 12.2 + xfce4.6 (xfce4-power-manager doesn't work) zux Slackware 4 04-22-2009 11:28 AM
Counter-Strike works in Wine but the keyboard doesn't work in the game objorkum Linux - Games 2 01-12-2004 02:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration