-   Slackware (
-   -   kernel upgrade to 3.14.1 on slackware 14.1, now it won't boot (

sfzombie13 04-25-2014 08:51 AM

kernel upgrade to 3.14.1 on slackware 14.1, now it won't boot
ok, having issues again. i have never u[graded a kernel before, so i tried it. my wifi was not working, it is an atheros 9xxx and i was reading that the 3.14.1 kernel had support for it. so i read how to do it, made sure i didn't trash the old one, compiled the kernel (took forever to answer all the questions, i just hit the defaults on most of them except for the atheros wifi), removed the old symlink and made a new one. tried to reboot, and after it decompressed the kernel, it went to a black screen.
i have several live cds, the ultimate boot cd, trinity rescue kit, and even made a boot usb stick when i installed slackware. so why am i asking this? well, if it were that easy to fix, i wouldn't be using windows for this question. the only way i could get write access to my slackware partition was using slax. i deleted the symlink and made a new one pointing to the old kernel. didn't work. then i tried to chroot into the / of the non booting system with no luck. i don't think i am understanding how to do it, and i have read at least 5 web pages with with instructions, but none of them are working.
well, i thought, i can just reinstall, all my data is on another partition anyway, so i tried that. that's when i found out that my dvd drive is going bad, the dvd i used to install slackware last week is not recognized. i tried booting it with another laptop, and it worked fine. windows error logs say i have been having dvd issues along with hard drive errors. looks like it is just about done, good thing i have a recent backup.
i really don't understand the reason for chrooting into the /, i thought that as long as the symlink got fixed, it should boot. can anyone provide me with the understanding of the reason for the process? and all of the tutorials i have looked at are not for slackware, maybe that's why they didn't work. thanx in advance.

moisespedro 04-25-2014 09:15 AM

1 - Never remove your old kernel off LILO before checking if your new kernel is working
2 - In doubt, use Slackware's huge config file

cynwulf 04-25-2014 09:38 AM

As a safety measure you don't change the vmlinuz symlink - that should point to the Slackware kernel - usually the huge kernel which always works or generic + initrd. This means you always have a working kernel.

You need to mount / (and any other partitions you might need), chroot in, (lots of guides for doing this on the web), restore the generic or huge kernel symlink, edit lilo as required, run lilo, boot the system and try again.

When building a kernel, this guide is probably the best:

Qury 04-25-2014 12:01 PM

i have run into similar problems in the past due to carelessness

i used the following to resolve:

- start computer with slackware install disc
- mount your root partition under /mnt
- cd /mnt
- chroot /mnt
- then mcedit /etc/lilo.conf
- ensure you have proper kernel configred vmlinuz-huge-3.10.whatever :)
- lilo -v

If all goes well, then you will be fine at the next reboot.

When i add a new kernel i usually just copy the default linux entry and amend the kernel to the new one that i've copied over to /boot

Bertman123 04-25-2014 07:18 PM

I learned the hard way not to mess with your working kernel. Even when I thought I knew what I was doing I still messed my system up. Supposedly you can get the slack install dvd to install with unetbootin, but I haven't been successful with that so far.

sfzombie13 04-25-2014 11:12 PM

well, it turns out that neither have i. i tried all manner of ways to get in, and in the end, i found it was a combination of bad luck and issues i had no idea were there, but should have. the hard drive was failing, in turn causing the dvd drive to fail intermittently. this in combination with my limited knowledge of linux rescue, led to a situation which was hard to diagnose. new hd, new install of slackware, and i'm back at it. this time, there will be no deleting of the symlink to the working kernel. thanx for the link to the great tutorial about building a kernel, the reason i need this is the support for the atheros wifi, and to gain enough knowledge to truly "know" it.

one other question: is there a reason why the symlinks would be missing? before, when i typed in ifconfig, it said not found, but when i typed /sbin/ifconfig, it worked. it's working fine now, so it may have been a symptom of the failing hard drive. anyway, off to build a new kernel and all weekend to get it done. thanx for the help.

and one more thing, for the next time (there's always a next time), why wouldn't just replacing the symlink with one that pointed to the other kernel work? i mean, what is the logic behind needing to chroot into the system? it seems to me that when i booted into slax and deleted the one and replaced it with another would work.

moisespedro 04-26-2014 12:03 AM

This one is a great guide too

sfzombie13 04-26-2014 12:51 AM

thanx for that last one, but this is me typing from my newly built and installed 3.14.1 kernel. and it only took two tries. now, it's back to that damn lfs build to see where i messed it up. have a good night all, and weekend.

cynwulf 04-26-2014 04:05 PM


Originally Posted by moisespedro (Post 5159383)

This is just for rebuilding the existing kernel, not building a new one. Hence it skips "make oldconfig", which is an important step and removal and recreation of symlinks, etc.

All times are GMT -5. The time now is 08:20 AM.