-   Slackware (
-   -   Kernel panics on Slack14 install to Xenserver 6.0 (

arfon 10-23-2012 08:57 AM

Kernel panics on Slack14 install to Xenserver 6.0
I've got 2 Xenserver 6.0 boxes, TOTALLY different hardware between them and I get the same kernel panics on both. Slack13.37 running on both fine.

When I go to install Slack14 using the hugesmp.s kernel, the kernel panics a little after the 'boot:' prompt. It seems to have 3 different 'sticking points'. Here are screen shots of each:

When I use the huge.s kernel, the install gets stuck in a loop.

malekmustaq 10-24-2012 02:04 AM

Have you tried passing the "NOAPIC" option and boot of the installer? Press F1 or F2 there are many choices. Also is your machine is not using multi processor you may use only the "huge.s" kernel, not the 'smp'.

arfon 10-24-2012 08:18 AM

noapci had no effect. I tried the huge.s kernel and it gets stuck in a loop.

poremland 02-18-2013 11:13 PM

I'm having the same problem
Were you ever able to figure out how to boot Slackware 14.0 with Xen Server 6? I've been trying to upgrade a Slackware 13.37 guest running on Xen Server 6 to Slackware 14.0 but have been unable to even get the install cd to boot.

I've tried several combinations of: hugesmp.s pci=routeirq acpi=off pci=noacpi but I always get stuck in a kernal panic or a loop with the huge.s kernel.

sardinha 02-19-2013 04:05 AM

switched to VMWare ESXi
I've tried using Slackware 14 in XenServer too with no success.
I switched to VMWare ESXi without any problem with Slackware 14 boot cd and installation (current).

arfon 02-19-2013 10:28 AM

SOLVED: (Sorta)
My solution was to switch to VirtualBox. Runs Slackware 14 with no problems.

All times are GMT -5. The time now is 04:02 PM.