-   Slackware (
-   -   Kernel panic with generic kernel Slackware 13.1 (

goodadamgood 01-31-2011 11:17 AM

Kernel panic with generic kernel Slackware 13.1
Hi everyone,
I'm very new to Slackware, installed 13.1 32-bit on my Lenovo T61 several days ago and already it's been a lot of fun...I'm learning so much.

I really fear that this has been asked about a million and a half times but I just can't help but be confused.

I have three distros on my machine, Linux Mint Debian Edition, Ubuntu Studio and Slackware 13.1

I have a /boot partition on my drive btw...

Ok, the Slack Huge kernel (vmlinuz-huge- boots up fine from Grub which by the way was installed by Mint Debian. From what I can see it's Grub and not Grub2. How can I figure out which I have??

I tried to install everything I'll need to use my Nvidia drivers but couldn't get X using the Huge kernel and figured maybe I should try Nvidia drivers under the generic kernel. Booting into the generic gives me a kernel panic.

Having done some googling I think I need to install an initrd. Does this seem like the direction to go? If so well I tried it and get an error:


$ sudo /sbin/mkinitrd -c -k vmlinuz-generic-
ERROR: No /lib/modules/vmlinuz-generic- kernel modules tree found for kernel "vmlinuz-generic-"

Can't figure out where to take it from there but am I really barking up the right tree?

Hope to hear from some people. I'm loving Slackware so far and look forward to getting into it more.


Cepoon 01-31-2011 11:48 AM

Change to the boot directory:


cd /boot
Log in as root and type:


mkinitrd -c -k -m ext3 -f ext3 -r /dev/sda2
ext3 and /dev/sda2 = Depends on your filesystem and check your fstab.

Now you have created initrd.gz in /boot direcotry. You must configure lilo bootloader now.

Add these settings to your /etc/lilo.conf:


# Linux bootable partition config begins
image = /boot/vmlinuz
initrd = /boot/initrd.gz
root = /dev/sda2
label = whatyouwant
# Linux bootable partition config ends
The last thing, apply changes in your lilo.conf


lilo -v
That's it.

bgeddy 01-31-2011 12:43 PM


Can't figure out where to take it from there but am I really barking up the right tree?
The command

su -c "/usr/share/mkinitrd/ "
will show you what mkinitrd command to run to succesfully generate an initrd on Slackware 13.1. Then just follow the steps Cepoon gave to update lilo.conf and rerun lilo.

goodadamgood 01-31-2011 04:57 PM

Awesome thank you guys for the tips and quick reply! Following Cepoon's post it's booting the kernel. Actually at installation I didn't add lilo / bootloader figuring Grub would be enough. After adding initrd to my grub.cfg it's all good.

Now on to getting Nvidia drivers up without errors...

All times are GMT -5. The time now is 06:29 AM.