-   Slackware (
-   -   Kernel Panic on new computer (

fatalerror0x00 02-01-2013 04:31 PM

Kernel Panic on new computer
So I'm using Slackware64 on a computer that's several years old. I tried to start up and soon as I did right off I had this kernel panic:


Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,1)

I've looked this up but I just don't quite seem to understand what it means I've got some things that might be wrong (two) but either one I can't figure out how I'm gonna do with what I've got. I'm not sure if I'm just doing something wrong or what. Any input you have would be greatly appreciated. Thanks :)

n1x4 02-01-2013 04:36 PM

Is lilo pointing to the right partition?

Check to see which is bootable and adjust accordingly.

fatalerror0x00 02-01-2013 04:43 PM

I'll have to setup lilo all on my own then so I can actually look and see I finally got the paritions mounted with the Slackware disc and found theres like nothing there the first parition has 4 folders the rest have 1 it's really weird whats happening with my partitions on this computer somethings really not right and I'm very concerned I've never had this issue it's not remembering some stuff

Bazzaah 02-02-2013 03:21 AM

Can you boot the huge kernel?

jostber 02-04-2013 02:19 PM

kingbeowulf 02-04-2013 06:41 PM

Also, when installing on an existing system, especially if the hard drive had ANY previous OS on it, make sure you keep an eye on the MBR. I tend to stick Windows and several Linux OS on various partions, or when I upgrade a Windows box to Linux, I stomp on the MBR with lilo. If I don't, telling lilo to use just the superblock, on the next boot, whatever stub is in the MBR tries to boot. In fact, I just had that wtf moment the other day after reinstalling 14.0 over the old 13.37. Pretty much same error as the OP.

Moral of this ramble, have your lilo.conf look something like this:

# Start LILO global section
boot = /dev/sda
compact        # faster, but won't work on all systems.
# Linux bootable partition config begins
image = /boot/vmlinuz
  initrd = /boot/initrd.gz
  root = /dev/sdb1
  label = Slackware
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda1
  label = Windows7
  table = /dev/sda
# Windows bootable partition config ends

Basically, "boot = /dev/sda" tells lilo to use the MBR, "root = /dev/sdb1" is were your bootable partition is.

Now, if this was a running installation, and you suddenly can't boot, then I suspect your hard drive: Track 0, partition table or susperblock errors with the possibility of a bad /boot or even /boot/initrd.gz I would grab a copy of and do some testing.

All times are GMT -5. The time now is 10:41 PM.