-   Slackware (
-   -   kernel modules loaded at boot time (

gusgorman 04-07-2003 01:04 PM

kernel modules loaded at boot time
I've recently switched to Slackware-9, and something confuses me, and google has not been my friend yet.

At boot time, it seems like an attempt is made to load every kernel module, so i get loads of insmod errors for hardware that I do not have. Is the idea that you build your own kernel straight away to avoid this? Or is there something else I should do? It just seems a bit ugly, so i'd like to stop it. ( Also, the rivafb.o module is getting loaded, which I would like to stop, and append="apm=off" in lilo.conf doesn't seem to do the trick)

tangle 04-07-2003 02:07 PM

There is a file name modules.rc in /etc/rc.d. In the file there are a list of modules. Just comment with a # to not load the module at boot time.

gusgorman 04-07-2003 03:04 PM

Thanks for the reply... however, I've already looked at that file, and it basically isn't loading anything... most of it is commented out already.

tobyl 04-07-2003 03:52 PM

I am getting the same problem.
I am a new user and I am enjoying getting used to slackware (previously mdk9.0).
The rc.modules file implies that KMOD is loading (or trying) the unwanted modules. Can KMOD be modified?
Also dmesg and /var/log/syslog and messages omit the failing insmod messages that I see at boot. Is there somewhere else I can see them, or change the verbosity of the logs?
Its not a problem to recompile, but I wouldn't have thought it was necessary.

tobyl 04-09-2003 04:23 PM

gusgorman, you do not mention which modules your system is trying to load, other than rivafb.o.
I was getting problems with the i810 watchdog timer and RNG modules. I overcame the problem by recompiling the kernel in the end.
the module you mention is in Frame-buffer support, so you could recompile the kernel without this module and any others that annoy you.
If you do recompile, use the guide at the top of this forum, but he forgot to say do 'make mrproper' before make menuconfig.
The other way I discovered is to put an entry in /etc/modules.conf like 'alias <modulename> off' which you could experiment with.

docGonzo2000 04-10-2003 01:28 AM

Disable hotplugging. That way, you can edit /etc/rc.d to load only those modules you want. You can compile a different kernel, but it'll be easy to fix if you just run the setup script for it in pkgtool. It'll ask you if you want to enable hotplugging, just say no.

Another option is to chmod a-x /etc/rc.d/rc.hotplug

I have had problems with the 2.4.20 kernel anyway, so I actually compiled my own 2.4.18 kernel from Slack 8.1 on 9.0. All of my devices work fine, and Slack 9 is great. I hope that they fix my sound problems with the next stable version of the kernel... I'd like to run the new one.

Hope you get it working right.

Shakey 04-10-2003 05:48 AM


Originally posted by tobyl
... I was getting problems with the i810 watchdog timer and RNG modules. I overcame the problem by recompiling the kernel in the end...

tobyl, I had the same problem with i810 watchdog timer and I got rid of it by removing the i810_tco.o from module files and doing depmod -a. It helped - I don't see those annoing insmod errors at bootup. It still puzzles me what causes these errors? What parts in kernel needs this i810_tco and rng modules? Did you find the reason for these and what did you change in kernel recompile?


R0N1N 04-10-2003 01:18 PM

I didn't like hotplugging either. It kept starting modules that I didn't want loaded. I completely removed the hotplug package. I like to be able to control which modules are loaded through the rc.modules. Problem resolved.

tobyl 04-10-2003 04:08 PM

Shakey - yes I found out a bit about the i810 watchdog timer. It is meant for servers mainly and causes a reboot under certain conditions, presumably to prevent downtime. The RNG part is a random number generator, but seems to be unnecessary as well. The kernel section that relates to it is Watchdog Cards. KMOD seems to try and load this module for all i8xx mobo chipsets, but this causes errors if, as in my case it is an 845 chipset, not i810. I disabled Watchdog Cards completely when I recompiled, with no loss of performance.
You can read more about this in /usr/src/linux/doc.

Your method of removing the error messages seems equally valid to mine, and the stuff about hotplug is new to me, I had supposed it was to do with usb! I need to investigate this further.

KMOD, in case you were wondering, is a kernel level replacement for kerneld, which tries to load the right modules for your hardware at boot time. usr/src/linux/doc contains bit of info about this as well.

still learning...!

Shakey 04-14-2003 06:49 AM

Hello again! Yes - now I'm a bit wiser and as you tobyl said - still learning! Anyway - I rechecked my kernel configuration and I couldn't find anything enabled concerning hotplugging or watchdog cards! Could kmod be responsible for loading these nonexisting modules or could it be some other i8xx related stuff?


Excalibur 04-14-2003 10:45 AM

The new hotplug system in Slack 9.0 is run through the /etc/ script. If you desire to disable this new feature then I suggest "chmod 000 /etc/rc.d/rc.hotplug" to remove the execute bits from the script. That will disable the startup of the hotplug script.

If want to leave it enabled and you experiencing a problem with just one or two modules, then I suggest adding the module name(s) to the end of the /etc/hotplug/blacklist file. That will prevent the module from being loaded through the new hotplug system.

Perhaps it will be of some help.

All times are GMT -5. The time now is 03:46 AM.