LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
 
Search this Thread
Old 03-28-2014, 04:04 AM   #1
RoyBatty100
LQ Newbie
 
Registered: Mar 2013
Posts: 4

Rep: Reputation: Disabled
kernel-generic-smp-3.10.30_smp-i686 there's no RTC device


Hi guys
I wanted use ntp on Slackware 14.1 kernel-generic-smp-3.10.30_smp-i686,
What I noticed after reboot it took ages to save hwclock and the time was incorrect.
I tried command hwclock --show and nothing, tryed /dev/rtc and rtc0 still nothing.
I have checked zgrep HCTOSYS /proc/config.gz not set.
After kernel recompilation finally I got CONFIG_RTC_HCTOSYS=y
CONFIG_RTC_HCTOSYS_DEVICE="rtc0" and now everything works fine.
Hwclock shows time and ntp works well. Question, is there an easier
way to make RTC work that way?
Thanks
 
Old 03-28-2014, 08:52 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,818

Rep: Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011Reputation: 1011
The short answer is no.
It appears your system does not have a persistent_clock or else it is not being recognised.

From http://lkml.iu.edu/hypermail/linux/k...4.3/00350.html
John Stultz
Quote:
Its only systems where there isn't a persistent_clock is where the RTC layer
and the HCTOSYS is helpful.

Again, if you're having a problem where an x86 system isn't getting its time
initialized correctly, please let me know the details of the system.
then Kay Sievers
Quote:
Until the above commits we always needed:
CONFIG_RTC_HCTOSYS=y
CONFIG_RTC_HCTOSYS_DEVICE="rtc0"
to get the system time correctly initialized at bootup on x86.
and John Stultz again
Quote:
On non-x86 (mostly embedded) platforms that do not have persistent_clock support, yes, the above is needed.

But I'm unaware of the above actually being necessary on x86, as its always had persistent_clock support.
 
2 members found this post helpful.
Old 03-28-2014, 10:06 PM   #3
RoyBatty100
LQ Newbie
 
Registered: Mar 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thumbs up Thank you

Quote:
Originally Posted by allend View Post
The short answer is no.
It appears your system does not have a persistent_clock or else it is not being recognised.

From http://lkml.iu.edu/hypermail/linux/k...4.3/00350.html
John Stultz

then Kay Sievers

and John Stultz again
Thank you for quick reply. That did the job.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel: Processor Family Selection for Generic i686 frozenQueue Linux - Kernel 1 09-23-2010 02:37 AM
[SOLVED] very slow boot with 2.6.32.2 generic-smp kernel thach.trung.ngoc Slackware 3 01-10-2010 06:31 AM
Generic SMP kernel with no initrd? songangel Slackware 8 03-26-2009 06:12 PM
ndiswrapper and generic smp kernel Bazzaah Slackware 13 05-17-2008 02:31 AM
smp oops in kernel 2.6.20-16-generic anirudhvij Linux - Kernel 0 08-19-2007 06:02 AM


All times are GMT -5. The time now is 01:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration