-   Slackware (
-   -   kernel/backlight/nvidia (

perbh 12-27-2012 06:57 PM

computer: dell precision m90
graphics adapter: nVidia Corporation G71 [Quadro FX 2500M] (rev a1)

Any kernel from 3.3 and later will not allow me to change the backlight intensity and everything is just so dark as to be unuseable.
The 3.2 and earlier kernels are/were allright. This is not just a slackware-problem, also happened with archlinux.
I have tried "echo 7 >/sys/class/backlight/acpi_video0/brightness" and nor will the brightness button work (also, again - it is fine with 3.2 and earlier)

I'm using the open driver (nouveau) but I believe I tried the nvidia driver under archlinux - no joy!
Also, as far as I can remember, I also tried acpi=vendor under archlinux, still no joy.

Does anyone have any suggestions?
Thank you in advance.

TommyC7 12-27-2012 07:09 PM


xbacklight -set 100

perbh 12-27-2012 07:14 PM

nope - I've tried that before as well.
as a curiosity - I just tried it running 3.2.29"

# xbacklight -set 100
No outputs have backlight property

wtf? I _know_ I have tried it before with no luck - probably under archlinux as well (it's fairly recently - as from 14.0 - that I have installed slackware on absolutely all my machines - earlier I just used it on servers)

Actually, its not only an X problem - it also happens as it boots ... but then the nouveau driver is loaded fairly early in the boot process.

TommyC7 12-27-2012 07:24 PM

Have you tried Fn+<Brightness Button>?

On my laptop, the brightness button is F3, so I would use Fn+F3. However, if you have Action Keys enabled (or was it disabled?) just "F3" should work.

perbh 12-27-2012 07:56 PM

oh yeah - tried that as well - still no joy.
I have changed to another 'puter here so I can experiment with the dell one ..

It is actually the 'nouveau' driver that is at fault. If I boot 3.7.1 with 'nomodeset vga=794', it seems to work - apart from the fact that I now need a decent xorg.conf - guess I have to try the nvidia driver again *sigh*, it's such a nuisance having to 'remake' it each time I try a new kernel ..
Of lately - the efforts seem to be to make xorg.conf superfluous ...
Trying the vesa-driver - I only get 1280x1024 when my display can use 1920x1200.

perbh 12-27-2012 08:35 PM

I guess I can put this down as solved.
I ended up using 'nomodeset,vga=794' and then a xorg.conf using the venerable 'nv'-driver.
I have got my 1920x1200 resolution, and the brightness function keys work again.

Definitely - this is a problem with the nouveau driver, has got nothing to do with the kernel-version as such - though, implicitly, nouveau is part of the kernel.
I can confirm that the nouveau driver as found in 3.2.29 is working perfectly. As from 3.3 and onwards, it is broken (at least as far as _my_ brightness is concerned).

All times are GMT -5. The time now is 01:47 PM.