LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Kernel 4.4.261 doesn't boot (4.4.240 was fine) (https://www.linuxquestions.org/questions/slackware-14/kernel-4-4-261-doesnt-boot-4-4-240-was-fine-4175693468/)

SeB30 04-10-2021 12:22 PM

Kernel 4.4.261 doesn't boot (4.4.240 was fine)
 
Hi,
my first post on linuxquestions,
I have a running Slack 14.2 on old hardware (Opteron 180), today upgraded to new kernel and system hang at boot, freeze just after message Booting kernel (generic) or with ‘panic not syncing vfs blablabla’ (huge).
I was able to recover from DVD with kernel 4.4.14, removed 4.4.261 and re-do installation (mkinird + lilo) and found same behaviour with 4.4.261 (downloaded again and MD5 checked).
Unfortunately, I can’t go back to 4.4.240 because package is replaced in /patches!
Do I need to build from source ?

So my humble proposal : keep at least kernel n-1 in install script, for recovery purpose (yes, I must have been done myself!).

@+

enorbet 04-10-2021 01:37 PM

There is no reason that 4.4.241 or any newer kernel should simply not boot and Panic other than a generic kernel with a bad initrd. It's always wise to keep a working kernel as a safety net when installing a new kernel. You can very likely use HUGE as is or generic after employing "mkinitrd". Most commonly it is the file system that requires either built-in or initrd support. It panics because it can't read root.

hazel 04-10-2021 01:53 PM

When making an initrd for a new kernel, remember that the mkinitrd script will by default use the version of the currently running kernel (which is not what you want). So you will need to use a -k option for mkinitrd as well as the hardware-dependent options given by Pat's helper script.

If you don't do this, the initrd will contain modules incompatible with your new kernel, including the driver for your root filesystem, which is one thing that might give you that error message.

SeB30 04-10-2021 04:10 PM

For some time, I use Ŧmkinitrd -c -k 4.4.xxx-smp -m ext3 -f ext3 -r /dev/sdc6ŧ to boot generic, but this time kernel hang very soon, just a few lines after decompressing, and huge doesn't find root FS, for no apparent reason, compared to 4.4.240 .
Maybe support for my old CPU (32b) is gone, or kernel compilation was done in new way ?
I am using Slackware from the era of 2.0.xx kernel and AFAIR, never been in that situation.

enorbet 04-10-2021 04:29 PM

I think I would just install or rebuild from the 32bit Current kernel package which is something like 5.10.x. I haven't used a 4x kernel in ages even on a 32 bit 14.2 system. I still have a few 32 bit installs on both 32bit CPUs and also on 2 64bit CPUs. Having a pure 32bit sometimes helps me maintain multilib on 64bit and I still have an old AMD FX-57 box that I'll likely keep working till years end or possibly dedicate to some vintage stuff.

SeB30 04-11-2021 12:15 PM

Ok, I installed current kernel generic 5.10.28 + initrd and it works well.
Thanks for advice.

enorbet 04-11-2021 01:48 PM

Congratulations, SeB30. :D Please mark solved now.

SeB30 04-11-2021 04:18 PM

Well, only half solved because 4.4.261 doesn’t boot for unknown reason.

Paulo2 04-11-2021 04:46 PM

I donīt know if itīs related but that new kernel in Slackware 14.2 makes my notebook
freeze when playing a video in youtube.
Keyboard and mouse freeze, and sound keeps playing in one second loop.

The machine is a HP Compaq Presario from 2009, old machine too like OP.
Code:

Linux claudio-pc 4.19.184 #1 SMP Thu Apr 1 20:17:28 -03 2021 x86_64 Genuine Intel(R) CPU            585  @ 2.16GHz GenuineIntel GNU/Linux
I reverted to 4.4.240 and it didnīt freeze, like was before the kernel update.

Now Iīm running 4.19.x to have a kernel with updates, itīs running ok.

I didnīt posted that problem before because anyone posted any similiar problem.

enorbet 04-11-2021 08:25 PM

Hello Paulo2
Did you just install the kernel packages (all I hope) or did you rebuild it from source (much better with localmodconfig)?

Paulo2 04-11-2021 09:03 PM

Quote:

Originally Posted by enorbet (Post 6240065)
Hello Paulo2
Did you just install the kernel packages (all I hope) or did you rebuild it from source (much better with localmodconfig)?

I installed the new kernel 4.4.261 packages as usual with slackpkg, then running mkinitrd and lilo.
The system booted ok but crashed at youtube.

Then I tried kernel 4.4.260, it built ok but crashed at youtube too,
so I reverted to the last good kernel 4.4.240. I built it from source
since there isn't a cumulative repository (at least not that I'm aware of).


All times are GMT -5. The time now is 08:19 PM.