LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-23-2018, 08:14 AM   #16
dr.s
Member
 
Registered: Feb 2010
Distribution: Slackware64-14.2
Posts: 221

Rep: Reputation: 58

Quote:
Originally Posted by Pixxt View Post
Kernel 4.19.11 here and I still have them on boot.
Penguins missing since 4.19.12
 
1 members found this post helpful.
Old 12-23-2018, 09:09 AM   #17
Pixxt
Member
 
Registered: May 2008
Distribution: Slackware, Debian,
Posts: 202

Rep: Reputation: 103Reputation: 103
Quote:
Originally Posted by tramtrist View Post
Thanks Pixxt! I diff'd your file and found 2 things I thought might be what was causing the problem. My .config had these two options set to =y and I set them to =N

CONFIG_FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER
CONFIG_EXPERT

They're now # not set
# CONFIG_FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER is not set

And I have penguins !!!
I can successfully and effectively use Slackware again with Tux inspiration

I think it's the framebuffer_console setting because I read other places that framebuffer has a lot to do with what happens with TUX at boot...
Cheers mates!!
Cool Beans!
 
Old 12-23-2018, 10:04 AM   #18
Markus Wiesner
Member
 
Registered: Mar 2016
Distribution: Slackware
Posts: 64

Rep: Reputation: 105Reputation: 105
Quote:
Originally Posted by https://wiki.archlinux.org/index.php/silent_boot#Disabling_deferred_takeover

Disabling deferred takeover

If the new behavior leads to issues, you can disable deferred takeover by using the fbcon=nodefer kernel parameter.
This solves the "issue" ;-) with the missing penguins without recompiling the kernel (at least here, still with kernel 4.19.8).

For grub, set this in /etc/default/grub (and then update grub.cfg):

Code:
GRUB_CMDLINE_LINUX_DEFAULT="fbcon=nodefer"
For lilo, add this in /etc/lilo.conf (and then reinstall lilo):

Code:
append = "fbcon=nodefer"

Last edited by Markus Wiesner; 12-23-2018 at 10:07 AM.
 
6 members found this post helpful.
Old 12-23-2018, 10:34 AM   #19
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,777
Blog Entries: 1

Rep: Reputation: 3112Reputation: 3112Reputation: 3112Reputation: 3112Reputation: 3112Reputation: 3112Reputation: 3112Reputation: 3112Reputation: 3112Reputation: 3112Reputation: 3112
Quote:
Originally Posted by Markus Wiesner View Post
This solves the "issue" ;-) with the missing penguins without recompiling the kernel (at least here, still with kernel 4.19.8).

For grub, set this in /etc/default/grub (and then update grub.cfg):

Code:
GRUB_CMDLINE_LINUX_DEFAULT="fbcon=nodefer"
For lilo, add this in /etc/lilo.conf (and then reinstall lilo):

Code:
append = "fbcon=nodefer"
That works!
Many Thanks!
 
Old 12-23-2018, 10:35 AM   #20
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware64 -current (started with 13.37(32))
Posts: 555

Original Poster
Rep: Reputation: 240Reputation: 240Reputation: 240
Quote:
Originally Posted by Markus Wiesner View Post
For lilo, add this in /etc/lilo.conf (and then reinstall lilo):

Code:
append = "fbcon=nodefer"
It works with lilo penguins are back.

Thanks to all for tracking this, I will mark this as solved.
 
2 members found this post helpful.
Old 12-27-2018, 04:53 PM   #21
Aeterna
Member
 
Registered: Aug 2017
Location: Terra Mater
Distribution: VM Host: Slackware-current, VM Guests: Artix, CRUX, FreeBSD, Funtoo, HardenedBSD, OpenIndiana
Posts: 345

Rep: Reputation: Disabled
Intersting, because this option is not enabled by default if one runs config editor even when creating new .config file
 
1 members found this post helpful.
Old 12-27-2018, 05:14 PM   #22
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 502

Rep: Reputation: 269Reputation: 269Reputation: 269
I just wanted to mark this as a high priority bug. Having the penguins appear is VERY important. It's literally the only time my wife takes interest while I'm booting my Slack laptop...
 
4 members found this post helpful.
Old 12-27-2018, 05:18 PM   #23
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,607

Rep: Reputation: 297Reputation: 297Reputation: 297
Thanks for finding that Markus Wiesner!
 
Old 12-27-2018, 05:50 PM   #24
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,248

Rep: Reputation: 4942Reputation: 4942Reputation: 4942Reputation: 4942Reputation: 4942Reputation: 4942Reputation: 4942Reputation: 4942Reputation: 4942Reputation: 4942Reputation: 4942
Quote:
Originally Posted by tramtrist View Post
Thanks Pixxt! I diff'd your file and found 2 things I thought might be what was causing the problem. My .config had these two options set to =y and I set them to =N

CONFIG_FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER
CONFIG_EXPERT

They're now # not set
# CONFIG_FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER is not set

And I have penguins !!!
I can successfully and effectively use Slackware again with Tux inspiration

I think it's the framebuffer_console setting because I read other places that framebuffer has a lot to do with what happens with TUX at boot...
Cheers mates!!
I made this change earlier this week when I compiled my 4.19.12 kernel and disabling that actually knocked out my screen throughout the whole boot process. It didn't come up until KDE started (I have runlevel 4 as default and kdm is set to auto login for my user). I'll just live without the tux for now... I really don't reboot my computer much, so I'm not too worried.
 
Old 12-27-2018, 10:44 PM   #25
1337_powerslacker
Member
 
Registered: Nov 2009
Distribution: Slackware64-current
Posts: 801
Blog Entries: 9

Rep: Reputation: 543Reputation: 543Reputation: 543Reputation: 543Reputation: 543Reputation: 543
Quote:
Originally Posted by tramtrist View Post
Thanks Pixxt! I diff'd your file and found 2 things I thought might be what was causing the problem. My .config had these two options set to =y and I set them to =N

CONFIG_FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER
CONFIG_EXPERT

They're now # not set
# CONFIG_FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER is not set

And I have penguins !!!
I can successfully and effectively use Slackware again with Tux inspiration

I think it's the framebuffer_console setting because I read other places that framebuffer has a lot to do with what happens with TUX at boot...
Cheers mates!!
I'm happy to report that I also have my penguins back. There's just something so comforting about seeing an array of penguins displayed across the top of my screen...
 
Old 12-28-2018, 03:26 AM   #26
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Debian, Slackware
Posts: 2,105
Blog Entries: 6

Rep: Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321
Where are these fabled penguins? Is it a line in LILO?
 
Old 12-28-2018, 03:40 AM   #27
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 2,543

Rep: Reputation: 801Reputation: 801Reputation: 801Reputation: 801Reputation: 801Reputation: 801Reputation: 801
Kernel 4.19.x no more Tux in boot screen and led blinking on suspend.

Do you use the frame buffer Lysander?

If not, then you won't see the penguins.

You can fix it with a "vga = xxx" line in your lilo.conf.

Look in the sample lilo config file for some suggestions.
 
Old 12-28-2018, 03:58 AM   #28
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Debian, Slackware
Posts: 2,105
Blog Entries: 6

Rep: Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321Reputation: 2321
Quote:
Originally Posted by rkelsen View Post
Do you use the frame buffer Lysander?

If not, then you won't see the penguins.

You can fix it with a "vga = xxx" line in your lilo.conf.

Look in the sample lilo config file for some suggestions.
Hmm so maybe the second line here needs to be uncommented on my desktop:

Code:
# VESA framebuffer console @ 1024x768x64k
#vga=791
Now, my netbook uses a 1024x600 screen, so according to allend it may be useful to use

Code:
video=inteldrmfb:mode=1024x600
in the "append= " string, in addition to using

Code:
# VESA framebuffer console @ 640x480x256
#vga=769
or similar.

Is there any technical purpose to these penguins other than their looking nice?
 
Old 12-28-2018, 06:09 AM   #29
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware64 -current (started with 13.37(32))
Posts: 555

Original Poster
Rep: Reputation: 240Reputation: 240Reputation: 240
Quote:
Originally Posted by Lysander666 View Post
Hmm so maybe the second line here needs to be uncommented on my desktop:

Code:
# VESA framebuffer console @ 1024x768x64k
#vga=791
Now, my netbook uses a 1024x600 screen, so according to allend it may be useful to use

Code:
video=inteldrmfb:mode=1024x600
in the "append= " string, in addition to using

Code:
# VESA framebuffer console @ 640x480x256
#vga=769
or similar.

Is there any technical purpose to these penguins other than their looking nice?
You could uncomment the line '#vga = ask', lilo will display a menu with (probably) supported screen resolutions.
I have a notebook with Intel video and it uses i915, but lilo doesn't support native resolution 1280x800.

On my desktop lilo supports native 1680x1050 and, with the NVidia driver, penguins always stay on top of the
screen, even if I login. Only with a screen reset they disapear.
(with nouveau the screen resets when it is loaded).


The penguin can be changed to some company logo, and there is one penguin for cpu or cpu core.
It is realy easy to change the logo, but I think there is some trick to make it with so smooth edges.
I tried some edits but it ends with rough edges.
 
Old 12-28-2018, 09:00 AM   #30
Aeterna
Member
 
Registered: Aug 2017
Location: Terra Mater
Distribution: VM Host: Slackware-current, VM Guests: Artix, CRUX, FreeBSD, Funtoo, HardenedBSD, OpenIndiana
Posts: 345

Rep: Reputation: Disabled
Quote:
Originally Posted by Paulo2 View Post
You could uncomment the line '#vga = ask', lilo will display a menu with (probably) supported screen resolutions.
I have a notebook with Intel video and it uses i915, but lilo doesn't support native resolution 1280x800.

On my desktop lilo supports native 1680x1050 and, with the NVidia driver, penguins always stay on top of the
screen, even if I login. Only with a screen reset they disapear.
(with nouveau the screen resets when it is loaded).


The penguin can be changed to some company logo, and there is one penguin for cpu or cpu core.
It is realy easy to change the logo, but I think there is some trick to make it with so smooth edges.
I tried some edits but it ends with rough edges.
I replaced penguins with Slackware logo. It works even in virtual machine (with enabled 4 processors equals to four Slackware logos. If I would add more, then more penguins, if I removed processosrs, then less penguins). This is on laptop with Haswell


I never had an issue with the logo during boot. If someone had logo visible before 4.19.x, it still should be there unless default Slackware kernel was modified now to run in quiet mode and no penguins. The options added do nothing more than helps quiet boot.

Quote:
CONFIG_FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER:

If enabled this defers the framebuffer console taking over the
console from the dummy console until the first text is displayed on
the console. This is useful in combination with the "quiet" kernel
commandline option to keep the framebuffer contents initially put up
by the firmware in place, rather then replacing the contents with a
black screen as soon as fbcon loads.
Attached Thumbnails
Click image for larger version

Name:	VM Slackware boot.png
Views:	75
Size:	65.0 KB
ID:	29328  
 
3 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to kill task when Black Screen with HDD LED light blinking for hours gabytf Linux - Newbie 18 09-22-2011 12:24 PM
HAL Daemon Polling and Hard Drive LED Blinking Woodsman Slackware 10 08-03-2009 01:55 AM
when hibernate to ram, power led keeps blinking cyrilng Linux - Hardware 10 06-02-2009 06:49 AM
nx6110 laptop, drivers installed with ndiswrapper but blinking led dragupl Linux - Wireless Networking 0 10-09-2006 02:07 PM
Hard disk led won't stop blinking AlleyTrotter Slackware 6 10-22-2005 10:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration