-   Slackware (
-   -   Kernel 3.7.1 keyboard's dead (

RoyBatty100 03-06-2013 09:41 PM

Kernel 3.7.1 keyboard's dead
Hi there.
I just updated to slackware64 current. Using kernel generic 3.7.1 and initrd. The thing is after boot up keyboard's dead. It's Logitech Media Keyboard 600 (nothing fancy). That's the initrd script I used.

mkinitrd -c -k 3.7.1 -f ext4 -r /dev/cryptvg/root -m usb-storage:hid-generic:ehci-hcd:usbhid:xhci-hcd:mbcache:jbd2:ext4 -C /dev/sdb2 -L -u -l jp106 -o /boot/initrd.gz

I have to mention it worked fine with slackware64 14
generic kernel 3.2.x. I did some experiment and used .config file Exton Linux, it worked fine (Kernel itself 5MB) but I'd like to use Slackware64 out of the box, without fiddling. To me it's some kind of regression, some option is off in the kernel .config file, any ideas?.
Thank you for your help.

volkerdi 03-06-2013 10:02 PM

The usbhid and hid-generic modules require the hid module. I'm not sure if adding that to the list is the entire fix, but it might be.

RoyBatty100 03-07-2013 12:41 AM

The Man himself and BINGO!. Worked out flawlessly.
Have to admit those days kernel is more complicated since Slackware kernel 2.2.6 :) (hid isn't usbhid).
Once again thank you very much :)).

All times are GMT -5. The time now is 02:46 PM.