-   Slackware (
-   -   Kernel 2.6.7 installation from Slackware 10 packages? (

plm 06-28-2004 09:20 AM

Kernel 2.6.7 installation from Slackware 10 packages?
Hi there,

Well I was wondering how to install the 2.6.7 kernel from the testing directory on the CD. There are packages, but I donŽt know how to proceed. Can anyone please explain me?

slakmagik 06-28-2004 09:28 AM

cd to the kernel directory.

installpkg everything except the headers.

Edit lilo. Run lilo. Reboot. Enjoy.

(Don't forget to run the mkinitrd script linked in /boot if you use reiser and the generic kernel.)

plm 06-28-2004 09:45 AM

Thank you very much :)

I have a few questions, though, I donŽt use lilo, i use loadlin, and as I read from the README.initrd there is a line that is added to lilo.conf, because initrd is required to run the 2.6.7 kernel, so my question is, would loadlin start the 2.6.7 kernel the usual way, or do I have to add some things. For example, I have a copied bzimage of the bare.i 2.4.26 on my windows partition, and when I want to run Slackware, I write Žloadlin bzimage root=/dev/hda8 roŽ and now I may have to add something that loads initrd. And the other thing is, when I install the packages, can I copy the 2.6.7 kernel image from /boot to my windows partition?

slakmagik 06-28-2004 09:58 AM

I'm not sure if an initrd is required - virtually required for most anything, but I think it's possible to run an ext3 system (probably with stuff missing) without it.

I've only used loadlin to load zipslack, and I forget the details. Don't have a loadlin man page handy, either, but I suspect it would take an 'initrd' argument or something. As far as copying the kernel, I don't see why not. But why not use lilo?

Anyway, I suspect it would be okay but someone who was more familiar with loadlin could probably answer better. Like I say, check the man page and it should say what to do. Good luck. :)

plm 06-28-2004 10:06 AM

Well if it doesnŽt work IŽll install lilo. :) Really thanks for the help very much :) :)

plm 06-28-2004 11:08 AM

Well, I got an error 'Kernel Panic: VFS Could not mount root filesystem', when I booted the 2.6.7 kernel image with loadlin. I ran the mkinitrd script with the command 'mkinitrd -c -k 2.6.7 -m reiserfs' like it's written in the readme file, but should I have a mkinitrd package in the kernel packages folder? Well, I installed everything except the headers and the root filesystem cannot be mounted..
Does anyone have an idea how to solve this?

slakmagik 06-28-2004 11:17 AM

Did the mkinitrd script produce an 'initrd.gz'? And can loadlin take the 'initrd' argument? For lilo, it's:

image = /boot/vmlinuz-generic-2.6.7
  label = slackwareB 
  root = /dev/hdb5
  initrd = /boot/initrd.gz

I'd figure if you were booting off of a 'boot' on your windows drive, that's where the initrd needs to be, too. It could mean a lot of things, but probably means it didn't find the initrd, so couldn't load the module, so couldn't mount root.

This should work but other options are lilo or compiling a kernel with reiser built in.

plm 06-28-2004 12:06 PM

yes that's what I thought too :) I now have a working Slackware 10 with a 2.6.7 kernel! :) I read the manual of loadlin and there I found that it is possible to load a ramdisk with just adding 'initrd=image' and it worked! :) everything is okay now and works perfectly, I think! :) Thanks for the help!

slakmagik 06-28-2004 12:33 PM

Congrats! Glad you got it working. :)

All times are GMT -5. The time now is 08:38 AM.