Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 06-22-2005, 09:58 PM   #1
Dr. Psy
Registered: May 2005
Distribution: Slackware 10.1
Posts: 49

Rep: Reputation: 15
Kernel 2.6.12 upgrade and console text size

I could use some help here from you more experienced kernel compilers out there!

I have never done the kernel compile thing before, because I liked knowing that for the most part, the included kernel version was probaby somewhat more stable and secure then the latest. But this time, I was moved to upgrade to the new 2.6.12 kernel for a couple reasons. Namely the new cryptoloop support and the IPSec support.

The compile went great. Much better than expected. I am quite happy [and excited] with the new kernel, as I now have a few more projects to work on now.

But theres one thing I dont like [minor, but nevertheless...]

And that is the fact that unlike the included Slackware 10.1 kernel 2.4.29 which had the nice small text at the console, I now have the 'extra-large' text!

What do I need to do in the kernel to get back the nice small text I am used to? Does that have something to do with the framebuffer options?

Anyways, if someone could give me a hand with what to do under the kernel options to get that nice small text back, I would be very appreciative!

Old 06-22-2005, 10:08 PM   #2
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
compile VESA VGA and Framebuffer support into your kernel.
Old 06-22-2005, 11:48 PM   #3
Dr. Psy
Registered: May 2005
Distribution: Slackware 10.1
Posts: 49

Original Poster
Rep: Reputation: 15
Okay, I did this. And I still have the large console text.
Old 06-22-2005, 11:52 PM   #4
Senior Member
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
What's the value of vga in /etc/lilo.conf?
Old 06-22-2005, 11:58 PM   #5
LQ Newbie
Registered: May 2005
Posts: 15

Rep: Reputation: 0
Are they compiled in, or as modules? I *think* they have to be compiled in (there's probably a more technical term for that, but I mean active, but not as a module, you know?) At least, that's how I got it to work in mine.

Last edited by beezlebozo; 06-23-2005 at 12:12 AM.
Old 06-23-2005, 01:27 AM   #6
Dr. Psy
Registered: May 2005
Distribution: Slackware 10.1
Posts: 49

Original Poster
Rep: Reputation: 15
Well, I got it working, the problem was that for some reason, the new kernel wasn't loading after typing LILO. Yes, I compiled those options into the kernel. Problem now, is even though it is finally starting in the proper mode, now it's frezing after it starts! lol!

Well, Im on the right track now anyways. This looks like something Im just going to have to play with.

Kinda funny. Everything works great in the new kernel. But the one thing I am having trouble with is the trivial issuse of the font size. lol! Go figure.

anyways, I'll get this. Thanks for the help.
Old 06-23-2005, 01:37 AM   #7
LQ Guru
Registered: Mar 2004
Distribution: Slackware
Posts: 5,388

Rep: Reputation: 408Reputation: 408Reputation: 408Reputation: 408Reputation: 408
If you have a nvidia card, do not enable CONFIG_FB_VGA16
but make sure CONFIG_FB_VESA is enabled (as built-in)

Also did you enable some fonts in config, like CONFIG_FONT_8x8 ?
Old 06-23-2005, 02:47 AM   #8
Dr. Psy
Registered: May 2005
Distribution: Slackware 10.1
Posts: 49

Original Poster
Rep: Reputation: 15
Success. Again, thank you all for the help.

keefaz, Dont have nVidia. And yes I am pretty sure the fonts you mentioned were enabled. As far as I can tell, I did everythign correctly the first time. I went over it several times, but it just kept freezing no matter what I did. So I just started over with a fresh untarred kernel, and redid the same thing (to the best of my knowledge) and it works now.
Old 06-23-2005, 02:52 AM   #9
LQ Veteran
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,797

Rep: Reputation: 2158Reputation: 2158Reputation: 2158Reputation: 2158Reputation: 2158Reputation: 2158Reputation: 2158Reputation: 2158Reputation: 2158Reputation: 2158Reputation: 2158
Pick up the config from your old system, then
make oldconfig
Answer all the questions for the new options (there'll be a few), then
make menuconfig
as usual. I did this for 2.6.11 and it worked fine.

EDIT: - too late it seems

Last edited by syg00; 06-23-2005 at 02:53 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blank console screen after kernel upgrade saltireboy Slackware 2 05-06-2005 03:47 AM
No Video in Text Mode (runlevel 3) after Kernel 2.6.7 Upgrade tsales314 Linux - Laptop and Netbook 4 08-31-2004 02:06 AM
Empty terminal [command line] with no text after kernel upgrade to 2.6.7 whencat Red Hat 7 07-09-2004 03:59 PM
Kernel 2.6.5 - how do I get this thing to support higher res console text? xanas3712 Linux - Newbie 4 05-10-2004 02:41 PM
(here's a challenge) VGA text console modes with a new kernel. ftgow Linux - Hardware 9 02-12-2004 02:08 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:34 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration