-   Slackware (
-   -   Kernel 2.4.23 compile causes kernel panics on ATA RAID-1 (mirror) array (

Raptor Ramjet 12-15-2003 07:20 AM

Kernel 2.4.23 compile causes kernel panics on ATA RAID-1 (mirror) array

I have a Slackware 9.1. system installed on a RAID-1 array (mirror) on a highpoint HPT372 controller.

Yesterday I used swaret to update my system and decided that, in a spirit of experimentation, I'd comment out the "EXCLUDE = kernel, Lilo" line whilst doing so (I though it was about time I started learning about kernel upgrades etc.)

Sadly however the new 2.4.23 kernel that was installed now kernel panics on boot up as it can't find my root file system and suggests I append a correct "root=" option. (This is despite the boot messages including entries showing that my RAID array was "speed tested" succesfully)

I therefore tried using the "kernel compiling guide for newbies" thread and recompiled the 2.4.23 kernel from source. Whilst doing so I went through the options and made sure that RAID support was included but this sadly has made no difference.

I have also checked my Lilo configuration and reinstalled it to the MBR but this didn't help either.

I was therefore wondering if anyone could tell me what the differences are between the way the "bare" and "ataraid.i" kernels supplied on the Slackware CD are compiled ? i.e. what specific settiongs should I be making when doing a kernel compile so that I produce an "ataraid.i" style version of the 2.4.23 kernel ?

Failing this could I recover my system by simply replacing the current /boot/vmlinuz file with the one from my boot floppy (which is the 2.4.22 "ataraid.i" kernel) ?

Or should I simply take this opportunity to try using a 2.6 kernel image instead ?

Any advice gratefully received as my box was working beautifully before this update !

Raptor Ramjet 12-18-2003 05:22 AM

O.K. nobody wished to help with that....

So I've now also tried compiling the new 2.6 kernel and this didn't help either as the kernel still panics when attempting to access my RAID array.

So can anyone advise me how I can get a working kernel back that can talk to an ATA RAID-1 array on a highpoint 372 controller ? Other than making sure that ATA RAID support is enabled in "make menuconfig" (I specified that all RAID options should be "built in") is there something fundamental I'm missing ?

Raptor Ramjet 12-18-2003 12:29 PM

oh well, please close this thread as I took the big bang approach and reinstalled everything from scratch.

gargamel 12-18-2003 01:40 PM

It wouldn't have helped even if I had posted this before you asked for closing the thread, but...
... I have the same problem on a non-RAID system!

I've started two threads because I am unable to use Slackware using the disk images of Slackware-current (post 9.1). My network adapter is not detected --- it works with 9.1 stable disks. So I thought I could fix it with a customized boot disk, with pcmcia and network support in the self-compiled kernel. But with that I get exactly the same error message you mention.

Unfortunately I can't help, I can just share your pain...


All times are GMT -5. The time now is 10:02 PM.