LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-15-2008, 07:43 AM   #1
raixun
LQ Newbie
 
Registered: Jun 2008
Location: Istanbul
Distribution: slackware
Posts: 22

Rep: Reputation: 15
KDM: no sound, lm-sensors: error, bootloader


hi all i have some problem with slack

1) i use slackware 12.1 wth default kernel.if i start x with "$ startx" command That is well i can listen music but if i start with "# kdm" soundcard doesnt work i cannot listen something:S

2) i installed lm-sensors later do configure with "sensor-detect" but When i start sensors i get below error:

-------------------
$ sensors
No sensors found!
Make sure you loaded all the kernel drivers you need.
Try sensors-detect to find out which these are.
---------------------

3) When my computer bootting. default boot loader is FreeBSD's boot loader but i want it start with Slackware's boot loader LILO therefore What must i ?
 
Old 06-15-2008, 08:10 AM   #2
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,366

Rep: Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835
Quote:
Originally Posted by raixun
1) i use slackware 12.1 wth default kernel.if i start x with "$ startx" command That is well i can listen music but if i start with "# kdm" soundcard doesnt work i cannot listen something:S
Add your user to the audio, cdrom, plugdev and video groups (the audio group is the culprit here, but the other groups are important for other reasons). You can accomplish this with the following:
Code:
gpasswd -a username group
You will have to log out and back in for the changes to take effect.
Quote:
Originally Posted by raixun
2) i installed lm-sensors later do configure with "sensor-detect" but When i start sensors i get below error:

-------------------
$ sensors
No sensors found!
Make sure you loaded all the kernel drivers you need.
Try sensors-detect to find out which these are.
---------------------
When you run sensors-detect, it should output a list of modules that must be loaded. You should add these modules to /etc/rc.d/rc/modules-$(uname -r), which is /etc/rc.d/rc.modules-2.6.24.5-smp in a default setup. You could also try manually loading the modules using `modprobe module` and then running sensors. It should be noted, however, that lm-sensors is already included with Slackware by default, so I'm hoping you installed the official package instead of compiling from source or some such thing.
Quote:
Originally Posted by raixun
3) When my computer bootting. default boot loader is FreeBSD's boot loader but i want it start with Slackware's boot loader LILO therefore What must i ?
You should run `liloconfig` as root to setup LILO. You should probably choose the expert mode to ensure that everything is correct. If it fails, then you can edit /etc/lilo.conf manually and run `/sbin/lilo` afterwards to write the changes to the MBR. Search the forums for more information on editing lilo.conf.
 
Old 06-15-2008, 08:11 AM   #3
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 210Reputation: 210Reputation: 210
Quote:
Originally Posted by raixun;31852272)
..i installed lm-sensors later do configure with "sensor-detect"
If this is what you typed, it should be sensors-detect. If you are successfull you should go through a configure procedure.

Last edited by {BBI}Nexus{BBI}; 06-15-2008 at 08:15 AM.
 
Old 06-15-2008, 03:28 PM   #4
raixun
LQ Newbie
 
Registered: Jun 2008
Location: Istanbul
Distribution: slackware
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by T3slider View Post
Add your user to the audio, cdrom, plugdev and video groups (the audio group is the culprit here, but the other groups are important for other reasons). You can accomplish this with the following:
Code:
gpasswd -a username group
You will have to log out and back in for the changes to take effect.
i write to shell as root

$ gpasswd -a raixun root
Adding user raixun to group root
$
but i cannot enable sound i couldnt accomplish that =(

other problems been solved thank u


Quote:
Originally Posted by {BBI}Nexus{BBI} View Post
If this is what you typed, it should be sensors-detect. If you are successfull you should go through a configure procedure.
i writed # sensors-detect and echo "YES" to all qiestions
sorry my englsh is not good i sometimes can use false words

Last edited by raixun; 06-21-2008 at 05:22 AM.
 
Old 06-15-2008, 03:44 PM   #5
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,366

Rep: Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835
Quote:
Originally Posted by raixun
i write to shell as root

$ gpasswd -a raixun root
Adding user xunivin to group root
$
but i cannot enable sound i couldnt accomplish that =(
The correct command would have been
Code:
# gpasswd -a raixun audio
# gpasswd -a raixun video
# gpasswd -a raixun cdrom
# gpasswd -a raixun plugdev
 
Old 06-15-2008, 04:04 PM   #6
raixun
LQ Newbie
 
Registered: Jun 2008
Location: Istanbul
Distribution: slackware
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by T3slider View Post
The correct command would have been
Code:
# gpasswd -a raixun audio
# gpasswd -a raixun video
# gpasswd -a raixun cdrom
# gpasswd -a raixun plugdev
again thank u !!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
need help with lm-sensors and sensors-applet in gnome fakie_flip Linux - Hardware 5 07-15-2007 03:00 PM
Conky - sensors-detect > modprobe i2c-nforce2 > WARNING: Error inserting i2c_core... macroron Slackware 2 07-12-2007 04:10 PM
Error on KDM tytower MEPIS 1 01-11-2007 05:06 AM
GNOME Sensors Applet says NO SENSORS FOUND! badgerbox76 Linux - Newbie 2 12-24-2005 12:58 PM
Problem with lm sensors, everything works but that damn beep sound objorkum Linux - Software 0 01-07-2004 04:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration