-   Slackware (
-   -   KDM does not allow xfce to shutdown (

trryhend 03-18-2011 10:46 AM

KDM does not allow xfce to shutdown
OS = Slackware 13.1
I'm normally a KDE user but tried xfce4 and found that it works nicely. I wanted to switch to it for a while.

I did find one particular problem:
When you try and end the session, you can Log Out but can not Restart or Shutdown. If you click on Restart or Shutdown it asks for password. Even after entering a valid password, it will not allow the action. (I tried user and root's passwords.) It says "Please enter your password." After entering the password it says, "Either the password you entered is invalid, or the system administrator disallows shutting down this computer with your user account."
(Before you ask; my user is in power group.)

I tinkered with it for a while and decided it must have something to do with KDM and so I switched my default runlevel to 3 and started xfce4 [via startx] and it worked as expected.

Next I tried using xdm instead of kdm and YES, it works as expected. I was able to Restart or Shutdown (no asking for password, it just does it.)

So; What is it about KDM that does not allow xfce4 to restart or shutdown?

BTW, it seems to work ok in -current, (or at least, someone who uses -current told me that he was able to shutdown or restart from xfce4 and he said that he was indeed running kdm). So it's apparently been fixed in our future release... so, again, what is it about kdm that is causing this anomily? Curious...

dive 03-18-2011 12:34 PM

Which groups are you in? You need to be in power group for this to work usually.

trryhend 03-19-2011 06:06 PM

Yes, I'm in power group.

Any other suggestion(s)?

hitest 03-19-2011 06:26 PM

What other groups is your regular user a member of? I don't need a password to shutdown XFce from KDM; it works just fine here.

Erik_FL 03-21-2011 07:52 PM

XFCE uses a helper program to shut down or restart the system. You must add the helper program to the "/etc/sudoers" file.

Edit the file "/etc/sudoers" and add the following lines.


# Shutdown from XFCE4
%users        ALL=(root) NOPASSWD: /usr/libexec/xfsm-shutdown-helper

I made the change on my system and can shut down or restart from XFCE4.

bmanth60 05-01-2011 05:40 PM

Hi Erik_FL,

Thank you so much for the post, I was working with SLiM and had the same problem!


lpallard 09-24-2011 11:54 PM

Dont mean to high jack this thread but I just got the same problem on Slack 13.37 and googling brought me here...

After several months running 13.1 and upgraded to 13.37 about 3 months ago, I just started a few days ago to have this problem. I am not sure why after 28-36 months its happening... I get this error when I try to Suspend to RAM. It usually works. I know that if I reboot the problem will go away, but will come back at some point...

Anyways, adding


# Shutdown from XFCE4
%users ALL=(root) NOPASSWD: /usr/libexec/xfsm-shutdown-helper
to /etc/sudoers generates a new problem. I get an error message saying:


Failed to suspend session

Suspend and Hibernate are only supported through HAL, which is unavailable

lpallard 09-25-2011 08:37 PM

I just tried to put my machine in suspend to RAM, and it worked. Really some kind of bug. Anyone has a clue hoe to pinpoint the problem?

All times are GMT -5. The time now is 12:35 PM.