-   Slackware (
-   -   KDE4 issues on intel 845G integrated graphics (slackware 13.0 x86) (

agentdcooper 11-12-2009 04:48 AM

KDE4 issues on intel 845G integrated graphics (slackware 13.0 x86)
3 Attachment(s)
I want to post this question as seperate from the intel xorg issues being reported and troubleshot in this thread = [TESTING REQUEST] Xorg in -current (yes, again) as I am thinking this issue is more KDE4-centric/KDE4-related. I have an ancient dell inspiron 1100 laptop running an "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device". the trouble I am reporting here is that upon loading KDE 4.2.4 that comes with slackware 13.0 x86 DVD (or the newer KDE from slackware-current, I've tried them both - but currently have reverted back to a fresh install) the intro/splash screen is displayed with black and white bubbles, and a KDE 4 icon bar that flashes up each icon until it gets to the KDE one, then upon a normal startup of KDE4 I would see the splash-screen transition to a desktop background... but on my fubar'd laptop the splash-screen disappears completely to a black-background, and KDE continues to boot up... hitting the hard drive, with the HDD LED flashing, and a couple onscreen indicators that akonadi started, then suspended (for some unknown reason?), all the while the KDE startup music is playing... after all this completes, I am left with a black background. I always thought I was dead in the water here... just stuck, only my mouse arrow is shown, I can move it all around, but clicking on everything, typing on keyboard... nothing works -- OR SO I THOUGHT! I just found out that I can issue some keyboard shortcuts!

now mind you that it took me a lot of haggaling to get THIS FAR... first off, slackware 13.0 x86 DVD installs xf86-video-intel-2.8.0 by default, I found that starting KDE would just black-screen, and do jack to begin with. I have been working on this laptop + Xorg and the intel drivers since the day slackware 13 was released - my current winning combination is slackware 13.0 x86 DVD fresh install, and upgrading to libdrm-2.4.15-i486-1, mesa-7.6-i486-1, xf86-video-intel-2.9.1-i486-1 (using slightly modified slackbuild scripts from each respective /source directory on the slackware 13 DVD), and lastly running a custom 2.6.32-rc6-zen1 "Haec verba audi - vitam aeternam" zen kernel. I can run all other window managers perfectly now, without this combination I get nasty screen tears, icons with lines thru them, unreadable fonts, and a whole slew of crap. xfce, black box, window maker, fluxbox, they all run perfect now... except KDE4.x!

so I started to mess around and found that pushing ALT+F1 brings up the start menu! in a really weird location?? but it is navigatable... I am noticing EVERY window I open get opened all squished up in the top-left-hand corner (the LAST image attached to this message is EXACTLY what I see for every window launched, except for the startmenu - they get stuck in the top-left hand corner of the screen, and I have to strech them out to view and work with any window or application I run)... I have screenshots (luckilly printscreen in KDE4 lets me save screenshots to convery to you wtf is going on! hah) no matter how many windows I bring up I cannot ALT+TAB them, it just doesnt let me. thankfully I can access the KDE4 SYSTEM SETTINGS from the the start menu shortcut ALT+F1. going to DISPLAY section I find something troubling ;

the SCREEN AND ORIENTATION's VGA and LVDS sections are all grey'd out! I cant select anything, no resolution changes, nothing! I find that I can goto the screensavers and run GL screensavers in TEST mode just fine, GLmatrix works great =) desktop effects are OFF.

I cant for the life of me figure this out, I hope it is fixable! does anyone have suggestions on how I can remedy this issue that only is occuring with KDE4?

I attached images to this message to help explain what I see on my screen...
my Xorg.0.log =>
my glxinfo output =>

anything else one may need? I get the same problem with xorg.conf and without btw.
...thanks, sorry for the long post...

agentdcooper 11-13-2009 06:45 PM

after reading dolphin77's excellent radeon KMS post, I've decided to give intel KMS a go, to see if it will handle KDE4 any different -- in the meantime, if anyone has any help feel free to post. I will update with my findings soon. time for a new slack13 install on this laptop (I like starting fresh) =)

agentdcooper 11-23-2009 11:00 PM

just a little update here... my situation still remains, after many days of troubleshooting I've come to this conclusion;
- intel i915 drivers are the ones to use for intel KMS & framebuffer, just adding the following to lilo.conf enables this ;;

append = "i915.modeset=1"
- no matter what combination of kernel (and/or zen patches), libdrm, mesa I use I get the SAME results in KDE4 (trying the latest of each branch required me to update to newer util-macros version).
- I've gone so far as booting other distro's, and the list is quite long... the latest archlinux-testing distro seems to be the one with brand-spanking new/bleeding-edge packages and still I get same issues in it. even the new [9.10] kunbuntu running KDE4 gives me the same results in KDE4 as listed above.

so, I strictly believe this issue to be related to KDE4, as no matter which distro I run, all other window managers work great - it's just KDE4 that is fubar [as described in my first post above].

I will continue to mess with this, but as far as things go I am sticking with KDE 3.5, as it is the ONLY KDE solution for this intel 845G video hardware at this time.

if anyone out there has suggestions, feel free to post here... till next time :banghead:

PS: as far as raw framerates and performance with the intel 845G :: my favorite combination now is slackware-current, linux 2.6.32-rc8 with zen patch, latest libdrm/mesa/util-macros, and enabling KMS with i915 drivers. xfce has become my fav in the absence of KDE4.

All times are GMT -5. The time now is 04:47 PM.