-   Slackware (
-   -   kde won't start after update to 3.2.3 (

phase9 06-15-2004 01:30 PM

kde won't start after update to 3.2.3

After an upgrad from kde-3.2.1 to kde-3.2.3 (from, kde doesn't start any longer.

After "startx" on the terminal, the X-server seems to start, then there comes the error message in a window:

"Could not start kdeinit. Check your installation"

On the terminal are additional error messages like "... opt/kde/lib/ undefined symbols ..."

Any ideas?

yelo 06-15-2004 03:07 PM

Did you upgrade ALL of kde? I mean, by downloading ALL the kde* packages(like kdemultimedia, kdegames, kdeadmin,etc...?

it should be SEVERAL packages that you have to upgrade, all by running upgradepkg on.

320mb 06-15-2004 04:52 PM

make sure you have the current packages of QT and Quanta

1351 06-15-2004 05:54 PM

If you upgraded using Swaret, it seems that the dependency check is a little broken.
I got exactly the same error as you when I upgraded, and finally tracked it down to the fam-2.7.0 package, which was required, but had not been installed with the rest of the upgrade. After downloading the missing package, KDE worked fine for me.

If it's not that specific problem that you're experiencing, I'd be prepared to wager that it's a similar missing dependency issue,

phase9 06-16-2004 11:53 AM


I have upgrade all kde packages (kde*, arts, qt, lcms, taglib) with upgradepkg. Unstalling (pkgtool) and then installing (installpkg) them gave the same error.
fam-2.7.0-i686-1 is installed.
I have not used swaret.

Still some ideas?

1351 06-16-2004 12:30 PM

Check your X log files, in /var/log . They may shed a little more light on your problem by providing more specific error messages. If you're using XFree, the log file will be /var/log/XFree86.0.log, and if you're using Xorg the file will be /var/log/Xorg.0.log

It does sound like a missing library of some description... I'm admittedly stabbing in the dark here, but perhaps you need a more recent version of QT?

phase9 06-16-2004 03:15 PM


A look into /var/log/XFree86.0.log does't help.

I'm using the QT version shipped with kde-3.2.3 from

It seems I must stay with kde-3.2.1 and wait for the next version to come.

thegeekster 06-16-2004 10:28 PM

What does the ~/.xsession-errors file say?.........

Also, have you deleted the temp files used by KDE(~/.DCOP-* /tmp/ksocket-*)..............Log out of the KDE and into the console as root, then delete those files, including all the hidden .DCOP files in all user's directories..................Sometimes those files and directories can cause some heartache...................They will be recreated as soon as KDE is started again.... :)

phase9 06-17-2004 11:49 AM


In ~/.xsession-errors aren't any error messages. In fact, after renaming it, it wasn't even created anew.

Deleting the content of /tmp and /var/tmp and ~/.DCOP* files didn't change anything.

The only errors (tty1) I get are those relocation errors of /opt/kde/lib/ and "Error: Can't contact kdeinit!"


thegeekster 06-17-2004 12:53 PM

Both kdeinit (/opt/kde/bin/kdeinit) and the lib file,, are part of the kdelibs pkg...................that library file is actually a symlink for /opt/kde/lib/ might want to check to make sure points to and they both exist............

Offhand, it sounds like something is wrong with the kdelibs installation........???

Carpo 06-18-2004 06:13 AM

i had the same prob - i solved it by uninstalling QT,Quanta and ALL kde packages, then i just reinstalled the new kde packages using installpkg *.tgz from kde folder. :)

phase9 06-19-2004 05:31 AM


I checked the symlinks, they do exist.
I thought allready about a broken download of kdelibs, but downloading it again from a different source didn't help.

I did both ways: removing/installing and upgrading.

Sorry that didn't work, but thanks for your tries.

reddazz 06-19-2004 11:50 AM

I had the same problem and the solution was to remove the qt package from the kde site and use swaret to install the qt packages from Slackware. Like someone mentioned you may also have to remove all kde packages and reinstall.

little_ball 06-19-2004 04:18 PM

I did had the same problem too, when I try to upgrade kde 3.2.1 to KDE 3.2.3 from I uninstall and reinstall everything once and again, including QT3, and still have the same problem with kdeinit not found and KDE wonīt start. So Iīm not saying this would work, but I uninstall all KDE download KDE 3.2.3 from current, even qt3 from current, delete all symlinks of KDE folder in my home. (even I delete /opt/kde manually) then I did installpkg and startx and KDE 3.2.3 work fine. I think the reason of this error is cause kde 3.2.3 packages from are a little mess up or I donīt know, but I couldnīt resolved it so I download KDE 3.2.3 of current to my slack 9.1 and that did work nice.

thegeekster 06-19-2004 07:30 PM

I think reddazz and little_ball may be on to something.................about using the QT pkg from the same download site with the KDE pkgs...........kdelibs depends on both QT and arts when compiling, so you will need the same pkgs of both that were used when the kdelibs pkg was built...............In other words, along with using the same QT pkg, also use the same Arts pkg from the same site KDE was downloaded from..........

All times are GMT -5. The time now is 03:29 AM.