LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-28-2013, 03:33 PM   #1
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Slackware 14; CentOS; Vyatta
Posts: 372

Rep: Reputation: 33
KDE / Thinkpad always starts with dimmed screen


After KDM login, my KDE desktop always starts dimmed to its minimum level, forcing me to hit Fn + [Brightness up] repeatedly to raise it to normal level.

I've tried changing every setting I can find in systemsettings to try to overwrite a misconfiguration or something but nothing seems to make a difference. So, where is the startup setting set? In KDE config files I assume but where?

Cheers
 
Old 06-28-2013, 07:24 PM   #2
WhiteHotLoveTiger
Member
 
Registered: Jun 2012
Location: NB, Canada
Distribution: Slackware
Posts: 71

Rep: Reputation: 2
I'm not sure where the startup config settings are, but is the behaviour consistent whether you're plugged in or on battery power?
 
Old 06-28-2013, 09:30 PM   #3
Grischuna
Member
 
Registered: Mar 2009
Distribution: Slackware64 14.0 multilib
Posts: 44

Rep: Reputation: 0
Quote:
Originally Posted by spoovy View Post
After KDM login, my KDE desktop always starts dimmed to its minimum level, forcing me to hit Fn + [Brightness up] repeatedly to raise it to normal level.

I've tried changing every setting I can find in systemsettings to try to overwrite a misconfiguration or something but nothing seems to make a difference. So, where is the startup setting set? In KDE config files I assume but where?

Cheers
Have you tried to right click on your battery icon in the task manager and then choose 'Power Settings'. There inside you can set the brightness level for AC power, on battery, etc.

Same can be found in the KDE system settings under 'power management'.

Cheers
 
Old 06-29-2013, 08:00 AM   #4
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Slackware 14; CentOS; Vyatta
Posts: 372

Original Poster
Rep: Reputation: 33
Yes it's consistent across power sources.

Yes I've tried changing all system settings that relate to screen brightness; with no joy
 
Old 06-29-2013, 02:41 PM   #5
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + Xmonad
Posts: 299

Rep: Reputation: 95
Sounds to me like a BIOS setting. I know that kernel 3.2.45 "listens" to the BIOS
better than 2.6.37 does (which is a bad thing IMO).
Check your "screen brightness" setting in your BIOS.
The fact that you don't see the dimming until AFTER login might simply mean that since
KDE isn't fully up, that it, through the kernel, isn't yet taking cues from the BIOS.
 
Old 06-29-2013, 04:19 PM   #6
Grischuna
Member
 
Registered: Mar 2009
Distribution: Slackware64 14.0 multilib
Posts: 44

Rep: Reputation: 0
Quote:
Originally Posted by spoovy View Post
Yes it's consistent across power sources.

Yes I've tried changing all system settings that relate to screen brightness; with no joy
May be 'stupid' to ask but you have checked the box as seen in the attachment?

Cheers
Attached Images
File Type: jpeg brightness.jpeg (25.5 KB, 16 views)
 
Old 06-30-2013, 10:42 AM   #7
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Slackware 14; CentOS; Vyatta
Posts: 372

Original Poster
Rep: Reputation: 33
Thanks Grischuna but yes I tried all the brightness settings!

I never though it could be a BIOS thing though; I'll check that out.
 
Old 06-30-2013, 10:49 AM   #8
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Slackware 14; CentOS; Vyatta
Posts: 372

Original Poster
Rep: Reputation: 33
Nope nothing in BIOS related to screen brightness.
 
Old 06-30-2013, 01:39 PM   #9
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
You can take a look at the /sys/class/backlight/acpi_video0/ directory. There are files for "actual_brighness", "brightness" and "max_brightness". On my Thinkpad max_brightness=15, you could put a line into your /etc/rc.d/rc.local
Code:
echo 12 > /sys/class/backlight/acpi_video0/brightness
which sets your brightness to 12 at systemstart. You can check the brightness with
Code:
cat /sys/class/backlight/acpi_video0/actual_brightness
Markus

Last edited by markush; 07-01-2013 at 11:10 AM.
 
Old 07-01-2013, 11:04 AM   #10
Kallaste
Member
 
Registered: Nov 2011
Distribution: Slackware
Posts: 345

Rep: Reputation: 84
Quote:
Originally Posted by markush View Post
You can take a look at the /sys/class/backlight/acpi_video0/ directory. There are files for "actual_brighness", "brightness" and "max_brightness". On my Thinkpad max_brightness=15, you could put a line into your /etc/rc.d/rc.local
Code:
echo 12 /sys/class/backlight/acpi_video0/brightness
which sets your brightness to 12 at systemstart. You can check the brightness with
Code:
cat /sys/class/backlight/acpi_video0/actual_brightness
Markus
Markus made a typo. That should actually be

Code:
echo 12 > /sys/class/backlight/acpi_video0/brightness
Also worth mentioning that computers are different here, and the /sys/class/backlight/acpi_video0 directory may not be the right one. My Asus Zenbook has two directories under /sys/class/backlight: acpi_video0 and intel_backlight. Both directories have a "brightness" file. But to affect the setting, the one in intel_brighness is the one I need to alter.
 
1 members found this post helpful.
Old 07-01-2013, 11:11 AM   #11
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Hi BloomingNutria, thanks for the hint, I've changed the typo

Here it's a Lenovo Thinkpad x100e and I suppose the path should be correct. But if it's not, it's relatively easy to find the correct one (we're Slackware-users as you know )

Markus

Last edited by markush; 07-01-2013 at 11:12 AM.
 
Old 07-01-2013, 04:16 PM   #12
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Slackware 14; CentOS; Vyatta
Posts: 372

Original Poster
Rep: Reputation: 33
Ah; good idea but no joy unfortunately! I changed the setting (exact same file structure on my Thinkpad T420 btw), from 9 to 13 which seemed to make the screen brighter on inital boot, while in console up to and including KDM screen, but as soon as I get to the actual desktop it's dropped back low again. It's something KDM/KDE is doing I reckon.
 
Old 07-01-2013, 04:54 PM   #13
Kallaste
Member
 
Registered: Nov 2011
Distribution: Slackware
Posts: 345

Rep: Reputation: 84
What does
Code:
cat /sys/class/backlight/acpi_video0/actual_brightness
show in KDE? Is it showing that the brightness has been turned down?

I don't use KDE myself, but I think you may be able to change it in System Settings -> Power Management -> Power Profiles. If not, then see if you have a /usr/share/config/kdm/Xsetup file. If so, then you might like to add an xbacklight command such as
Code:
xbacklight -inc 20
or similar to this file and see if that helps.

Last edited by Kallaste; 07-01-2013 at 04:57 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
When I exit X, dislpay is dimmed ... Alexvader Slackware 9 10-21-2009 06:29 PM
Screen corrupted when X starts SUSE 10 floyd Suse/Novell 3 12-17-2005 07:51 AM
DHCP dimmed out virtualme Linux - Newbie 1 02-12-2005 08:41 AM
Scorched 3D starts but then has a blank screen rpbarlow Linux - Games 0 12-24-2004 10:36 PM
KDE starts with fuzzy screen... SiCkness Linux - Newbie 1 10-02-2004 02:57 AM


All times are GMT -5. The time now is 11:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration