-   Slackware (
-   -   kde/qt instalation has no icons to dialogs (

rudsonalves 07-16-2009 03:41 PM

kde/qt instalation has no icons to dialogs

I'm running a PyQt application in a Slackware64 (current release) and saw that the QMessageBox class don't show me the icons. The same happens with Slackware-current.

In the Slackware 12.0 the icons appear.

The test code can be downloaded from the

Someone can help?

bgeddy 07-16-2009 07:54 PM

Yes - I've noticed this with PyQt4. Try changing KDE's settings. Goto System Settings->Appearance->Style and change Widget Style to Plastique or CleanLooks. It should then show your icons with the message boxes.

rudsonalves 07-17-2009 10:47 AM

Yes Bgeddy.

But I tried with Kubuntu and icons appeared normally. I compared the folder /usr/share/icons of the Slackware and Kubuntu and saw that have more icons in the Slackware, which means there is no lack of icon, but perhaps some configuration to compile KDE, Qt and PyQt.

bgeddy 07-17-2009 12:15 PM

Hmm - I have just tried this on Kubuntu as, as you say, the icons appear for the "Oxygen" widget style whereas they don't on Slackware current.

Looking at the directories /usr/share/icons/oxygen/{8x8,16x16,22x22,32x32,48x48,128x128,scalable}} it looks like the all the icons are there in Slackware.

Very odd. I must admit that I don't know the ins and outs of a KDE4 build or in fact exactly how all the components are inter-related i.e. icons and dialogs in the component packages. I must admit it's very strange though. I always thought it was a bug in KDE till you pointed out this works in Kubuntu. Thanks for that.

bgeddy 07-17-2009 01:37 PM

I just tried specifically setting the messagebox icon with this change to your code :

def critical_button_clicked(self):
        print "Critical pressed..."
        msg = QMessageBox(self)

This worked in the Oxygen widget style setting of KDE4 so it must have something odd going on in the build of QT/KDE or perhaps the PyQT4 package of Slackware as it works in Kubuntu. It may be worth reporting this to Pat as that's the idea of current in the first place !

OK - I wouldn't report it to Pat just yet. I just tried the same thing in OpenSuse and I couldn't get any icons to display under any widget style setting whatsoever! Possibly a KDE bug after all. Maybe Kubuntu has fixed this or applied some update.

All times are GMT -5. The time now is 01:03 PM.