-   Slackware (
-   -   kde problem on first startx (

sknowonweb 04-27-2006 11:50 AM

kde problem on first startx
Hello friends
I am running slackware 10.2 with KDE bundled with that CD .
Recently iinstalled a TTF font for my locale . after that , whenever i start the computer and issue a startx command , KDE fails to start indicating bad font path/element and some more messages on screen.
But the strange fact is KDE starts the second time i gave a startx command .
I tried this after many reboots and the problem is same.first time KDE never starts. whats the probleme pals ? .

P S :) i tried to grab that xorg message just before KDE startsto save in a file , but how to do it.If u guide me i can post what the exact error it states

Thank u pals

dcdbutler 04-27-2006 11:56 AM

The X log should be in

sknowonweb 04-27-2006 12:09 PM

Hello freinds :
I am posting my error xorg.log , thanx dcdbutler.
I shortened it as forum rules restricts me


_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/sathish:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.13 i686 [ELF]
Current Operating System: Linux sathish 2.4.31 #6 Sun Jun 5 19:04:47 PDT 2005 i686
Build Date: 11 September 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 27 22:36:07 2006
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout " Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/TTF/,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/CID/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(**) ModulePath set to "/usr/X11R6/lib/modules"
(WW) Open APM failed (/dev/apm_bios) (No such device)
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.2
X.Org Video Driver: 0.7
X.Org XInput driver : 0.4
X.Org Server Extension : 0.2
X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
ABI class: X.Org Video Driver, version 0.7
(--) using VT number 7


(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(**) Option "Protocol" "auto"
(**) Mouse0: Device: "/dev/mouse"
(**) Mouse0: Protocol: "auto"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/mouse"
(**) Option "Buttons" "5"
(==) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 5
(**) Option "CoreKeyboard"
(**) Keyboard0: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) Keyboard0: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(--) Mouse0: PnP-detected protocol: "ImPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
(II) I810(0): Display plane A is enabled and connected to Pipe A.
(II) I810(0): Enabling plane A.
(II) I810(0): Display plane A is now enabled and connected to Pipe A.
(II) I810(0): PIPEACONF is 0x80000000
(II) I810(0): Mode bandwidth is 66 Mpixel/s
(II) I810(0): maxBandwidth is 640 Mbyte/s, pipe bandwidths are 184 Mbyte/s, 0 Mbyte/s
(WW) I810(0): Extended BIOS function 0x5f61 not supported.
SetClientVersion: 0 8
(WW) I810(0): Setting the original video mode instead of restoring
the saved state
(WW) I810(0): Successfully set original devices
(II) I810(0): xf86UnbindGARTMemory: unbind key 4
(II) I810(0): xf86UnbindGARTMemory: unbind key 0
(II) I810(0): xf86UnbindGARTMemory: unbind key 1
(II) I810(0): xf86UnbindGARTMemory: unbind key 3
(II) I810(0): xf86UnbindGARTMemory: unbind key 2

tobyl 04-27-2006 02:47 PM

did you make other changes or just installed a font?

bad font path/element is not ideal, but i have not known it to stop kde from starting

can you uninstall the font to be sure that is the cause?


sknowonweb 04-28-2006 09:28 AM

hello tobyl,
I am not sure that font causes the problem. But i am sure this thing happen only after i installed that font .
Actually i copied that font to /usr/x11r6/lib/x11/fonts/ and typed mkfontscale and mkfontdir . Is thatwrong means to install a font .

Actually i don know hoe to uninstall a font , do i just delete that font .
Then freinds what is that xf86unbindgartmemory:unbind key #'s
i smell that thing holds responsible for this prob.

tobyl 04-28-2006 01:53 PM

Could you give the name of the graphics chipset, just to make sure the right driver is being loaded.

Also, what resolution are you using? If it is high, eg 1280x1024 or more, try reducing it, as a test,
to see if that makes any difference.
I must admit I dont uninstall fonts much either but I guess you could just delete it and rerun
mkfontscale and mkfontdir on that dir (I think these commands wont affect TTF in kde, but will affect non fontconfig enabled apps)
the other necessary stuff will happen when you reboot.

This line bothers me
(WW) I810(0): Setting the original video mode instead of restoring
the saved state

I think this is the key, does it not imply that the wrong video mode is being attempted first time around?

I would only make one change at a time though, then if the fault clears, you will have a better understanding of what was the cause


tobyl 04-28-2006 02:35 PM

I've been googling this problem for you. My guess is that it is a laptop with a graphics chipset that uses shared memory.
Intel 855GM, 845 or 865 embedded graphics are the usual suspects. If this is the case, find out if there is a newer bios
version for your machine, as this appears to fix a problem with lack of video memory in many cases...

also make sure dri is enabled in your xorg.conf. I also read that setting VideoRam to the desired value in the Section "Device"
in this file can help

of course I could be barking up the wrong tree (english idiom)


sknowonweb 04-28-2006 11:43 PM

Hello Mr Tobyl,
I deleted the font and restarted my PC . This time KDE starts fine at first try .
Mine is a intel 845 GBV Motherboard with inbuilt 64 MB ram .
DRI is disabled in a warning message ,

(II) Loading extension XFree86-DRI
(EE) I810(0): [dri] DRIScreenInit failed. Disabling DRI.
I cant find the video memory section in logfile .
I think but the following section has some usefull info .(Actually its from a successful attemp file log

(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/X11R6/lib/modules/linux/libint10.a
(II) I810(0): initializing int10
(WW) I810(0): Bad V_BIOS checksum
(II) I810(0): Primary V_BIOS segment is: 0xc000
(II) I810(0): VESA BIOS detected
(II) I810(0): VESA VBE Version 3.0
(II) I810(0): VESA VBE Total Mem: 832 kB
(II) I810(0): VESA VBE OEM: Brookdale-G Graphics Chip Accelerated VGA BIOS
(II) I810(0): VESA VBE OEM Software Rev: 1.0
(II) I810(0): VESA VBE OEM Vendor: Intel Corporation
(II) I810(0): VESA VBE OEM Product: Brookdale-G Graphics Controller
(II) I810(0): VESA VBE OEM Product Rev: Hardware Version 0.0
(II) I810(0): Before: SWF1 is 0x00000101
(II) I810(0): After: SWF1 is 0x00000108
(==) I810(0): Default visual is TrueColor
(II) I810(0): Allocated 128 kB for the ring buffer at 0x0
(II) I810(0): Allocating at least 384 scanlines for pixmap cache
(II) I810(0): Initial framebuffer allocation size: 5632 kByte
(II) I810(0): Allocated 4 kB for HW cursor at 0x7fff000
(II) I810(0): Allocated 16 kB for HW (ARGB) cursor at 0x7ffb000
(II) I810(0): Allocated 4 kB for Overlay registers at 0x7ffa000 (0x0adb1000).
(II) I810(0): Allocated 64 kB for the scratch buffer at 0x7fea000
But any how it solves that .
Thanks for ur concern .
Have a nice Day

tobyl 04-29-2006 06:07 AM

I'm glad its working better for you.
Your video settings could probably be improved with a bit of work.
It is almost certainly related to how video memory is allocated by Xorg.
DRI is almost certainly being disabled due to lack of memory being allocated to the video device.

VideoRam 65536
in the device section of your xorg.conf is reported to help by some

if you do decide to investigate further, read here:

but if you are content, then leave things as they are.

All times are GMT -5. The time now is 09:15 PM.