LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-08-2016, 01:23 PM   #1
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,752

Rep: Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671
KDE does not honor my settings in ~/.Xresources. Why?


On Slackware64-14.2 with all patches applied, I have this in ~/.Xresources:
Code:
XTerm*background:#001b33
XTerm*foreground:white
In all WM/DE that can be set as default by xwmconfig, xterm gets a dark blue background but in KDE xterm has a white background.

However xinitrc.kde merges ~/.Xresources as do other xinitrc.* files.

I have no idea what changes that afterwards and didn't find a clue in /usr/bin/startkde at first look (maybe because my knowledge of KDE is null).

Any clue appreciated.
 
Old 11-08-2016, 01:38 PM   #2
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 774

Rep: Reputation: 587Reputation: 587Reputation: 587Reputation: 587Reputation: 587Reputation: 587
Hello,

Quote:
Originally Posted by Didier Spaier View Post
On Slackware64-14.2 with all patches applied, I have this in ~/.Xresources:
Code:
XTerm*background:#001b33
XTerm*foreground:white
In all WM/DE that can be set as default by xwmconfig, xterm gets a dark blue background but in KDE xterm has a white background.

However xinitrc.kde merges ~/.Xresources as do other xinitrc.* files.

I have no idea what changes that afterwards and didn't find a clue in /usr/bin/startkde at first look (maybe because my knowledge of KDE is null).

Any clue appreciated.
XTerm*<attr> does not work, but xterm*<attr> works. I use xterm*<attr> syntax, so, I don't know if this is a change or something else.

--
SeB
 
4 members found this post helpful.
Old 11-08-2016, 02:13 PM   #3
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,752

Original Poster
Rep: Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671
Merci encore, Sébastien!

You are right, and using only lower case letters works in all WM I tried.

Actually I wrote XTerm because it is spelled this way in "man xterm". Now that you make me think of it, I have read in some document (I can't remember which one right now) that XTerm is the old syntax and now only the first letter may be capitalized (Xterm), but the old syntax is still accepted to spare users the need to rewrite existing resource files. However Xterm doesn't work in KDE either, so I will keep xterm anyway.
 
Old 11-08-2016, 06:13 PM   #4
jmccue
Member
 
Registered: Nov 2008
Location: US
Distribution: slackware
Posts: 255

Rep: Reputation: 126Reputation: 126
Strange, this works for me
Quote:
XTerm*background: black
XTerm*foreground: green
But when using kde, my settings are ignored until I manually issue
Code:
xrdb -load ~/.Xdefaults
and that command exists in my ~/.xinitrc (I use run level 3).

What I did in the past was have a 'startup' script called by kde's startup/stop setup but when I rebuilt the system for 14.2 I have yet to fully setup kde for my use.

I wonder, do all your other ~/.Xresources work as expected ?

John
 
Old 11-08-2016, 06:29 PM   #5
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,752

Original Poster
Rep: Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671Reputation: 2671
@John: I have really few settings in ~/.Xresources.

To elaborate a bit: I am preparing the release of Slint-14.2 and want that users get an homogeneous look with all or at least most WM/DE included, regardless of the runlevel. They will also have the same default background of the root window and the same panel and similar root menu layouts in all WM.

Thus, doing something specific for a DE/WM is something that I try to avoid.

But I digress, sorry.
 
Old 11-08-2016, 08:22 PM   #6
Gerard Lally
Senior Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware, Crux, NetBSD
Posts: 1,306

Rep: Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774
Quote:
Originally Posted by jmccue View Post
Strange, this works for me


But when using kde, my settings are ignored until I manually issue
Code:
xrdb -load ~/.Xdefaults
and that command exists in my ~/.xinitrc (I use run level 3).

What I did in the past was have a 'startup' script called by kde's startup/stop setup but when I rebuilt the system for 14.2 I have yet to fully setup kde for my use.

I wonder, do all your other ~/.Xresources work as expected ?

John
The setting which causes this is System Settings > Application Appearance > Colours > Options > Apply colours to non-KDE4 applications.

This setting means xterm will have a white background if your KDE window background is white. You can turn this option off but it's a clumsy solution which affects all other non-KDE applications as well.

Last edited by Gerard Lally; 11-08-2016 at 08:23 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Plasma 5 not reading .Xresources Gerard Lally Slackware 1 08-04-2016 08:38 PM
migrate kontact/korganizer settings from KDE 3.5.9 to KDE 4.1 TheOneAndOnlySM Linux - Software 1 08-01-2008 11:49 AM
Gnome settings overriding KDE settings frode SUSE / openSUSE 2 04-21-2007 03:35 PM
Mandrake 10.0 Gnome/KDE Taskbar icon settings...are there settings? LiquidRezin Linux - Newbie 2 03-22-2004 10:27 AM
Why doesn't Gnome 2.4 pickup my Xresources settings? LinuxLuvr Slackware 5 01-13-2004 04:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration